Ubuntu 12.04.5 LTS 配置 Nodejs 环境-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

Ubuntu 12.04.5 LTS 配置 Nodejs 环境

首先下载 node-v5.12.0.tar.gz 这个版本nodejs
安装时提示 C++ compiler too old, need g++ 4.8 or clang++ 3.4 (CXX=g++)
查看g++版本 4.6.3
安装4.9版本并切换到该版本后提示 -bash: /usr/bin/gcc: No such file or directory(应该是我装的有问题,但不知如何解决)
网上看到有朋友说即使升级了g++的版本也有许多坑,推荐直接下载二进制包,然后设置环境变量
于是下载 node-v5.12.0-linux-x86.tar.gz 这个版本
解压缩后找到里面的 node 文件
提示 -bash: ./node: No such file or directory
请大家帮忙看下这个要怎么弄

展开
收起
阿硫比斯 2017-05-05 14:38:41 2659 0
1 条回答
写回答
取消 提交回答
  • dongshan8
    旺旺:nectar2。

    题主您好,

    相对来说,您现在使用的ubuntu版本是较老了,阿里云目前公共镜像里有16.04的,或许您可以先尝试在16.04的ubuntu系统里安装node-v5.12,看能否成功喔。

    2019-07-17 21:08:20
    赞同 展开评论 打赏
问答排行榜
最热
最新
相关电子书
更多
Debian GNU/Linux 安全合规之路
立即下载
CentOS Nginx PHP JAVA多语言镜像使用手册
立即下载
CentOS Nginx PHP JAVA 多语言镜像使用手
立即下载