HDU-1017,A Mathematical Curiosity

简介: HDU-1017,A Mathematical Curiosity

Problem Description:


Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.


This problem contains multiple test cases!


The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.


The output format consists of N output blocks. There is a blank line between output blocks.


Input:


You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.


Output:


For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.


Sample Input:


1


10 1


20 3


30 4


0 0


Sample Output:


Case 1: 2


Case 2: 4


Case 3: 5


解题思路:


这道题的题目读的我是真的蛋疼,服了,读了十几遍愣是没读懂,后来才明白题意是说:先输入一个数n,然后会分成n块输入,每块每次输入2个数n,m,n=m=0时结束,当a和b满足0<a<b<n且使(a^2+b^2 +m)/(ab) 的值为整数时,那么这对a和b就是一组,输出这样的组数,一行输入,跟着一行输出。下面我们看代码:↓↓↓


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
  int n,m,ans=0,num=0,t;
  cin>>t;
  while(t--)
  {
    while(cin>>n>>m&&n!=0)
    {
      for(int a=1;a<100;a++)
      {
        for(int b=a+1;b<n;b++)
        {
          if((a*a+b*b+m)%(a*b)==0)
            ans++;
        }
      }
      cout<<"Case "<<++num<<": "<<ans<<endl;
      ans=0;
    }
    num=0;
    if(t)
      cout<<endl;
  }
  return 0;
}


相关文章
UVa10484 - Divisibility of Factors(数论)
UVa10484 - Divisibility of Factors(数论)
64 1
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
152 0
|
算法
AtCoder Beginner Contest 213 E - Stronger Takahashi(01BFS)
AtCoder Beginner Contest 213 E - Stronger Takahashi(01BFS)
135 0
|
开发者
牛客第六场-Combination of Physics and Maths
题意:选出一个子矩阵,使得所求的压强最大,压强是指这个子矩阵中每个元素之和 / 这个子矩阵最下面一行的元素之和
59 0
牛客第六场-Combination of Physics and Maths
hdu-1098 Ignatius's puzzle(费马小定理)
hdu-1098 Ignatius's puzzle(费马小定理)
154 0
hdu-1098 Ignatius's puzzle(费马小定理)
HDU-1027,Ignatius and the Princess II
HDU-1027,Ignatius and the Princess II
|
机器学习/深度学习 自然语言处理