HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem C. Sequence

简介: HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem C. Sequence

C — Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description


As we all know, Sister Ye is good at Graph Theory. Now he is intending to examine your Graph Theory level. Sister Ye would show you a degree sequence and ask you to find a simple graph that satisfies the sequence of degrees. Because the graph may be too large, you have to answer if such a graph exists or not only. In order to prevent you from guessing, Sister Ye will ask you more than once.


Input


The first line contains an integer T, the times Sister Ye ask you.


Each question will begin with a line contains an integer n, the size of sequence.

The following line contains a degree sequence a1,...,an.


Output


You should answer 'Y'(yes) or 'N'(no) for each question in one line.

1 ≤ T ≤ 50.

1 ≤ n ≤ 100000.

1 ≤ ai ≤ 10^9.


Sample Input

2

1

1

3

2 1 1


Sample Output

N

Y



Hint

loop:a loop is an edge that connects a vertex to itself.

simple graph: a graph without loops and multiple edges between two vertexes.

degree:the degree of a vertex in a graph is the number of edges connected to the vertex.

degree sequence: An integer sequence of the degrees for each vertex in the graph.


解题思路:给定一组节点的度序列来判断一个图是否为简单图?(符合以下两点即可)


每个节点度数要小于节点个数

该图具有偶数个奇数度的节点

AC 代码


#include<bits/stdc++.h>
#include<cmath>
#define mem(a,b) memset(a,b,sizeof a);
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int maxn=100010;
int n,a[maxn];
bool ok()
{
    int sum=0;
    for(int i=0;i<n;i++)
    {
        if(a[i]%2==1) sum++;
        if(a[i]>=n) return 0;
    }
    if(sum%2==1) return 0;
    return 1;
}
int main()
{
    int T; scanf("%d",&T);
    while(T-- && ~scanf("%d",&n))
    {
        for(int i=0;i<n;i++) scanf("%d",&a[i]);
        puts(ok()?"Y":"N");
    }
    return 0;
}
目录
相关文章
|
2月前
|
算法
【随想】每日两题Day.1
【随想】每日两题Day.1
21 0
|
11月前
2022天梯赛三月冲刺——PAT (Advanced Level)1013 Battle Over Cities (并查集找连通块)
2022天梯赛三月冲刺——PAT (Advanced Level)1013 Battle Over Cities (并查集找连通块)
63 0
|
C++ 网络架构
【PAT甲级 - C++题解】1013 Battle Over Cities
【PAT甲级 - C++题解】1013 Battle Over Cities
52 1
|
存储 C++
【PAT甲级 - C++题解】1056 Mice and Rice
【PAT甲级 - C++题解】1056 Mice and Rice
47 0
|
C++
【PAT甲级 - C++题解】1061 Dating
【PAT甲级 - C++题解】1061 Dating
56 0
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
76 0
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
78 0
[UPC] 2021秋组队17
A Quality-Adjusted Life-Year B Gwen’s Gift C Forest for the Trees D H-Index E Driving Lanes F Treasure Spotting G Neighborhood Watch H Small Schedule I Mr. Plow King J Rainbow Road Race
95 0
|
人工智能 安全
UPC-2021个人训练赛第20场-部分题解
RGB Triplets 题目描述 输入 输出 样例输入 Copy 样例输出 Copy 提示 Select Half 题目描述 输入 输出 样例输入 Copy 样例输出 Copy 提示 心灵的抚慰 题目描述 输入 输出 样例输入 Copy 样例输出 Copy 提示
149 0
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem E. Sequence
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem E. Sequence
130 0