HDOJ/HDU 1984 Mispelling4(删除第n个字符~)

简介: HDOJ/HDU 1984 Mispelling4(删除第n个字符~)

Problem Description

Misspelling is an art form that students seem to excel at. Write a program that removes the nth character from an input string.


Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.


Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.


Sample Input

4

4 MISSPELL

1 PROGRAMMING

7 CONTEST

3 BALLOON


Sample Output

1 MISPELL

2 ROGRAMMING

3 CONTES

4 BALOON



大水题!!!

就是一个字符串删除第n(从1开始)个字符就可以了。  

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int p=1;
        int t =sc.nextInt();
        while(t-->0){
            int a = sc.nextInt();
            String str=sc.next();
            System.out.print((p++)+" ");
            for(int i=0;i<str.length();i++){
                if(i!=(a-1)){
                    System.out.print(str.charAt(i));
                }
            }
            System.out.println();
        }
    }
}
目录
相关文章
HDOJ(HDU) 1491 Octorber 21st
HDOJ(HDU) 1491 Octorber 21st
124 0
HDOJ(HDU) 1491 Octorber 21st
|
测试技术
HDOJ(HDU) 1860 统计字符
HDOJ(HDU) 1860 统计字符
102 0
HDOJ/HDU 1321 Reverse Text(倒序输出~)
HDOJ/HDU 1321 Reverse Text(倒序输出~)
101 0
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
125 0
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
111 0
|
机器学习/深度学习 人工智能 BI
HDOJ/HDU 2550 百步穿杨(注意排序)
HDOJ/HDU 2550 百步穿杨(注意排序)
106 0
|
Java 测试技术
HDOJ(HDU) 1877 又一版 A+B(进制、、)
HDOJ(HDU) 1877 又一版 A+B(进制、、)
97 0
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 2163 Palindromes(判断回文串~)
93 0
HDOJ(HDU) 2115 I Love This Game(排序排序、、、)
HDOJ(HDU) 2115 I Love This Game(排序排序、、、)
93 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
236 0