HDOJ/HDU 1984 Mispelling4(删除第n个字符~)

简介: HDOJ/HDU 1984 Mispelling4(删除第n个字符~)

Problem Description

Misspelling is an art form that students seem to excel at. Write a program that removes the nth character from an input string.


Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.


Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.


Sample Input

4

4 MISSPELL

1 PROGRAMMING

7 CONTEST

3 BALLOON


Sample Output

1 MISPELL

2 ROGRAMMING

3 CONTES

4 BALOON



大水题!!!

就是一个字符串删除第n(从1开始)个字符就可以了。  

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int p=1;
        int t =sc.nextInt();
        while(t-->0){
            int a = sc.nextInt();
            String str=sc.next();
            System.out.print((p++)+" ");
            for(int i=0;i<str.length();i++){
                if(i!=(a-1)){
                    System.out.print(str.charAt(i));
                }
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
测试技术
HDOJ(HDU) 1860 统计字符
HDOJ(HDU) 1860 统计字符
79 0
|
索引
HDOJ/HDU 2567 寻梦(字符串简单处理)
HDOJ/HDU 2567 寻梦(字符串简单处理)
68 0
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 2163 Palindromes(判断回文串~)
73 0
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
HDOJ(HDU) 4847 Wow! Such Doge!(doge字符统计)
106 0
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
102 0
HDOJ/HDU 1321 Reverse Text(倒序输出~)
HDOJ/HDU 1321 Reverse Text(倒序输出~)
77 0
|
Java
HDOJ(HDU) 2097 Sky数(进制)
HDOJ(HDU) 2097 Sky数(进制)
79 0
|
存储
HDOJ/HDU 1073 Online Judge(字符串处理~)
HDOJ/HDU 1073 Online Judge(字符串处理~)
77 0
HDOJ/HDU 2352 Verdis Quo(罗马数字与10进制数的转换)
HDOJ/HDU 2352 Verdis Quo(罗马数字与10进制数的转换)
151 0
HDOJ 2072 单词数
HDOJ 2072 单词数
64 0