HDOJ 1070 Milk(水题,考英文的)

简介: HDOJ 1070 Milk(水题,考英文的)

Problem Description

Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.


Here are some rules:

1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).

2. Ignatius drinks 200mL milk everyday.

3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.

4. All the milk in the supermarket is just produced today.


Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.

Given some information of milk, your task is to tell Ignatius which milk is the cheapest.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.


Output

For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.


Sample Input

2

2

Yili 10 500

Mengniu 20 1000

4

Yili 10 500

Mengniu 20 1000

Guangming 1 199

Yanpai 40 10000


Sample Output

Mengniu

Mengniu


HintIn the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case,

milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.


首先要确认的是,每盒奶只喝五天啊。

倘若两种奶的日花销相同,那么就只挑量大的那盒买。


有2种方法,一种是对每天的开销来求的:如下:

import java.util.Scanner;
public class Main{
    static long db[][] = new long[10][4];
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        dabiao();
//      System.out.println(db[4][0]);
//      System.out.println(db[4][3]);
//      
        long t = sc.nextLong();
        while(t-->0){
            int n = sc.nextInt();
            int f=n%10;
            int m=n%4;
            //System.out.println(m);
            m--;
            if(m<0){
                m=3;
            }
            System.out.println(db[f][m]);
        }
    }
    private static void dabiao() {
        for(int i=1;i<=9;i++){
            for(int j=0;j<4;j++){
                db[i][j]=dabiao(i,j);
                //System.out.print(db[i][j]+" ");
            }
            //System.out.println();
        }
    }
    private static long dabiao(long i, long j) {
        long m=i;//4,3
        for(int k=1;k<=j;k++){
            m=(m*i)%10;
        }
        m=m%10;
        return m;
    }
}
目录
相关文章
|
10月前
【每日一题Day273】LC860柠檬水找零 | 贪心
【每日一题Day273】LC860柠檬水找零 | 贪心
52 0
【每日一题Day273】LC860柠檬水找零 | 贪心
|
10月前
【每日一题Day334】LC2591将钱分给最多的儿童 | 贪心
【每日一题Day334】LC2591将钱分给最多的儿童 | 贪心
56 0
|
10月前
|
C语言
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-4 报数 (20分)
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-4 报数 (20分)
|
10月前
|
C语言
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-6 删除字符 (20分)
PTA 浙大版《C语言程序设计(第3版)》题目集 习题8-6 删除字符 (20分)
P2433 【深基1-2】小学数学 N 合一
P2433 【深基1-2】小学数学 N 合一
298 0
|
10月前
|
Java
【LeetCode-六月每日一题-】-回文数
【LeetCode-六月每日一题-】-回文数
|
人工智能 测试技术
贪心: [蓝桥杯 2020 国 ABC] 答疑
贪心: [蓝桥杯 2020 国 ABC] 答疑
114 0
不同子串[蓝桥杯2019初赛]
一个字符串的非空子串是指字符串中长度至少为1 的连续的一段字符组成的串。 例如,字符串aaab 有非空子串a, b, aa, ab, aaa, aab, aaab,一共7 个。 注意在计算时,只算本质不同的串的个数。 请问,字符串0100110001010001 有多少个不同的非空子串?