HDU2577

简介: How to Type Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Problem Description Pirates have finished developing the typing software. He called Cathy to test hi
How to Type
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8

The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

对于每个字母之前的字母有两种状态 1.caps开启 2.caps关闭,有数组分别记录两种状态下的最短时间,接下来状态转移方程:

0代表没开,1代表开了,对当前字母分类
小写字母: timer[i+1][0]=min(timer[i][0]+1,timer[i][1]+2);
                     timer[i+1][1]=min(timer[i][0]+2,timer[i][1]+2);
大写字母: timer[i+1][0]=min(timer[i][0]+2,timer[i][1]+2);
                      timer[i+1][1]=min(timer[i][0]+2,timer[i][1]+1);


#include<stdio.h>
#include<string.h>
#define min(a,b) (a>b?b:a)
char m[120];
int timer[120][2];
int main()
{
	int n;
	while(scanf("%d%*c",&n)!=EOF)
	{
		while(n--)
		{
			gets(m);
			memset(timer,0,sizeof(timer));
			timer[0][1]=1;
			for(int i=0; i<strlen(m); i++)
				if(m[i]>='a' && m[i]<='z')
				{
					timer[i+1][0]=min(timer[i][0]+1,timer[i][1]+2);
					timer[i+1][1]=min(timer[i][0]+2,timer[i][1]+2);
				}
				else {
					timer[i+1][0]=min(timer[i][0]+2,timer[i][1]+2);
					timer[i+1][1]=min(timer[i][0]+2,timer[i][1]+1);
				}
			printf("%d\n",min(timer[strlen(m)][0],timer[strlen(m)][1]+1));
		}
	}
	return 0;
}


目录
相关文章
|
C++
HDU1862
中文题,题意挺好理解,不过多赘述。
1276 0
|
测试技术 Java
|
人工智能 Java
HDU 1257
最少拦截系统 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4182    Accepted Submission(s): 1528 ...
786 0

热门文章

最新文章