pdns 错误解决[备忘]

简介: 参见日志: pdns (master) server  /var/log/messages 错误信息提示: Jan 30 10:08:08 kylezhuang-hh-qa-dns-crguy pdns[6363]: AXFR of domain '199.10.in-addr.arpa' initiated by 10.199.132.168Jan 30 10:08:08 ky

参见日志:


pdns (master) server  /var/log/messages 错误信息提示:

Jan 30 10:08:08 kylezhuang-hh-qa-dns-crguy pdns[6363]: AXFR of domain '199.10.in-addr.arpa' initiated by 10.199.132.168
Jan 30 10:08:08 kylezhuang-hh-qa-dns-crguy pdns[6363]: AXFR of domain '199.10.in-addr.arpa' allowed: client IP 10.199.132.168 is in allow-axfr-ips
Jan 30 10:08:08 kylezhuang-hh-qa-dns-crguy pdns[6363]: Exception: All data was not consumed
Jan 30 10:08:08 kylezhuang-hh-qa-dns-crguy pdns[6363]: TCP Connection Thread died because of STL error: All data was not consumed
Jan 30 10:08:28 kylezhuang-hh-qa-dns-crguy pdns[6363]: AXFR of domain '199.10.in-addr.arpa' initiated by 10.199.132.168
.....
Jan 30 09:59:06 kylezhuang-hh-qa-dns-crguy pdns[23658]: AXFR of domain '199.10.in-addr.arpa' allowed: client IP 10.199.132.168 is in allow-axfr-ips
Jan 30 09:59:06 kylezhuang-hh-qa-dns-crguy pdns[23658]: Exception: All data was not consumed
Jan 30 09:59:06 kylezhuang-hh-qa-dns-crguy pdns[23658]: TCP Connection Thread died because of STL error: All data was not consumed


bind (slave) server /var/log/messages 错误信息提示:

Jan 30 03:45:48 hh-yun-puppet-129021 named[100639]: transfer of '199.10.in-addr.arpa/IN' from 10.199.132.152#53: connected using 10.199.129.21#60474
Jan 30 03:45:48 hh-yun-puppet-129021 named[100639]: transfer of '199.10.in-addr.arpa/IN' from 10.199.132.152#53: failed while receiving responses: end of file
Jan 30 03:45:48 hh-yun-puppet-129021 named[100639]: transfer of '199.10.in-addr.arpa/IN' from 10.199.132.152#53: Transfer completed: 23 messages, 2201 records, 96020 bytes, 0.027 secs (3556296 bytes/sec)


原因: master 服务器上具有不合法的语法解析, 导致 bind 无法主从同步获取完整的数据信息

解决方法,  检测主服务器数据库上的  records 表中 name 与 content 字段, 细心找到不合法的字段, 然后修复则可解决.

如:

mysql> select * from records where name='21.130.199.10.in-addr.arpa';   (不符合规范语法, 不知道谁埋的雷)
+----+-----------+----------------------------+------+---------------------------------------------------------------------------------+------+------+-------------+----------+-----------+------+
| id | domain_id | name                       | type | content                                                                         | ttl  | prio | change_date | disabled | ordername | auth |
+----+-----------+----------------------------+------+---------------------------------------------------------------------------------+------+------+-------------+----------+-----------+------+
|  4 |         2 | 21.130.199.10.in-addr.arpa | PTR  | pdns.199.10.in-addr.arpa admin.pdns.199.10.in-addr.arpa 7 1200 7200 64800 86400 |  360 | NULL |        NULL |        0 | NULL      |    1 |
+----+-----------+----------------------------+------+---------------------------------------------------------------------------------+------+------+-------------+----------+-----------+------+
1 row in set (0.00 sec)

mysql> delete from records where id=4;
Query OK, 1 row affected (0.00 sec)

mysql> select * from records where type='SOA' and domain_id=2;  (正确语法参考)
+----+-----------+---------------------+------+------------------------------------------------------------+------+------+-------------+----------+-----------+------+
| id | domain_id | name                | type | content                                                    | ttl  | prio | change_date | disabled | ordername | auth |
+----+-----------+---------------------+------+------------------------------------------------------------+------+------+-------------+----------+-----------+------+
|  2 |         2 | 199.10.in-addr.arpa | SOA  | dns.vclound.com admin.pdns.vclound.com 555 1200 7200 64800 |  360 | NULL |        NULL |        0 | NULL      |    1 |
+----+-----------+---------------------+------+------------------------------------------------------------+------+------+-------------+----------+-----------+------+




目录
相关文章
|
关系型数据库 块存储
ceph 故障分析(backfill_toofull)
在执行了 ceph 扩容之前, 发现长时间内都具有下面的状态存在 参考下面信息 # ceph -s cluster dc4f91c1-8792-4948-b68f-2fcea75f53b9 health HEALTH_WARN 13 pgs backfill_toofull; 1 pgs degraded; 1 pgs stuck degraded
7669 0
ping 返回 no buffer space available 解决方法
1. 云主机当前常规并发比较大,  约有 1900 个常规连接 [root@chao-data07 ~]# netstat -nt | grep EST | wc -l 1867 2. 当前出现 arp 表不正常现象 见到下面错误信息 Mar 24 14:06:31 chao-data07 dhclient[1112]: DHCPREQUEST on eth0 to 10.
5401 0
|
Web App开发 关系型数据库 MySQL
namedmanager 一个用户管理 bind 的 web gui
namedmanager 作用 使用新的 Amberphplib 框架,兼容 MySQL 5.6 STRICT SQL模式 是一个基于 Web 的 DNS 管理系统,可用来添加、调整和删除 DNS 的 zones/records 数据,支持 Bind 作为后端的 DNS 服务,支持 IPv4 和 IPv6.   namedmanager 软件安装方法   下载仓库地址 wge
4095 0
openstack 管理二十八 - rpm 方式部署 openstack [keystone]
说明 1 keystone 数据存储至 mariadb 中 2 keystone 主要为 nova, neutron, cinder 等组件提供数据认证服务, 3 keystone 自身管理 user, tenant, service, endpoint 等重要信息 安装 yum install -y openstack-keystone.noarch opens
1935 0
|
关系型数据库 MySQL 容器
openstack 管理二十九 - rpm 方式部署 openstack [glance]
作用 1 glance 主要用于管理云主机镜像 2 glance 需要进行 keystone 验证 3 在第一次云主机创建时候, 把镜像从 glance server 传输至 compute 组件中 安装 yum install -y openstack-glance.noarch openstack-glance-doc.noarch python-glance
1802 0
|
消息中间件 存储 关系型数据库
openstack 管理三十 - rpm 方式部署 openstack [cinder]
作用 1 cinder 需要连接 ceph 进行云硬盘存储 2 cinder 需要连接 keystone 进行用户验证 3 cinder 需要连接 rabbitmq 处理消息队列 默认下 openstack 提供卷驱动, 支持下面的块存储类型 LVM/iSCSI ThinLVM NFS NetAPP NFS Red Hat Storage (Gluster) Dell
2097 0
|
Linux
openstack 管理三十二 - rpm 方式部署 openstack [neutron]
作用 1 neutron 实现了 openstack 下的虚拟网络功能 2 能够实现路由与交换功能 3 能够具有 dhcp 分配 ip 至云主机 neutron 定义了整个 openstack 的网络模型, 当前测试使用了 flat (平面网络) 生产使用了 vlan flat gre local vlan vxlan neutron 在网络类型中支持下面的组件,
2527 0
|
监控 关系型数据库 MySQL
清理 zabbix 历史数据, 缩减 mysql 空间
zabbix 由于历史数据过大, 因此导致磁盘空间暴涨,  下面是结局方法步骤 1. 停止 ZABBIX SERER 操作 [root@gd02-qa-plxt2-nodomain-web-95 ~]# killall zabbix_server [root@gd02-qa-plxt2-nodomain-web-95 ~]# lsof -i:10051 2. 停止 mysql
3726 0
|
SQL Web App开发 关系型数据库
powerdns 安装部署备忘
PowerDNS 一种 DNS 服务器, 优点, 支持 PHP 网页管理, 支持直接在数据库中添加 DNS 地址记录, 比较灵活, 方便   参见信息 主机名 PDNS 中记录的主机名 本机 ip 地址 浮动 IP 地址 操作系统版本 备注 1 备注2    gd02-qa-plxt2-nodomain.ddns.vclound.com pdnsweb.v
2697 0
|
算法 关系型数据库 MySQL
mysql hash 索引 vs B-TREE 索引 理解
hash 索引 当前 memory 引擎, innodb 引擎支持 hash 索引, 索引将存放内存中,(innodb 存放 buffer pool)  innodb 启动 innodb-adaptive-hash-index 参数就能够支持   假设利用  show engine innodb status \G 看到大量类似下图的等待值 (参见 RW-latch 由 brt0
1667 0