开发者社区> 天飞.h> 正文

linux下安装PPS

简介: 到官方下载FEDORA版RPM包。 [talen@liangshan Downloads]$ sudo yum localinstall PPStream.rpm 已加载插件:axelget, fastestmirror, presto, priorities, refres...
+关注继续查看

到官方下载FEDORA版RPM包。


img_2fc18491e86ac969f9fb4a9300bb4005.png
[talen@liangshan Downloads]$ sudo yum localinstall PPStream.rpm 

已加载插件:axelget, fastestmirror, presto, priorities, refresh-packagekit, remove-with-leaves

设置本地安装进程

诊断 PPStream.rpm: PPStream-1.0.2-11.i386

PPStream.rpm 将被安装

Repository rpmfusion-free is listed more than once in the configuration

Repository rpmfusion-free-updates is listed more than once in the configuration

Repository rpmfusion-nonfree is listed more than once in the configuration

Repository rpmfusion-nonfree-updates is listed more than once in the configuration

No metadata available for fedora

No metadata available for rpmfusion-free

No metadata available for rpmfusion-free-updates

No metadata available for rpmfusion-nonfree

No metadata available for rpmfusion-nonfree-updates

No metadata available for skype

No metadata available for updates

No metadata available for updates-testing

No metadata available for virtualbox

Finish Download MetaData of Enabled Repo

Loading mirror speeds from cached hostfile

 * fedora: mirrors.163.com

 * rpmfusion-free: mirrors.163.com

 * rpmfusion-free-updates: mirrors.163.com

 * rpmfusion-nonfree: mirrors.163.com

 * rpmfusion-nonfree-updates: mirrors.163.com

 * updates: mirrors.163.com

 * updates-testing: mirrors.163.com

854 packages excluded due to repository priority protections

解决依赖关系

--> 执行事务检查

---> Package PPStream.i386 0:1.0.2-11 will be 安装

--> 处理依赖关系 libQtWebKit.so.4,它被软件包 PPStream-1.0.2-11.i386 需要

--> 执行事务检查

---> Package qt-webkit.i686 1:4.7.3-8.fc15 will be 安装

--> 处理依赖关系 libphonon.so.4,它被软件包 1:qt-webkit-4.7.3-8.fc15.i686 需要

--> 执行事务检查

---> Package phonon.i686 0:4.5.0-2.fc15 will be 安装

--> 处理依赖关系 phonon-backend(x86-32) >= 4.4,它被软件包 phonon-4.5.0-2.fc15.i686 需要

--> 处理依赖关系 kde-filesystem,它被软件包 phonon-4.5.0-2.fc15.i686 需要

--> 执行事务检查

---> Package kde-filesystem.i686 0:4-38.fc15 will be 安装

---> Package phonon-backend-gstreamer.i686 2:4.5.1-1.fc15 will be 安装

--> 完成依赖关系计算


依赖关系解决


==============================================================================================================================================

 软件包                                       架构                     版本                               仓库                           大小

==============================================================================================================================================

正在安装:

 PPStream                                     i386                     1.0.2-11                           /PPStream                      13 M

为依赖而安装:

 kde-filesystem                               i686                     4-38.fc15                          fedora                         47 k

 phonon                                       i686                     4.5.0-2.fc15                       fedora                        187 k

 phonon-backend-gstreamer                     i686                     2:4.5.1-1.fc15                     fedora                        115 k

 qt-webkit                                    i686                     1:4.7.3-8.fc15                     updates                       5.3 M


事务概要

==============================================================================================================================================

Install       5 Package(s)


总文件大小:18 M

总下载量:5.6 M

Installed size: 33 M

确定吗?[y/N]:y

下载软件包:

Package fedora download size 117740 less than 300000,Skip plugin!

Package fedora download size 47952 less than 300000,Skip plugin!

Package fedora download size 191576 less than 300000,Skip plugin!

[5/5]Ok,we will try to use axel to download this big file:5520432

Before we start,clean all the key files

初始化下载: http://mirrors.163.com/fedora/updates/15/i386//qt-webkit-4.7.3-8.fc15.i686.rpm

File size: 5520432 bytes

打开输出文件 /var/cache/yum/i386/15/updates/packages/qt-webkit-4.7.3-8.fc15.i686.rpm

开始下载


连接 2 结束                                                                    ]

连接 3 结束                                                                    ]

连接 1 结束                                                                    ]

连接 0 结束                                                                    ]

[100%] [..................................................] [ 115.4KB/s] [00:00]


5391.0 千字节 已下载,用时 46 秒。(115.36 千字节/秒)

Setting up and reading Presto delta metadata

Processing delta metadata

Package(s) data still to download: 349 k

(1/3): kde-filesystem-4-38.fc15.i686.rpm                                                                               |  47 kB     00:00     

(2/3): phonon-4.5.0-2.fc15.i686.rpm                                                                                    | 187 kB     00:00     

(3/3): phonon-backend-gstreamer-4.5.1-1.fc15.i686.rpm                                                                  | 115 kB     00:00     

----------------------------------------------------------------------------------------------------------------------------------------------

总计                                                                                                          116 kB/s | 349 kB     00:03     

运行 rpm_check_debug 

执行事务测试

事务测试成功

执行事务

  正在安装   : kde-filesystem-4-38.fc15.i686                                                                                              1/5 

  正在安装   : phonon-4.5.0-2.fc15.i686                                                                                                   2/5 

  正在安装   : 2:phonon-backend-gstreamer-4.5.1-1.fc15.i686                                                                               3/5 

  正在安装   : 1:qt-webkit-4.7.3-8.fc15.i686                                                                                              4/5 

  正在安装   : PPStream-1.0.2-11.i386                                                                                                     5/5 


已安装:

  PPStream.i386 0:1.0.2-11                                                                                                                    


作为依赖被安装:

  kde-filesystem.i686 0:4-38.fc15  phonon.i686 0:4.5.0-2.fc15  phonon-backend-gstreamer.i686 2:4.5.1-1.fc15  qt-webkit.i686 1:4.7.3-8.fc15 


完毕!

[talen@liangshan Downloads]$ 

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
阿里云服务器端口号设置
阿里云服务器初级使用者可能面临的问题之一. 使用tomcat或者其他服务器软件设置端口号后,比如 一些不是默认的, mysql的 3306, mssql的1433,有时候打不开网页, 原因是没有在ecs安全组去设置这个端口号. 解决: 点击ecs下网络和安全下的安全组 在弹出的安全组中,如果没有就新建安全组,然后点击配置规则 最后如上图点击添加...或快速创建.   have fun!  将编程看作是一门艺术,而不单单是个技术。
20234 0
阿里云服务器ECS远程登录用户名密码查询方法
阿里云服务器ECS远程连接登录输入用户名和密码,阿里云没有默认密码,如果购买时没设置需要先重置实例密码,Windows用户名是administrator,Linux账号是root,阿小云来详细说下阿里云服务器远程登录连接用户名和密码查询方法
22257 0
阿里云服务器怎么设置密码?怎么停机?怎么重启服务器?
如果在创建实例时没有设置密码,或者密码丢失,您可以在控制台上重新设置实例的登录密码。本文仅描述如何在 ECS 管理控制台上修改实例登录密码。
23540 0
阿里云服务器如何登录?阿里云服务器的三种登录方法
购买阿里云ECS云服务器后如何登录?场景不同,大概有三种登录方式:
13155 0
使用OpenApi弹性释放和设置云服务器ECS释放
云服务器ECS的一个重要特性就是按需创建资源。您可以在业务高峰期按需弹性的自定义规则进行资源创建,在完成业务计算的时候释放资源。本篇将提供几个Tips帮助您更加容易和自动化的完成云服务器的释放和弹性设置。
20887 0
+关注
天飞.h
脚踏实地,仰望天空. https://talenhao.github.io/
260
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
JS零基础入门教程(上册)
立即下载
性能优化方法论
立即下载
手把手学习日志服务SLS,云启实验室实战指南
立即下载