1031. Hello World for U (20)

简介: Given any string of N (>=5) characters, you are asked to form the characters into the shape of U.

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1  characters, then left to right along the bottom line with n 2  characters, and finally bottom-up along the vertical line with n 3  characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1  = n 3  = max { k| k <= n 2  for all 3 <= n 2  <= N } with n 1  + n 2  + n 3  - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

简析:一次ac,不解释。

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    string s;
    cin >> s;
    int len = (int)s.length();
    int n1, n2, n3, i = 0;
    n1 = n3 = (len + 2) / 3;
    n2 = len - n1 * 2 + 2;
    
    for (i = 0; i < n1 - 1; i++) {
        for (int j = 0; j < n2; j++) {
            if (j == 0) {
                printf("%c", s[i]);
            }else if(j == n2 - 1){
                printf("%c\n", s[len - i - 1]);
            }else{
                printf(" ");
            }
        }
    }
    int t = i;
    for (; i < t + n2; i++) {
        printf("%c", s[i]);
    }
    printf("\n");
    
    return 0;
}


目录
相关文章
|
6月前
|
移动开发 C++
Hello World
Hello World
50 0
10:Hello, World!的大小
10:Hello, World!的大小
99 0
|
C++
L1-001 Hello World
文章目录 L1-001 Hello World (5 分) 总结
94 0
L1-001 Hello World
Hello world
首帖则测试了解下如何使用,并且看看有什么不同的地方,是不是很好用呢 引用测试 H是什么不知道
559 0
|
Java
你真的会写Hello World吗
概要 起因A3项目发展2年后,功能较为稳定后 ,准备合并进EagleEye主体项目,遇到了个问题,代码很难merge进EagleEye。暴露了一个问题,代码写得太差。模块化。重新认识一下,如何写代码 入门版Hello World 下面这段经典代码,开始学习的时候,觉得非常的优美。
2615 0