1134. Vertex Cover (25)

简介: A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set.

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] ... v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
#include <iostream>
#include <vector>
using namespace std;

int main(){
    int n, m, a, b;
    cin >> n >> m;
    vector<int> nv[n];
    
    for (int i = 0; i < m; i++) {
        cin >> a >> b;
        nv[a].push_back(i);
        nv[b].push_back(i);
    }
    
    int k, p, t;
    cin >> k;
    for (int i = 0; i < k; i++) {
        bool ans[m];
        fill(ans, ans+m, false);
        cin >> p;
        
        for (int j = 0; j < p; j++) {
            cin >> t;
            for (int k = 0; k < nv[t].size(); k++) {
                ans[nv[t][k]] = true;
            }
        }
        
        bool flag = true;
        for (int j = 0; j < m; j++) {
            if (!ans[j]) {
                flag = false;
                break;
            }
        }
        
        if (flag) {
            cout << "Yes\n";
        }else{
            cout << "No\n";
        }
    }
    
    return 0;
}
 
目录
相关文章
|
人工智能 编解码 自然语言处理
论文解读:Inpaint Anything: Segment Anything Meets Image Inpainting
论文解读:Inpaint Anything: Segment Anything Meets Image Inpainting
433 0
|
存储
【PAT甲级】1134 Vertex Cover
【PAT甲级】1134 Vertex Cover
70 0
|
索引
LeetCode 84. Largest Rectangle in Histogram
给定n个非负整数表示直方图的条形高度,其中每个条形的宽度为1,找到直方图中最大矩形的区域。
77 0
LeetCode 84. Largest Rectangle in Histogram
|
机器学习/深度学习
Leetcode-Easy 887. Projection Area of 3D Shapes
Leetcode-Easy 887. Projection Area of 3D Shapes
134 0
Leetcode-Easy 887. Projection Area of 3D Shapes
|
算法
Split Shape by Plane in OpenCASCADE
Split Shape by Plane in OpenCASCADE eryar@163.com Abstract. Sometimes you want to split a shape by plane or even split a shape by a B Spline surfac...
1728 0
|
人工智能 图形学
OpenCASCADE Shape Location
OpenCASCADE Shape Location eryar@163.com Abstract. The TopLoc package of OpenCASCADE gives resources to handle 3D local coordinate systems called Locations.
1604 0