ubuntu14.04 编译安装highpoint rocketraid 2720驱动-阿里云开发者社区

开发者社区> 开发与运维> 正文

ubuntu14.04 编译安装highpoint rocketraid 2720驱动

简介: <p>highpoint官方只有ubuntu12.10驱动,对于ubuntu14.04或者12.04,需要手工编译安装驱动。</p> <p>基本步骤:</p> <p>1、下载rocketraid 2720驱动源代码</p> <p>2、在一台装有ubuntu14.04的机器上编译驱动</p> <p>3、如果新装系统,可使用highpoint官方提供的12.10驱动安装程序,替换里面的.ko驱动文

highpoint官方只有ubuntu12.10驱动,对于ubuntu14.04或者12.04,需要手工编译安装驱动。

基本步骤:

1、下载rocketraid 2720驱动源代码

2、在一台装有ubuntu14.04的机器上编译驱动

3、如果新装系统,可使用highpoint官方提供的12.10驱动安装程序,替换里面的.ko驱动文件

源码及我编译好的安装包下载:http://pan.baidu.com/s/1bntSjU3


源码使用1.6.1版本:rr272x_1x-linux-src-v1.6.1(官方的1.5版本编译时会报错)

编译方法:

cd rr272x_1x-linux-src-v1.6.1/product/rr272x/linux

make

产生rr272x_1x.ko文件

gzip rr272x_1x.ko

将文件拷贝到rr272x_1x-ubuntu-12.10-x86_64-v1.5.13.0327/boot,并改名为:rr272x_1x3.5.0-17-genericx86_64.ko.gz

驱动安装文档及一些官方下载:

http://www.lefern.com/question/60464/ru-he-zai-ubuntuzhong-an-zhuang-rapidrocket2720zhen-lie-qia-qu-dong/

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章