开发者社区> 科技小能手> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

利用冗余实现企业局域网的高可用性

简介:
+关注继续查看

利用冗余实现企业局域网的高可用性

一、基础知识:

随着Internet的迅猛发展,基于网络的应用逐渐增多。这就对网络的可靠性提出了越来越高的要求。斥资对所有网络设备进行更新当然是一种很好的可靠性解决方案;但本着保护现有投资的角度考虑,可以采用廉价冗余的思路,在可靠性和经济性方面找到平衡点。

<1>端口汇聚:

端口汇聚是将多个端口汇聚在一起形成一个汇聚组,在汇聚组中的各个成员端口之间,实现出/入负荷的分担,同时也提供了更高的连接可靠性。

端口汇聚分类:端口汇聚组可以分为负载分担汇聚组和非负载分担汇聚组。

在一个端口汇聚组中,端口号最小的作为主端口,其他的作为成员端口。同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口;

<2>虚拟路由器冗余:

VRRP是一种容错协议,它通过把几台路由设备联合组成一台虚拟的路由设备,并通过一定的机制来保证当主机的下一跳设备出现故障时,可以及时将业务切换到其它设备,从而保持通讯的连续性和可靠性。

VRRP的优势:既不需要改变组网情况,也不需要在主机上配置任何动态路由或者路由发现协议,就可以获得更高可靠性的缺省路由

VRRP路由器和虚拟路由器:VRRP路由器是指运行VRRP的路由器,是物理实体,虚拟路由器是指VRRP协议创建的,是逻辑概念。一组VRRP路由器协同工作,共同构成一台虚拟路由器。该虚拟路由器对外表现为一个具有唯一固定IP地址和MAC地址的逻辑路由器。

VRRP的工作原理:VRRP将局域网的一组路由器构成一个备份组,相当于一台虚拟路由器。局域网内的主机只需要知道这个虚拟路由器的IP地址,并不需知道具体某台设备的IP地址,将网络内主机的缺省网关设置为该虚拟路由器的IP地址,主机就可以利用该虚拟网关与外部网络进行通信。

<3>生成树协议:

生成树协议是一种二层管理协议,它通过有选择性地阻塞网络冗余链路来达到消除网络二层环路的目的,同时具备链路的备份功能。

生成树协议的主要功能有两个:一是在利用生成树算法、在以太网络中,创建一个以某台交换机的某个端口为根的生成树,避免环路。二是在以太网络拓扑发生变化时,通过生成树协议达到收敛保护的目的。

<4>生成树算法的计算过程:

1、根;首先选出算法,查找谁的bridge-id最小,则为根;

2、在每一个非根交换机,找离根最进的端口(并且开销最小),则为根端口

a) 根据cost来选取根端口;

b) 当cost相同时,通过bridge-id的优先级或mac来选取,小得是为根;

c) 当bridge-id相同时,对比(端口id)port id【包括端口号码 和 端口优先级】

3、在每一个网段(一条线路连接接口)指定端口 BP,与根端口连接的端口都是指定端口。

a) 根据cost

b) 根据bridge-id

4、找到阻塞端口

<5>端口状态:

FWD:转发状态;

BLK:阻塞状态;

LRN:学习状态;

LIS:监听状态;

二、案例- 1

1、实验说明:

某公司使用两种ISP运营商提供的网络,两种网络共同连接到因特网,为了实现公司局域网的高可用性,使用端口聚合和VRRP技术,并且本公司用户可以正常访Internet,正常办理业务。

2、实验拓扑:

wps_clip_image-26931

3、实验环境:

华为交换机2台(S2000系列)

华为路由器2台(R2621系列)

PC机4台

4、实验要求:

实现vlan间通信;

为实现路由器的高利用率,设置路由器在每个VRRP组中担任的不同角色;

两台交换机之间使用端口组合进行通信;

5、实验步骤:

<1>SW 1交换机配置:

1)划分vlan:

wps_clip_image-13812

2)配置trunk链路:

wps_clip_image-13220

3)配置端口聚合:

wps_clip_image-19561

<2>SW2交换机配置

1)划分vlan:

wps_clip_image-21388

2)设置trunk链路:

wps_clip_image-29952

3)配置端口聚合:

wps_clip_image-10877

<3>R1路由器配置:

1)配置以太网子接口:

wps_clip_image-16680

2)配置vrrp:

wps_clip_image-2476

<4>R2路由器配置:

1)配置以太网子接口:

wps_clip_image-13506

2)配置vrrp:

wps_clip_image-26381

6、验证测试:

<1>在正常情况下

1)VLAN10的PC 1主机ping VLAN20的PC 4主机:

wps_clip_image-12601

2)查看链路路径:

wps_clip_image-31866

3)查看R1的VRRP现状:

wps_clip_image-30360

4)查看R2的VRRP现状:

wps_clip_image-10504

<2>断开R1的链路后:

1)VLAN10的PC 1主机ping VLAN20的PC 4主机:

wps_clip_image-21007

2)查看链路路径:

wps_clip_image-28137

3)查看R2的VRRP现状:

wps_clip_image-3515

<3>断开R2的链路后:

1)VLAN10的PC 1主机ping VLAN20的PC 4主机:

wps_clip_image-27543

2)查看链路路径:

wps_clip_image-5049

3)查看R1的VRRP现状:

wps_clip_image-10524

三、案例- 1

1、实验说明:

某公司使用两种ISP运营商提供的网络,两种网络共同连接到因特网,为了实现公司局域网的高可用性,使用生成树和VRRP技术,并且本公司用户可以正常访Internet,正常办理业务。

2、实验拓扑:

wps_clip_image-1740

3、实验环境:

小凡模拟器;

思科路由器2台(3640)

思科交换机2台(3640)

两台PC(使用两台路由器来模拟)

4、实验要求:

实现vlan间通信;

为实现路由器的高利用率,设置路由器在每个VRRP组中担任的不同角色;

两台交换机之间使用端口组合进行通信;

5、实验步骤:

1)配置R1:

Router(config)#int eth 0/0.10 ! 进入以太网子接口

Router(config-subif)#encapsulation dot1Q 10 ! 封装协议和划分vlan

Router(config-subif)#ip add 192.168.10.1 255.255.255.0 ! 配置子接口ip

Router(config-subif)#standby 10 ip 192.168.10.254 ! 配置虚拟ip

Router(config-subif)#standby 10 priority 120 ! 配置vrrp组10的优先级

Router(config-subif)#standby 10 preempt ! 设为抢占模式

Router(config-subif)#exit

Router(config)#int eth 0/0.20

Router(config-subif)#encapsulation dot1Q 20 ! 封装协议和划分vlan

Router(config-subif)#ip add 192.168.20.1 255.255.255.0 ! 配置子接口ip

Router(config-subif)#standby 20 ip 192.168.20.254 ! 配置虚拟ip

Router(config-subif)#exit

Router(config)#

2)配置R2:

Router(config)#int eth 0/0.10

Router(config-subif)#encapsulation dot1Q 10 ! 封装协议和划分vlan

Router(config-subif)#ip add 192.168.10.2 255.255.255.0 ! 配置子接口ip

Router(config-subif)#standby 10 ip 192.168.10.254 ! 配置虚拟ip

Router(config-subif)#exit

Router(config)#int eth 0/0.20

Router(config-subif)#encapsulation dot1Q 20 ! 封装协议和划分vlan

Router(config-subif)#ip add 192.168.20.2 255.255.255.0 ! 配置子接口ip

Router(config-subif)#standby 20 ip 192.168.20.254 ! 配置虚拟ip

Router(config-subif)#standby 20 priority 120 ! 配置vrrp组20的优先级

Router(config-subif)#standby 20 preempt ! 设为抢占模式

Router(config-subif)#exit

Router(config)#

Router(config)#

3)配置SW1:

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#

Router(config)#

Router(config)#no ip routing ! 取消路由功能

Router(config)#

Router(config)#exit

Router#vlan database ! 进入vlan数据库

Router(vlan)#vlan 10 ! 创建vlan10

VLAN 10 added:

    Name: VLAN0010

Router(vlan)#vlan 20 ! 创建vlan20

VLAN 20 added:

    Name: VLAN0020

Router(vlan)#exit

APPLY completed.

Exiting....

Router#confi t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int range f0/6 - 10

Router(config-if-range)#switchport access vlan 10 ! 将接口划分到vlan10中

Router(config-if-range)#exit

Router(config)#int range f0/11 - 15

Router(config-if-range)#switchport access vlan 20 ! 将接口划分到vlan20中

Router(config-if-range)#exit

Router(config)#

Router(config)#int fa0/0

Router(config-if)#switchport mode trunk ! 设置成trunk端口

Router(config-if)#exit

Router(config)#

Router(config)#int fa0/1

Router(config-if)#switchport mode trunk ! 设置成trunk端口

Router(config-if)#channel-group 1 mode on  ! 将端口添加到聚合组1中

Creating a port-channel interface Port-channel1

Router(config-if)#exit

Router(config)#int fa0/2

Router(config-if)#switchport mode trunk

Router(config-if)#channel-group 1 mode on  ! 将端口添加到聚合组1中

Router(config-if)#exit

4)配置SW2:

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip routing

Router(config)#

Router(config)#exit

Router#vlan database ! 进入vlan数据库

Router(vlan)#vlan 10 ! 创建vlan10

VLAN 10 added:

    Name: VLAN0010

Router(vlan)#vlan 20 ! 创建vlan20

VLAN 20 added:

    Name: VLAN0020

Router(vlan)#exit

APPLY completed.

Exiting....

Router#confi t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int range f0/6 - 10

Router(config-if-range)#switchport access vlan 10 ! 将接口划分到vlan10中

Router(config-if-range)#exit

Router(config)#int range f0/11 - 15

Router(config-if-range)#switchport access vlan 20 ! 将接口划分到vlan20中

Router(config-if-range)#exit

Router(config)#

Router(config)#int fa0/0

Router(config-if)#switchport mode trunk ! 设置成trunk端口

Router(config-if)#exit

Router(config)#

Router(config)#int fa0/1

Router(config-if)#switchport mode trunk ! 设置成trunk端口

Router(config-if)#channel-group 1 mode on  ! 将端口添加到聚合组1中

Creating a port-channel interface Port-channel1

Router(config-if)#exit

Router(config)#int fa0/2

Router(config-if)#switchport mode trunk  ! 将端口添加到聚合组1中

Router(config-if)#channel-group 1 mode on

Router(config-if)#

6、验证测试:

1)PC1 与PC4之间测试连通性:

wps_clip_image-26934

wps_clip_image-24561

2)PC1 与PC4之间通信路径:

wps_clip_image-31084

wps_clip_image-10856

3)当R1出现故障时:

wps_clip_image-31702

4)当R2出现故障时:

wps_clip_image-1111

四、实验小结:

一定要将aggregatePort的switchport mode配置为trunk模式,否则其默认为access模式。

我们在数据上行时可以实现负载均衡,但是下行时却做不到,所以我们进行路由优先级的配置。



本文转自 cexpert 51CTO博客,原文链接:http://blog.51cto.com/cexpert/965287

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
物联网、人工智能和区块链将重塑商业经济
人工智能、区块链和物联网这三种新兴技术正在颠覆商业世界。事实证明,它们在缓解核心业务挑战和在增强现有业务模式提供更好的机会方面具有无穷的潜力。
32 0
23703
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载