CentOS6.8及7最小化安装后无法直接安装vmtools问题-阿里云开发者社区

开发者社区> 开发与运维> 正文

CentOS6.8及7最小化安装后无法直接安装vmtools问题

简介:

    问题发生背景

    近期因为学习需要使用CentOS-6.8与CentOS-7系统,因此最小化安装系统后例常进行vmtools的安装,然而竟然报错,报错内容如下

1
2
3
./vmware-install.pl
 
bash:./vmware-install.pl :/usr/bin/perl:bad interpreter:No such file or directory.

    这是什么鬼,最为菜鸟的我第一眼就看懵了,之前都没发生过,怎么这次就出现意外了?

于是上网查找问题所在。


    问题的搜索与解决:

    经过短暂的搜索发现了一个很有用的解决方法。

http://www.2cto.com/os/201111/112284.html 最小化安装CentOS6 VMware-tools安装几点注意事项

    其中这个内容的发现,让我隐约感觉到了问题所在。

    文章中提到这个问题的出现是由于缺少perl的支持,上面的报错内容就是说在/usr/bin/perl中找不到关于perl的支持。于是开始安装perl

1
yum groupinstall "Perl Support"

    在输入上述命令前还需要进行本地源的一些配置

    先删除/etc/yum.repos.d下的文件(目前我不知道为什么要删除只是知道这么做可以解决问题)

    然后创建/etc/yum.repos.d/CentOS-Media文件并进行相关配置

1
2
3
4
5
[名字] 起一个自己易识别的名字 
name=name  同上
baseurl=          将本地源指向挂在路径,这个需要自己事先创建并将本地源挂在其上 
gpgcheck=0                gpg的检查,0表示不自检,1表示自检。我选择不自检
enabled=1                 1表开启,0表关闭。因为我们是要使用本地源故设置为1

    上述工作都准备妥当就可以进行Perl Support的安装了。

    当perl安装完毕,vmtools就可以正常安装。

    问题解决。


    问题的后续思索:


    因为之前安装过6.x版本的redhat没有出现过相关问题,所以有点不明白为什么这次vmtools安装不上。

    不过我知道vmtools的最大作用是优化桌面环境,优化驱动,而Linux的最小化安装没有桌面,因此这可能是一部分原因,不过这应该是最表象的原因。

    因为我对于开发不太了解,但是还是知道点,vmtools在Linux中竟然会调用perl语言的支持,我想很大的可能是vmtools的开发使用了perl。

    之前在安装带有桌面的Linux从来没出现过这种问题,我想Linux的桌面应该也用到了perl环境,所以vmtools在带有桌面的Linux中安装没有问题。

    我不知道我的这种推测对还是不对,不过至少提出了一种假设等着自己去验证。










本文转自 紫色的茶碗 51CTO博客,原文链接:http://blog.51cto.com/chawan/1829532,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章