【高级】华为设备部署运营商网络架构-ISIS+BGP+IPv6理论及配置实战-阿里云开发者社区

开发者社区> 科技小先锋> 正文

【高级】华为设备部署运营商网络架构-ISIS+BGP+IPv6理论及配置实战

简介:
+关注继续查看

1.实验拓扑

      wKioL1Rz6wSyjYjEAAGBsKecBNs758.jpg

 使用ENSP模拟器(版本v100R002C001.2.00.350

2.实验需求

1)  通过ISISAS内部的直连和环回口路由宣告

2)  通过配置BGP协议将所有的用户业务路由宣告

3)  通过配置路由反射器实现市内、省内业务路由互传

4)  通过建立EBGP邻居实现全省和国干互联网路由互传

5)  通过巧妙配置黑洞路由实现用户业务网段聚合

6)  使用双协议栈方案实现ipv6网络平滑过渡现网方案实战

3.实验步骤

1)  IP规划

AR1接口ip地址:

GE0/0/0

12.0.0.1/30

AR5接口ip地址:

GE0/0/0

56.0.0.1/30


GE0/0/1

16.0.0.1/30


GE0/0/1

25.0.0.2/30


Loopback 0

1.1.1.1/32


Loopback 0

5.5.5.5/32

AR2接口ip地址

GE0/0/0

23.0.0.2/30

AR6接口ip地址

GE0/0/0

16.0.0.2/30


GE0/0/1   

25.0.0.1/30


GE0/0/1

56.0.0.2/30


GE0/0/2

26.0.0.1/30


GE0/0/2

26.0.0.2/30


GE6/0/0

23.0.0.1/30


GE6/0/0

67.0.0.1/30


Loopback 0

2.2.2.2/32


Loopback 0

6.6.6.6/32

AR3接口ip地址

GE0/0/0   

23.0.0.2/30

AR7接口ip地址

GE0/0/0

67.0.0.2/30


GE0/0/1   

37.0.0.1/30


GE0/0/1

37.0.0.2/30


GE0/0/2

34.0.0.1/30


GE0/0/2

78.0.0.1/30


Loopback 0

3.3.3.3/32


Loopback 0

7.7.7.7/32

AR4接口ip地址

GE0/0/0   

34.0.0.2/30

AR8接口ip地址

GE0/0/0   

78.0.0.2/30


GE0/0/1

48.0.0.1/30


GE0/0/1

48.0.0.2/30


Loopback 0

4.4.4.4/32


Loopback 0

8.8.8.8/32

2)配置脚本

  配置AS65001路由器中的各接口的ip地址,并启用isis路由协议

#R1的配置如下

------------------------以下是ip配置-----------------------

< R1>system-view         //进入系统视图

[R1]interface g0/0/0     //进接口

[R1-GigabitEthernet0/0/0]ipaddress 12.0.0.1 255.255.255.252    //配置ip地址和子网掩码

[R1-GigabitEthernet0/0/0]interfaceg0/0/1

[R1-GigabitEthernet0/0/1]ipaddress 16.0.0.1 255.255.255.252

[R1]interface loopback 0

[R1-LoopBack0]ipaddress 1.1.1.1 255.255.255.255

------------------------以下是isis路由配置-----------------------

[R1]routerid 1.1.1.1           //指定路由器的id

[R1]isis20                     //启用isis路由协议设置进程号为20

[R1-isis-20]is-level level-1    //设置路由器的级别为level-1

[R1-isis-20]net49.0020.0010.0100.1001.00//设置网络实体49AFI0020IDI区域信息0010.0100.1001system id00sel表示以太网

[R1]interface g0/0/0                      //进接口

[R1-GigabitEthernet0/0/0]isis enable 20   //调用进程号20isis协议

[R1-GigabitEthernet0/0/0]interface g0/0/1

[R1-GigabitEthernet0/0/1]isis enable 20

[R1-GigabitEthernet0/0/1]interface loopback 0

说明:

ISIS区域为两级结构的,level-1为内部区域,主要维护内部的路由,默认无法学习到区域间的路由。Level-2为中间区域,可以学习到内部的路由信息也可以学习到其他区域中的路由信息。Level-1-2在内部区域和中间区域之间,他即属于内部区域也属于中间区域,所以他同时维护着内部区域路由表和中间区域路由表

 

#R2的配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R2]router id 2.2.2.2

[R2]isis 20

[R2-isis-20]is-level level-1-2     //由于此路由即连接了L1又连接了L2所以他的级别为level-1-2

[R2-isis-20]net 49.0020.0020.0200.2002.00    

[R2]interface g0/0/0

[R2-GigabitEthernet0/0/0]isis enable 20

[R2-GigabitEthernet0/0/0]interface g0/0/1

[R2-GigabitEthernet0/0/1]isis enable 20

[R2-GigabitEthernet0/0/1]interface g0/0/2

[R2-GigabitEthernet0/0/2]isis enable 20

[R2-GigabitEthernet0/0/2]interface g6/0/0

[R2-GigabitEthernet6/0/0]isis enable 20

[R2]interface loopback 0

[R2-LoopBack0]isis enable 20

#R3配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R3]router id 3.3.3.3

[R3-isis-20]is-level level-2

[R3-isis-20]net 49.0010.0030.0300.3003.00        //下滑线部分为IDI

[R3-isis-20]interface g0/0/0

[R3-GigabitEthernet0/0/0]isis enable 20

[R3-GigabitEthernet0/0/0]interface g0/0/1

[R3-GigabitEthernet0/0/1]isis enable 20

[R3-GigabitEthernet0/0/1]interface g0/0/2

[R3-GigabitEthernet0/0/2]isis enable 20

[R3-GigabitEthernet0/0/2]interface loopback 0

[R3-LoopBack0]isis enable 20

 

说明:

level2区域中,不同的区域编号(IDI)是可以建立邻居关系的。但是在level-1中必须要相同的区域编号(IDI)才可以建立邻居关系。

 

#R5配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R5]routerid 5.5.5.5

[R5]isis 20

[R5-isis-20]is-level level-1

[R5-isis-20]net49.0020.0050.0500.5005.00

[R5-isis-20]interface g0/0/0

[R5-GigabitEthernet0/0/0]isis enable 20

[R5-GigabitEthernet0/0/0]interface g0/0/1

[R5-GigabitEthernet0/0/1]isisenable 20

[R5-GigabitEthernet0/0/1]interface loopback 0

[R5-LoopBack0]isisenable 20

#R6配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R6]routerid 6.6.6.6

[R6]isis 20

[R6-isis-20]is-level level-1-2

[R6-isis-20]net49.0020.0060.0600.6006.00

[R6-isis-20]interface g0/0/0

[R6-GigabitEthernet0/0/0]isisenable 20

[R6-GigabitEthernet0/0/0]interface g0/0/1

[R6-GigabitEthernet0/0/1]isis enable 20

[R6-GigabitEthernet0/0/1]interface g0/0/2

[R6-GigabitEthernet0/0/2]isisenable 20

[R6-GigabitEthernet0/0/2]interface g6/0/0

[R6-GigabitEthernet6/0/0]isis enable 20

[R6-GigabitEthernet6/0/0]interface loopback 0

[R6-LoopBack0]isisenable 20

#R7配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R7]router id 7.7.7.7

[R7]isis 20

[R7-isis-20]is-level level-2

[R7-isis-20]net 49.0010.0070.0700.7007.00

[R7-isis-20]interface g0/0/0

[R7-GigabitEthernet0/0/0]isis enable 20

[R7-GigabitEthernet0/0/0]interface g0/0/1

[R7-GigabitEthernet0/0/1]isis enable 20

[R7-GigabitEthernet0/0/1]interface loopback 0

[R7-LoopBack0]isis enable 20

#通过查看路由器的路由表是否学到所有的路由

[R7]display ip routing-table protocol isis

wKioL1Rz6aDDEd0nAAN6wNgAoDk403.jpg

说明已经学到了所有路由

  AS65002路由中通过OSPF内部网关协议,让所有路由器互通。

#R4配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是OSPF路由配置-----------------------

[R4]ospf 10          //开启ospf路由协议

[R4-ospf-10]area 0   //创建area 0区域

[R4-ospf-10-area-0.0.0.0]network 48.0.0.10.0.0.255 //area 0区域中通告链路网段

[R4-ospf-10-area-0.0.0.0]network 4.4.4.4 0.0.0.0     //area 0区域通告环回口地址

#R8配置如下

ip地址和R1的配置方法相同,此处略

------------------------以下是OSPF路由配置-----------------------

[R8]ospf 10

[R8-ospf-10]area 0

[R8-ospf-10-area-0.0.0.0]network 48.0.0.20.0.0.255

[R8-ospf-10-area-0.0.0.0]network 8.8.8.8 0.0.0.0

在路由器上面查看所学习的路由

wKiom1Rz6TvxZYn_AADPjKgFWco188.jpg

R8上面可以看到在R4上面所通告的路由,说明控制层数据已经连接了。

  通过BGP外部网关协议将所有的业务网段发送出去

#R1配置如下

------------------------以下是BGP路由配置-----------------------

[R1]bgp 65001        //开启bgp协议并指定AS(autonomoussystem)id

[R1-bgp]peer 2.2.2.2 as-number 65001   //手工指定邻居关系并指定对端的AS

[R1-bgp]peer 2.2.2.2 connect-interface loopback 0 //指定通过自己的环回口地址建立邻居

[R1-bgp]peer 6.6.6.6 as-number 65001

[R1-bgp]peer 6.6.6.6 connect-interface loopback 0

[R1-LoopBack0]isis enable 20

[R1-LoopBack0]interface loopback 10

[R1-LoopBack10]ip address 11.0.0.1 255.255.255.255      //模拟一个业务网段

[R1-LoopBack10]bgp 65001

[R1-bgp]network 11.0.0.1 32            //将业务网段通过bgp发送出去

 

说明:

BGP的邻居关系需要手动建立,在建立邻居过程中必须能够ping通对端的ip地址。由于BGP属于外部网关协议所以在建立邻居是需要指定对端的ASautonomous system)自治域系统编号。

由于环回口ip地址稳定性较高,所以在建立邻居时通常使用环回口ip地址。

 

#R2配置如下

------------------------以下是BGP路由配置-----------------------

[R2]bgp 65001

[R2-bgp]peer 1.1.1.1 as-number 65001

[R2-bgp]peer 1.1.1.1 connect-interfaceloopback 0

[R2-bgp]peer 5.5.5.5 as-number 65001

[R2-bgp]peer 5.5.5.5 connect-interface loopback 0

[R2-bgp]peer 6.6.6.6 as-number 65001

[R2-bgp]peer 6.6.6.6 connect-interfaceloopback 0

[R2-bgp]peer 3.3.3.3 as-number 65001

[R2-bgp]peer 3.3.3.3 connect-interface loopback 0

[R2-bgp]peer 7.7.7.7 as-number 65001

[R2-bgp]peer 7.7.7.7 connect-interface loopback 0

[R2-bgp]peer 1.1.1.1 reflect-client              //指定1.1.1.1为自己的客户端

[R2-bgp]peer 5.5.5.5 reflect-client

[R2-bgp]reflector cluster-id 1                   //设置群集号为

 

说明:

由于同一层的BARS设备比较多,不可能都建立成邻居关系。所以需要通过在上层设备上面做路由发射器,这样上层设备上面学习到的路由会传给自己的客户端

当建立了路由反射器之后,他的水平分割就被打乱了。所以需要设置群集号,这样客户端路由器则认为自己的上层有一个设备,上层设备的群集号要设置为相同。

 

#R3配置如下

------------------------以下是BGP路由配置-----------------------

[R3]bgp 65001

[R3-bgp]peer 1.1.1.1 as-number 65001

[R3-bgp]peer 1.1.1.1 connect-interfaceloopback 0

[R3-bgp]peer 2.2.2.2 as-number 65001

[R3-bgp]peer 2.2.2.2 connect-interfaceloopback 0

[R3-bgp]peer 5.5.5.5 as-number 65001

[R3-bgp]peer 5.5.5.5 connect-interface loopback 0

[R3-bgp]peer 6.6.6.6 as-number 65001

[R3-bgp]peer 6.6.6.6 connect-interfaceloopback 0

[R3-bgp]peer 7.7.7.7 as-number 65001

[R3-bgp]peer 7.7.7.7 connect-interface loopback 0

[R3]ip route-static 4.4.4.4 255.255.255.255 34.0.0.2 //由于R3R4是两个不同的AS所以他们之间没有启用ibgp则他们之间就不能互相学习到链路网段所以需要通过静态路由互相指定。

[R3]bgp 65001

[R3-bgp]peer 4.4.4.4 as-number 65002     //与不同的AS建立邻居是则为EBGP邻居

[R3-bgp]peer 4.4.4.4 connect-interfaceloopback 0

[R3-bgp]peer 4.4.4.4 ebgp-max-hop 2        //由于ebgp的默认跳数只有1当与loopback0建立邻居则需要2所以需要设置外部跳数为2

[R3-bgp]peer 1.1.1.1 next-hop-local    //指定下一跳地址为自己因为ebgp的下一跳始终为源路由器

[R3-bgp]peer 2.2.2.2 next-hop-local

[R3-bgp]peer 5.5.5.5 next-hop-local

[R3-bgp]peer 6.6.6.6 next-hop-local

[R3-bgp]peer 7.7.7.7 next-hop-local

#R4配置如下

------------------------以下是BGP路由配置-----------------------

[R4]bgp 65002

[R4-bgp]peer 8.8.8.8 as-number 65002

[R4-bgp]peer 8.8.8.8 connect-interfaceloopback 0

[R4]ip route-static 3.3.3.3 255.255.255.255 34.0.0.1

[R4]bgp 65002

[R4-bgp]peer 3.3.3.3 as-number 65001

[R4-bgp]peer 3.3.3.3 connect-interfaceloopback 0

[R4-bgp]peer 3.3.3.3 ebgp-max-hop 2

[R4]interface loopback 10

[R4-LoopBack10]ip address 44.0.0.4 255.255.255.255     //模拟业务网段

[R4]bgp 65002

[R4-bgp]network 44.0.0.4 32        //bgp中通过该业务网段

#R5配置如下

------------------------以下是BGP路由配置-----------------------

[R5]bgp 65001

[R5-bgp]peer 2.2.2.2 as-number 65001

[R5-bgp]peer 2.2.2.2 connect-interfaceloopback 0

[R5-bgp]peer 3.3.3.3 as-number 65001

[R5-bgp]peer 3.3.3.3 connect-interface loopback 0

[R5-bgp]peer 6.6.6.6 as-number 65001

[R5-bgp]peer 6.6.6.6 connect-interfaceloopback 0

[R5-bgp]peer 7.7.7.7 as-number 65001

[R5-bgp]peer 7.7.7.7 connect-interface loopback 0

#R6配置如下

------------------------以下是BGP路由配置-----------------------

[R6]bgp 65001

[R6-bgp]peer 1.1.1.1 as-number 65001

[R6-bgp]peer 1.1.1.1 connect-interfaceloopback 0

[R6-bgp]peer 2.2.2.2 as-number 65001

[R6-bgp]peer 2.2.2.2 connect-interfaceloopback 0

[R6-bgp]peer 3.3.3.3 as-number 65001

[R6-bgp]peer 3.3.3.3 connect-interface loopback 0

[R6-bgp]peer 5.5.5.5 as-number 65001

[R6-bgp]peer 5.5.5.5 connect-interface loopback 0

[R6-bgp]peer 7.7.7.7 as-number 65001

[R6-bgp]peer 7.7.7.7 connect-interface loopback 0

[R6-bgp]peer 1.1.1.1 reflect-client             

[R6-bgp]peer 5.5.5.5 reflect-client

[R6-bgp]reflector cluster-id 1 

#R7配置如下

------------------------以下是BGP路由配置-----------------------

[R7]bgp 65001

[R7-bgp]peer 1.1.1.1 as-number 65001

[R7-bgp]peer 1.1.1.1 connect-interfaceloopback 0

[R7-bgp]peer 2.2.2.2 as-number 65001

[R7-bgp]peer 2.2.2.2 connect-interfaceloopback 0

[R7-bgp]peer 3.3.3.3 as-number 65001

[R7-bgp]peer 3.3.3.3 connect-interfaceloopback 0

[R7-bgp]peer 5.5.5.5 as-number 65001

[R7-bgp]peer 5.5.5.5 connect-interface loopback 0

[R7-bgp]peer 6.6.6.6 as-number 65001

[R7-bgp]peer 6.6.6.6 connect-interface loopback 0

[R7]bgp 65001

[R7-bgp]peer 8.8.8.8 as-number 65002

[R7-bgp]peer 8.8.8.8 connect-interfaceloopback 0

[R7-bgp]peer 8.8.8.8 ebgp-max-hop 2

[R7-bgp]ip route-static 8.8.8.8 255.255.255.255 78.0.0.2

[R7-bgp]peer 1.1.1.1 next-hop-local

[R7-bgp]peer 2.2.2.2 next-hop-local

[R7-bgp]peer 5.5.5.5 next-hop-local

[R7-bgp]peer 6.6.6.6 next-hop-local

[R7-bgp]peer 3.3.3.3 next-hop-local

#R8配置如下

------------------------以下是BGP路由配置-----------------------

[R8]bgp 65002

[R8-bgp]peer 4.4.4.4 as-number 65002

[R8-bgp]peer 4.4.4.4 connect-interfaceloopback 0

[R8-bgp]peer 7.7.7.7 as-number 65001

[R8-bgp]peer 7.7.7.7 connect-interfaceloopback 0

[R8-bgp]peer 7.7.7.7 ebgp-max-hop 2

[R8]ip route-static 7.7.7.7255.255.255.255 78.0.0.1

通过查看路由表,看是否学到所有的路由

wKioL1Rz6c3iLw7AAAF5iEwcqfk777.jpg

 

说明:

同时也发现44.0.0.4并没有优化,这是因为isis路由协议在level-1区域中只有一条默认路由指向level-1-2路由,所以level-1区域中的路由器学习不到R3R7的链路网段。当bgp路由的下一跳在路由表中没有是则该路由不会优化,只有优化之后的路由才可以放到路由表中,执行路由转发。

 

通过在R2R6上面向level-1区域中注入level-2的路由明细,则level-1区域中的路由器会学习到区域间的路由

[R2]isis 20

[R2-isis-20]import-route isis level-2 into level-1   //level-2中的路由渗透到level-1

wKioL1Rz6d3zpocvAACqgkEzxig471.jpg

  BARS设备上面配置路由黑洞,将一个连续的网段发送出去。

#R1配置如下

------------------------以下是ip配置-----------------------

[R1]interface loopback 11

[R1-LoopBack11]ip address 218.0.0.1255.255.255.0       //R1上面模拟一段连续的业务网段

[R1-LoopBack11]interface loopback 12

[R1-LoopBack12]ip address 218.0.1.1255.255.255.0

[R1-LoopBack12]interface loopback 13

[R1-LoopBack13]ip address 218.0.2.1255.255.255.0

[R1-LoopBack13]interface loopback 14

[R1-LoopBack14]ip address 218.0.3.1 255.255.255.0

------------------------以下是网络汇总配置-----------------------

[R1]ip route-static 218.0.0.0 255.255.252.0 null 0    //由于bgp在发送路由时在路由表中必须存

在则该路由才会被发送出去。所以创建一个静态null 0 路由,当该网段的路由在路由表中没有上线则会被放入黑洞中。

[R1]bgp 65001

[R1-bgp]network 218.0.0.0 255.255.252.0   //将汇总后的网段发送出去

查看路由表中是否学习到R1通告的业务路由

wKiom1Rz6XHCpSk_AAFXVGva1uI131.jpg

  使用双协议栈方案实现ipv6网络平滑过渡现网

a)        Ipv6地址规划

AR1接口ip地址:

GE0/0/0

12::1/64

AR5接口ip地址:

GE0/0/0

56::1/64


GE0/0/1

16::1/64


GE0/0/1

25::2/64


Loopback 0

1::1/128


Loopback 0

5::5/128

AR2接口ip地址

GE0/0/0

12::2/64

AR6接口ip地址

GE0/0/0

16::2/64


GE0/0/1   

25::1/64


GE0/0/1

56::2/64


GE0/0/2

26::1/64


GE0/0/2

26::2/64


GE6/0/0

23::1/64


GE6/0/0

67::1/64


Loopback 0

2::2/128


Loopback 0

6::6/128

AR3接口ip地址

GE0/0/0   

23::2/64

AR7接口ip地址

GE0/0/0

67::2/64


GE0/0/1   

37::1/64


GE0/0/1

37::2/64


GE0/0/2

34::1/64


GE0/0/2

78::1/64


Loopback 0

3::3/128


Loopback 0

7::7/128

AR4接口ip地址

GE0/0/0   

34::2/64

AR8接口ip地址

GE0/0/0   

78::2/64


GE0/0/1

48::1/64


GE0/0/1

48::2/64


Loopback 0

4::4/128


Loopback 0

8::8/128

b)       AS65001区域中的路由器上面配置ipv6地址,配置ipv6isis内部网关协议

 #R1配置如下

------------------------以下是ip配置-----------------------

[R1]ipv6                    //路由器默认关闭ipv6功能所以要在system-view中打开此功能

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]ipv6 enable      //在接口中启用ipv6功能

[R1-GigabitEthernet0/0/0]ipv6 address 12::1/64   //在接口上面配置指定的ipv6 地址

[R1]interface g0/0/1

[R1-GigabitEthernet0/0/1]ipv6 enable

[R1-GigabitEthernet0/0/1]ipv6 address 16::1/64

[R1-GigabitEthernet0/0/1]interface loopback0

[R1-LoopBack0]ipv6 enable

[R1-LoopBack0]ipv6 address 1::1/128

------------------------以下是isis路由配置-----------------------

[R1]isis 20                     //进入isis视图

[R1-isis-20]ipv6 enable        //isis视图中启用ipv6功能

[R1-isis-20]interface g0/0/1

[R1-GigabitEthernet0/0/1]isis ipv6 enable20     //isis对应的接口上面启用Isis协议

[R1-GigabitEthernet0/0/1]interface g0/0/0

[R1-GigabitEthernet0/0/0]isis ipv6 enable20

[R1-GigabitEthernet0/0/0]interface loopback0

[R1-LoopBack0]isis ipv6 enable 20

#R2的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R2]isis 20

[R2-isis-20]ipv6 enable

[R2-isis-20]ipv6 import-route isis level-2 into level-1 //level-2中的路由渗透到level-1应为bgp在建立邻居时路由表中必须要有下一跳的路由条目这样bgp路由才会优化并放入路由表中。

[R2-isis-20]interface g0/0/0

[R2-GigabitEthernet0/0/0]isis ipv6 enable 20

[R2-GigabitEthernet0/0/0]interface g0/0/1

[R2-GigabitEthernet0/0/1]isis ipv6 enable20

[R2-GigabitEthernet0/0/1]interface g6/0/0

[R2-GigabitEthernet6/0/0]isis ipv6 enable 20

[R2-GigabitEthernet6/0/0]interface g0/0/2

[R2-GigabitEthernet0/0/2]isis ipv6 enable20

[R2-GigabitEthernet0/0/2]interface loopback 0

[R2-LoopBack0]isis ipv6 enable 20

#R3的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R3]isis 20

[R3-isis-20]ipv6 enable

[R3]interface g0/0/0

[R3-GigabitEthernet0/0/0]isis ipv6 enable 20

[R3-GigabitEthernet0/0/0]interface g0/0/1

[R3-GigabitEthernet0/0/1]isis ipv6 enable20

[R3-GigabitEthernet0/0/1]interface loopback0

[R3-LoopBack0]isis ipv6 enable 20

#R5的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R5]isis 20

[R5-isis-20]ipv6 enable

[R5-isis-20]interface g0/0/0

[R5-GigabitEthernet0/0/0]isis ipv6 enable20

[R5-GigabitEthernet0/0/0]interface g0/0/1

[R5-GigabitEthernet0/0/1]isis ipv6 enable 20

[R5-GigabitEthernet0/0/1]interface loopback0

[R5-LoopBack0]isis ipv6 enable 20

#R6的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R6]isis 20

[R6-isis-20]ipv6 enable

[R6-isis-20]ipv6 import-route isis level-2 into level-1

[R6-isis-20]interface g0/0/0

[R6-GigabitEthernet0/0/0]isis ipv6 enable 20

[R6-GigabitEthernet0/0/0]interface g0/0/1

[R6-GigabitEthernet0/0/1]isis ipv6 enable 20

[R6-GigabitEthernet0/0/1]interface g0/0/2

[R6-GigabitEthernet0/0/2]isis ipv6 enable 20

[R6-GigabitEthernet0/0/2]interface g6/0/0

[R6-GigabitEthernet6/0/0]isis ipv6 enable20

[R6-GigabitEthernet6/0/0]interface loopback0

[R6-LoopBack0]isis ipv6 enable 20

#R7的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是isis路由配置-----------------------

[R7]isis 20

[R7-isis-20]ipv6 enable

[R7-isis-20]interface g0/0/0

[R7-GigabitEthernet0/0/0]isis ipv6 enable 20

[R7-GigabitEthernet0/0/0]interface g0/0/1

[R7-GigabitEthernet0/0/1]isis ipv6 enable 20

[R7-GigabitEthernet0/0/1]interface loopback0

[R7-LoopBack0]isis ipv6 enable 20

查看ipv6的路由表,看是否已经学到所有的链路路由

[Huawei]display isis route ipv6

wKioL1Rz6oXTQ5CwAAGbXlXBMsI441.jpg

通过路由表说明已经学习到所有的路由

c)        AS65002区域路由上面配置ip地址,并启用ospfipv6功能

#R4的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是ospf路由配置-----------------------

[R4]ospfv3 10

[R4-ospfv3-10]router-id 4.4.4.4    //指定ospfv3协议中的路由id

[R4-ospfv3-10]interface g0/0/1

[R4-GigabitEthernet0/0/1]ospfv3 10 area 0     //在指定的接口上面启用ospfv3并指定所在区域

[R4-GigabitEthernet0/0/1]interface loopback0

[R4-LoopBack0]ospfv3 10 area 0

 

说明:

Ospfv3ospfv2的升级,主要区别就是ospfv3增加了ipv6的功能,但router id号任然为32位。Ospfv3是基于链路运行的,ospfv2是基于网段运行的。

#R8的配置如下

Ipv6地址和R1的配置方法相同,此处略

------------------------以下是ospf路由配置-----------------------

[R8]ospfv3 10           

[R8-ospfv3-10]router-id 8.8.8.8

[R8-ospfv3-10]interface loopback 0

[R8-LoopBack0]ospfv3 10 area 0

[R8-LoopBack0]interface g0/0/1

[R8-GigabitEthernet0/0/1]ospfv310 area 0

在路由器上面查看ospfv3路由表是否学到所有链路路由

wKioL1Rz6qDifRFhAAEjh2NDtcM463.jpg

从路由表中可以看出R4已经学习到R8的直连网段和环回口地址

d)       在所有路由器上面运行基于ipv6bgp协议,让所有路由在ipv6的环境中传递业务网段

#R1的配置如下

------------------------以下是bgp路由配置-----------------------

[R1]interface loopback 10

[R1-LoopBack10]ipv6 enable

[R1-LoopBack10]ipv6 address 11::1 128     //模拟ipv6的业务网段

[R1]bgp 65001

[R1-bgp]peer 2::2 as-number 65001         //指定建立邻居的ipv6地址并指定端口号

[R1-bgp]peer 2::2 connect-interfaceloopback 0//ipv6模式下告诉自己的邻居和自己环回口建邻居

[R1-bgp]peer 3::3 as-number 65001

[R1-bgp]peer 3::3 connect-interfaceloopback 0

[R1-bgp]peer 6::6 as-number 65001

[R1-bgp]peer 6::6 connect-interfaceloopback 0

[R1-bgp]peer 7::7 as-number 65001

[R1-bgp]peer 7::7 connect-interface loopback 0

[R1-bgp]ipv6-family unicast            //进入ipv6地址族模式

[R1-bgp-af-ipv6]peer 2::2 enable          //ipv6地址族模式中启用2::2邻居

[R1-bgp-af-ipv6]peer 3::3 enable

[R1-bgp-af-ipv6]peer 6::6 enable

[R1-bgp-af-ipv6]peer 7::7 enable

#R2的配置如下

------------------------以下是bgp路由配置-----------------------

[R2]bgp 65001

[R2-bgp]peer 1::1 as-number 65001

[R2-bgp]peer 1::1 connect-interfaceloopback 0

[R2-bgp]peer 5::5 as-number 65001

[R2-bgp]peer 5::5 connect-interfaceloopback 0

[R2-bgp]peer 3::3 as-number 65001

[R2-bgp]peer 3::3 connect-interfaceloopback 0

[R2-bgp]peer 6::6 as-number 65001

[R2-bgp]peer 6::6 connect-interfaceloopback 0

[R2-bgp]peer 7::7 as-number 65001

[R2-bgp]peer 7::7 connect-interface loopback 0

[R2]bgp 65001

[R2-bgp]ipv6-family unicast

[R2-bgp-af-ipv6]peer 1::1 enable

[R2-bgp-af-ipv6]peer 3::3 enable

[R2-bgp-af-ipv6]peer 5::5 enable

[R2-bgp-af-ipv6]peer 6::6 enable

[R2-bgp-af-ipv6]peer 7::7 enable

#R3的配置如下

------------------------以下是bgp路由配置-----------------------

[R3]bgp 65001

[R3-bgp]peer 1::1 as-number 65001

[R3-bgp]peer 1::1 connect-interfaceloopback 0

[R3-bgp]peer 5::5 as-number 65001

[R3-bgp]peer 5::5 connect-interfaceloopback 0

[R3-bgp]peer 2::2 as-number 65001

[R3-bgp]peer 2::2 connect-interface loopback0

[R3-bgp]peer 6::6 as-number 65001

[R3-bgp]peer 6::6 connect-interfaceloopback 0

[R3-bgp]peer 7::7 as-number 65001

[R3-bgp]peer 7::7 connect-interface loopback 0

[R3-bgp]peer 4::4 as-number 65002

[R3-bgp]peer 4::4 connect-interfaceloopback 0

[R3-bgp]peer 4::4 ebgp-max-hop 2       //设置外部路由的最大跳数为2特性跟ipv4是一样的

[R3-bgp]ipv6-family unicast

[R3-bgp-af-ipv6]peer 4::4 enable

[R3-bgp-af-ipv6]peer 2::2 enable

[R3-bgp-af-ipv6]peer 1::1 enable

[R3-bgp-af-ipv6]peer 5::5 enable

[R3-bgp-af-ipv6]peer 6::6 enable

[R3-bgp-af-ipv6]peer 7::7 enable

[R3-bgp-af-ipv6]peer 1::1 next-hop-local  //设置ebgp的下一跳地址为自己

[R3-bgp-af-ipv6]peer 2::2 next-hop-local

[R3-bgp-af-ipv6]peer 7::7 next-hop-local

[R3-bgp-af-ipv6]peer 5::5 next-hop-local

[R3-bgp-af-ipv6]peer 6::6 next-hop-local

[R3]ipv6 route-static 4::4 128 34::2  //由于R3R4在不同的AS因此没有链路网段这里需要指定静态路由。

 

说明:

所谓地址族,就是把ipv4ipv6vpnv4分成不同的,对每个单独进行配置

#R4的配置如下

------------------------以下是bgp路由配置-----------------------

[R4]bgp 65002

[R4-bgp]peer 3::3 as-number 65001

[R4-bgp]peer 3::3 connect-interfaceloopback 0

[R4-bgp]peer 3::3 ebgp-max-hop 2

[R4-bgp]peer 8::8 as-number 65002

[R4-bgp]peer 8::8 connect-interfaceloopback 0

[R4-bgp]ipv6-family unicast

[R4-bgp-af-ipv6]peer 3::3 enable

[R4-bgp-af-ipv6]peer 8::8 enable

[R4-bgp]ipv6 route-static 3::3 128 34::1

#R5的配置如下

------------------------以下是bgp路由配置-----------------------

[R5]bgp 65001

[R5-bgp]peer 2::2 as-number 65001

[R5-bgp]peer 2::2 connect-interfaceloopback 0

[R5-bgp]peer 3::3 as-number 65001

[R5-bgp]peer 3::3 connect-interfaceloopback 0

[R5-bgp]peer 6::6 as-number 65001

[R5-bgp]peer 6::6 connect-interfaceloopback 0

[R5-bgp]peer 7::7 as-number 65001

[R5-bgp]peer 7::7 connect-interface loopback 0

[R5]bgp 65001

[R5-bgp]ipv6-family unicast

[R5-bgp-af-ipv6]peer 2::2 enable

[R5-bgp-af-ipv6]peer 3::3 enable

[R5-bgp-af-ipv6]peer 6::6 enable

[R5-bgp-af-ipv6]peer 7::7 enable

#R6的配置如下

------------------------以下是bgp路由配置-----------------------

[R6]bgp 65001

[R6-bgp]peer 1::1 as-number 65001

[R6-bgp]peer 1::1 connect-interfaceloopback 0

[R6-bgp]peer 5::5 as-number 65001

[R6-bgp]peer 5::5 connect-interfaceloopback 0

[R6-bgp]peer 3::3 as-number 65001

[R6-bgp]peer 3::3 connect-interfaceloopback 0

[R6-bgp]peer 2::2 as-number 65001

[R6-bgp]peer 2::2 connect-interfaceloopback 0

[R6-bgp]peer 7::7 as-number 65001

[R6-bgp]peer 7::7 connect-interface loopback 0

[R6]bgp 65001

[R6-bgp]ipv6-family unicast

[R6-bgp-af-ipv6]peer 1::1 enable

[R6-bgp-af-ipv6]peer 3::3 enable

[R6-bgp-af-ipv6]peer 5::5 enable

[R6-bgp-af-ipv6]peer 2::2 enable

[R6-bgp-af-ipv6]peer 7::7 enable

#R7的配置如下

------------------------以下是bgp路由配置-----------------------

[R7]bgp 65001

[R7-bgp]peer 1::1 as-number 65001

[R7-bgp]peer 1::1 connect-interfaceloopback 0

[R7-bgp]peer 5::5 as-number 65001

[R7-bgp]peer 5::5 connect-interfaceloopback 0

[R7-bgp]peer 2::2 as-number 65001

[R7-bgp]peer 2::2 connect-interfaceloopback 0

[R7-bgp]peer 6::6 as-number 65001

[R7-bgp]peer 6::6 connect-interfaceloopback 0

[R7-bgp]peer 3::3 as-number 65001

[R7-bgp]peer 3::3 connect-interface loopback 0

[R7-bgp]peer 8::8 as-number 65002

[R7-bgp]peer 8::8 connect-interfaceloopback 0

[R7-bgp]peer 8::8 ebgp-max-hop 2

[R7-bgp]ipv6-family unicast

[R7-bgp-af-ipv6]peer 2::2 enable

[R7-bgp-af-ipv6]peer 1::1 enable

[R7-bgp-af-ipv6]peer 5::5 enable

[R7-bgp-af-ipv6]peer 6::6 enable

[R7-bgp-af-ipv6]peer 3::3 enable

[R7-bgp-af-ipv6]peer 8::8 enable

[R7-bgp-af-ipv6]peer 1::1 next-hop-local

[R7-bgp-af-ipv6]peer 2::2 next-hop-local

[R7-bgp-af-ipv6]peer 3::3 next-hop-local

[R7-bgp-af-ipv6]peer 5::5 next-hop-local

[R7-bgp-af-ipv6]peer 6::6 next-hop-local

[R7]ipv6 route-static 8::8 128 78::2

#R8的配置如下

------------------------以下是bgp路由配置-----------------------

[R8]bgp 65002

[R8-bgp]peer 4::4 as-number 65002

[R8-bgp]peer 4::4 connect-interfaceloopback 0

[R8-bgp]peer 7::7 as-number 65001

[R8-bgp]peer 7::7 connect-interface loopback 0

[R8-bgp]peer 7::7 ebgp-max-hop 2

[R8-bgp]ipv6 route-static 7::7 128 78::1

通过displaybgp ipv6 peer查看路由器之间是否已经建立器邻居关系

wKiom1Rz6j2ze5ASAAFEBw_9Byg237.jpg

建立了邻居之后下面测试一下在ipv4ipv6下面的业务网段是否都可以ping

wKioL1Rz6s6AWtKEAAM4GJ_5r1k088.jpg

R1上面通过ipv4ipv6两种模式ping R4的业务网段都是通的,说明现网具备了从ipv4ipv6平滑过渡的需求。



本文转自Y.weisheng 51CTO博客,原文链接:http://blog.51cto.com/yuan2/1582280,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
《Drupal实战》——1.4 常见配置
本节书摘来自华章计算机《Drupal实战》一书中的第1章,第1.4节,作者 葛红儒,更多章节内容可以访问云栖社区“华章计算机”公众号查看。
946 0
《VMware vSphere企业运维实战》——2.2 VMware ESXi 5控制台设置
相比VMware ESX Server,VMware ESXi 5的控制台更加精简、高效、方便,管理员可以直接在VMware ESXi 5控制台界面中完成管理员密码的修改、控制台管理地址的设置与修改、VMware ESXi主机名称的修改、重启系统配置(恢复VMware ESXi默认设置)等功能。
2284 0
Spring Boot外部化配置实战解析
源码解析Spring Boot外部化配置实战。
9360 0
在Solaris网络部署HIDS配置实战
http://www.chineselinuxuniversity.net/articles/14912.shtml
611 0
6967
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载