一、目的:在通过帧中继网络通信的两台路由器之间实现验证功能(封装类型为帧中继的串行接口不能进行PPP验证,使用Virtual-Template来实现)。
二、实验拓扑图:
二、实验拓扑图:
三、具体配置:
1、路由器R1:
username R1 password 0 00830725
!
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay interface-dlci 102 ppp Virtual-Template10 (将虚拟模板与本地dlci值关联)
no frame-relay inverse-arp
!
!
interface Virtual-Template10
bandwidth 1544
ip address 192.168.1.1 255.255.255.0
ppp authentication pap
!
1、路由器R1:
username R1 password 0 00830725
!
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay interface-dlci 102 ppp Virtual-Template10 (将虚拟模板与本地dlci值关联)
no frame-relay inverse-arp
!
!
interface Virtual-Template10
bandwidth 1544
ip address 192.168.1.1 255.255.255.0
ppp authentication pap
!
2、路由器R2:
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay interface-dlci 201 ppp Virtual-Template10 (将虚拟模板与本地dlci值关联)
no frame-relay inverse-arp
!
!
interface Virtual-Template10
bandwidth 1544
ip address 192.168.1.2 255.255.255.0
ppp pap sent-username R1 password 0 00830725
!
四、验证
1. sh ip int bri (查看接口状态)
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay interface-dlci 201 ppp Virtual-Template10 (将虚拟模板与本地dlci值关联)
no frame-relay inverse-arp
!
!
interface Virtual-Template10
bandwidth 1544
ip address 192.168.1.2 255.255.255.0
ppp pap sent-username R1 password 0 00830725
!
四、验证
1. sh ip int bri (查看接口状态)
virtual-template接口的状态永远为down/down,主要看virtual-template生成的virtual-access的值为UP/UP则接口启用。
2.ping
2.ping
3.sh frame-relay pvc
4.查看virtual-access 1的状态
sh int virtual-access 1
sh int virtual-access 1
五、附录:
pap 认证过程
服务端:
R1#
*Mar 1 00:36:40.599: Vi1 PPP: Using default call direction
*Mar 1 00:36:40.599: Vi1 PPP: Treating connection as a dedicated line
*Mar 1 00:36:40.599: Vi1 PPP: Session handle[B000001C] Session id[54]
*Mar 1 00:36:40.603: Vi1 PPP: Authorization required
*Mar 1 00:36:40.959: Vi1 PAP: I AUTH-REQ id 4 len 16 from "R1"
*Mar 1 00:36:40.959: Vi1 PAP: Authenticating peer R1
*Mar 1 00:36:40.963: Vi1 PPP: Sent PAP LOGIN Request
*Mar 1 00:36:40.967: Vi1 PPP: Received LOGIN Response PASS
*Mar 1 00:36:40.971: Vi1 PPP: Sent LCP AUTHOR Request
*Mar 1 00:36:40.975: Vi1 PPP: Sent IPCP AUTHOR Request
*Mar 1 00:36:40.979: Vi1 LCP: Received AAA AUTHOR Response PASS
*Mar 1 00:36:40.983: Vi1 IPCP: Received AAA AUTHOR Response PASS
*Mar 1 00:36:40.983: Vi1 PAP: O AUTH-ACK id 4 len 5
*Mar 1 00:36:41.199: Vi1 PPP: Sent IPCP AUTHOR Request
R1#
*Mar 1 00:36:41.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
*Mar 1 00:36:41.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
pap 认证过程
服务端:
R1#
*Mar 1 00:36:40.599: Vi1 PPP: Using default call direction
*Mar 1 00:36:40.599: Vi1 PPP: Treating connection as a dedicated line
*Mar 1 00:36:40.599: Vi1 PPP: Session handle[B000001C] Session id[54]
*Mar 1 00:36:40.603: Vi1 PPP: Authorization required
*Mar 1 00:36:40.959: Vi1 PAP: I AUTH-REQ id 4 len 16 from "R1"
*Mar 1 00:36:40.959: Vi1 PAP: Authenticating peer R1
*Mar 1 00:36:40.963: Vi1 PPP: Sent PAP LOGIN Request
*Mar 1 00:36:40.967: Vi1 PPP: Received LOGIN Response PASS
*Mar 1 00:36:40.971: Vi1 PPP: Sent LCP AUTHOR Request
*Mar 1 00:36:40.975: Vi1 PPP: Sent IPCP AUTHOR Request
*Mar 1 00:36:40.979: Vi1 LCP: Received AAA AUTHOR Response PASS
*Mar 1 00:36:40.983: Vi1 IPCP: Received AAA AUTHOR Response PASS
*Mar 1 00:36:40.983: Vi1 PAP: O AUTH-ACK id 4 len 5
*Mar 1 00:36:41.199: Vi1 PPP: Sent IPCP AUTHOR Request
R1#
*Mar 1 00:36:41.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
*Mar 1 00:36:41.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
客户端:
R2#
*Mar 1 00:36:28.359: Vi1 PPP: Authorization required
*Mar 1 00:36:28.471: Vi1 PPP: No authorization without authentication
*Mar 1 00:36:28.471: Vi1 PAP: Using hostname from interface PAP
*Mar 1 00:36:28.471: Vi1 PAP: Using password from interface PAP
*Mar 1 00:36:28.475: Vi1 PAP: O AUTH-REQ id 4 len 16 from "R1"
*Mar 1 00:36:28.723: Vi1 PAP: I AUTH-ACK id 4 len 5
R2#
*Mar 1 00:36:28.359: Vi1 PPP: Authorization required
*Mar 1 00:36:28.471: Vi1 PPP: No authorization without authentication
*Mar 1 00:36:28.471: Vi1 PAP: Using hostname from interface PAP
*Mar 1 00:36:28.471: Vi1 PAP: Using password from interface PAP
*Mar 1 00:36:28.475: Vi1 PAP: O AUTH-REQ id 4 len 16 from "R1"
*Mar 1 00:36:28.723: Vi1 PAP: I AUTH-ACK id 4 len 5
本文转自 tiger506 51CTO博客,原文链接:http://blog.51cto.com/tiger506/153716,如需转载请自行联系原作者