贪心初步-FatMouse' Trade

简介: 这道题是真的很简单,只需要用优先队列以单位价值作为排序规则就可以解决。 FatMouse' Trade Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total...

这道题是真的很简单,只需要用优先队列以单位价值作为排序规则就可以解决。

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46804    Accepted Submission(s): 15704


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
 
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
 
 
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining
 
附上代码:

#include <cstdio>
#include<queue>
#define maxn 1005;
using namespace std;

struct Food{
	int hav,ned;
	double va;
};

bool operator < (struct Food a,struct Food b){
	if(a.va < b.va)
		return	true;
	else
		return	false;
}
int main(){
	int m,n;
	struct Food	ha[1005];
	while(scanf("%d %d",&m,&n) && m!=-1&&n!=-1){
		priority_queue<struct Food> lis;
		for(int i = 0;i < n;i++){
			scanf("%d %d",&ha[i].hav,&ha[i].ned);
		}
		for(int i = 0;i < n;i++){
			ha[i].va = ha[i].hav*1.0/ha[i].ned;
			lis.push(ha[i]);
		}
		double cnt = 0.0;
		while(!lis.empty() && m){
			struct	Food t;
			t = lis.top();
			if(m >= t.ned){
				m -= t.ned;
				cnt += t.hav;
				lis.pop();
			}else{
				cnt += t.va * m;
				m = 0;
				lis.pop();
			}
		}
		printf("%.3f\n",cnt);
	}
	return	0;
}


相关文章
|
算法 C++ Python
每日算法系列【LeetCode 926】将字符串翻转到单调递增
每日算法系列【LeetCode 926】将字符串翻转到单调递增
|
C++
Early Orders单调栈
大体思路: 用pos数组来记录每个数出现的最后的位置 然后遍历每一个数组元素,如果当前元素已经被标记过了(已经被使用),那么就跳过这次循环 设遍历数组元素的时候,将这个数组的下标记为 i ,值的大小为 x 当栈里面有元素,并且栈顶的元素大于x,并且栈顶这个数最后出现的位置大于当前这个数最后出现的位置 i ,那么说明栈里面这一数列就不是最优的,就可以将当前的元素x替换掉栈顶元素,先pop(),然后将这个数标记为 0 ,–>未使用 如果当上述条件一直满足的时候,可以一直进行上面的操作 知道不满足题意,然后讲当前这个数放到栈的顶端
92 0
Early Orders单调栈
|
算法
杭电oj 猫和老鼠的交易 HDOJ 1009--FatMouse‘ Trade 法特穆斯贸易 贪心算法
杭电oj 猫和老鼠的交易 HDOJ 1009--FatMouse‘ Trade 法特穆斯贸易 贪心算法
227 0
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
Go
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
HDOJ/HDU 1133 Buy the Ticket(数论~卡特兰数~大数~)
116 0
【1146】Topological Order (25分)【拓扑排序】
【1146】Topological Order (25分)【拓扑排序】 【1146】Topological Order (25分)【拓扑排序】
107 0
HDOJ/HDU 2566 统计硬币(公式~遍历~)
HDOJ/HDU 2566 统计硬币(公式~遍历~)
159 0