zzu--2014年11月16日月潭赛 C称号

简介:

1230: Magnets

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 24   Solved: 13
[ Submit][ Status][ Web Board]

Description

Mad scientist Mike entertains himself by arranging rows of dominoes. He doesn't need dominoes, though: he uses rectangular magnets instead. Each magnet has two poles, positive (a "plus") and negative (a "minus"). If two magnets are put together at a close distance, then the like poles will repel each other and the opposite poles will attract each other.

Mike starts by laying one magnet horizontally on the table. During each following step Mike adds one more magnet horizontally to the right end of the row. Depending on how Mike puts the magnet on the table, it is either attracted to the previous one (forming a group of multiple magnets linked together) or repelled by it (then Mike lays this magnet at some distance to the right from the previous one). We assume that a sole magnet not linked to others forms a group of its own.

Mike arranged multiple magnets in a row. Determine the number of groups that the magnets formed.

Input

The first line of the input contains an integer n (1 <= n <= 100000) ---- the number of magnets. Then n lines follow. The i-th line (1 <= i <= n) contains either characters "01", if Mike put the i-thmagnet in the "plus-minus" position, or characters "10", if Mike put the magnet in the "minus-plus" position.

Output

On the single line of the output print the number of groups of magnets.

Sample Input

6
1 0
10
10
01
10
10
4
01
01
1 0
10

Sample Output

3
2

HINT

The first testcase corresponds to the figure. The testcase has three groups consisting of three, one and two magnets.


The second testcase has two groups, each consisting of two magnets.

Source

CF


题意:就是去求一堆磁铁能分成几段!


大水题AC代码:

#include <stdio.h>

int main()
{
    char a[3];
    int n;
    while(scanf("%d", &n) != EOF)
    {
                      scanf("%s", a);
                      n--;
                      char cur = a[1];
                      int ans=1;
                      while(n--)
                      {
                                scanf("%s", a);
                                if(a[0] == cur)
                                {
                                        ans++;
                                        cur = a[1];
                                }
                      }
                      printf("%d\n", ans);
    }
    return 0;
}




版权声明:本文博客原创文章,博客,未经同意,不得转载。


本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4632972.html,如需转载请自行联系原作者


相关文章
|
C++
2019 第十届蓝桥杯大赛软件赛决赛,国赛,C/C++大学B组题解
2019 第十届蓝桥杯大赛软件赛决赛,国赛,C/C++大学B组题解
274 0
|
2月前
|
算法 安全 Shell
2024i春秋第四届长城杯网络安全大赛暨京津冀网络安全技能竞赛初赛wp-flowershop+easyre
2024i春秋第四届长城杯网络安全大赛暨京津冀网络安全技能竞赛初赛wp-flowershop+easyre
183 1
|
7月前
|
网络安全 数据安全/隐私保护 XML
2024“天一永安杯“宁波第七届网络安全大赛极安云科战队部分WP
2024“天一永安杯“宁波第七届网络安全大赛极安云科战队部分WP
2024“天一永安杯“宁波第七届网络安全大赛极安云科战队部分WP
|
7月前
|
存储 安全 计算机视觉
参加第十二届中国软件杯比赛感想以及经验
今年我作为参赛选手参加了中国软件杯南京线下赛,参加了总决赛答辩环节,下面总结一些参加比赛的经验以及感受
|
7月前
|
前端开发 JavaScript API
中国农村大学生学习了这个【React教程】迎娶导师女儿,出任CEO走上人生巅峰
中国农村大学生学习了这个【React教程】迎娶导师女儿,出任CEO走上人生巅峰
68 0
2022年9月月赛乙组 T3.棋盘问题
2022年9月月赛乙组 T3.棋盘问题
|
供应链 安全 搜索推荐
最新动态 | 长江商学院、清华五道口金融学院校友走进阿里
最新动态 | 长江商学院、清华五道口金融学院校友走进阿里
120 0
|
测试技术 C++ Windows
2021 第十二届蓝桥杯大赛软件赛决赛, 国赛,C/C++ 大学B 组
2021 第十二届蓝桥杯大赛软件赛决赛, 国赛,C/C++ 大学B 组
178 1
|
机器学习/深度学习 人工智能 算法
四所中国高校夺冠三大赛道,这场24个国家2500多支队伍角逐的算法竞赛刚刚落幕
可以「欺骗」神经网络的对抗样本是近期计算机视觉,以及机器学习领域的热门研究方向。为了让 AI 能够抵御攻击,研究人员一直在寻找构建稳固机器学习算法的道路。最近,在国际顶级人工智能大会 IJCAI 上,一场有关人工智能安全的攻防战落下了帷幕。
212 0
四所中国高校夺冠三大赛道,这场24个国家2500多支队伍角逐的算法竞赛刚刚落幕
|
程序员 iOS开发 开发者
2013中国新媒体创业大赛昨决赛,SegmentFault 成为决赛的最大黑马
浙江在线07月29日讯 比新意,比架构,比商业模式。昨天由浙江日报报业集团主办,传媒梦工场承办的2013中国新媒体创业大赛全国总决赛在杭州举行。来自北京、上海、深圳、成都、武汉、南京、杭州、厦门等八大赛区的20支创业团队,带着他们不同领域的项目,各自在短短的15分钟内,亮出绝招吸引评委,博得喝彩。
144 0
2013中国新媒体创业大赛昨决赛,SegmentFault 成为决赛的最大黑马