【maven】pom.xml文件没错,但是项目有小红叉,Problems中可以看到错误:“Dynamic Web Module 3.0 requires Java 1.6 or newer.”-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

【maven】pom.xml文件没错,但是项目有小红叉,Problems中可以看到错误:“Dynamic Web Module 3.0 requires Java 1.6 or newer.”

简介:   解决方法: 1.将 1 2 org.apache.maven.plugins 3 maven-compiler-plugin 4 2.

 

解决方法:

1.将

1 <plugin>  
2             <groupId>org.apache.maven.plugins</groupId>  
3             <artifactId>maven-compiler-plugin</artifactId>  
4             <version>2.3.2</version>  
5             <configuration>  
6                 <source>1.8</source>  
7                 <target>1.8</target>  
8             </configuration>  
9         </plugin>
View Code

插入在这个位置

 

2.

在ecplise上:保存,项目构建完成后在项目文件夹上点右键,选择Maven->Update Project Configuration,问题解决。

在myecplise上:

 

 

问题解决:

 

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章