解决 php-cgi 启动时提示缺少 msvcr110.dll 的问题-阿里云开发者社区

开发者社区> 安全> 正文

解决 php-cgi 启动时提示缺少 msvcr110.dll 的问题

简介: 问题描述: 启动 php-cgi 时如果提示缺少 msvcr110.dll问题原因: 缺少 vc 2012 运行库   问题解决: 需要安装 vcredist_x64.exe 或 vcredist_x86.
问题描述

启动 php-cgi 时如果提示缺少 msvcr110.dll

问题原因

缺少 vc 2012 运行库
 
问题解决
需要安装 vcredist_x64.exe 或 vcredist_x86.exe
 
下载地址:
http://www.microsoft.com/zh-cn/download/details.aspx?id=30679
 
---------------------------------------------------------------------------------------------------
http://windows.php.net/download/
打开这个链接, 我们看到一系列的下载地址, 以下是一一解释:
VC11 x86 Non Thread Safe (vc11 非线程安全)
VC11 x86 Thread Safe (vc11 线程安全)
VC9 x86 Non Thread Safe
VC9 x86 Thread Safe
VC6 x86 Non Thread Safe

注意看左侧的说明. VC9 and VC11, 
Visual Studio 2005 是vc6.
Visual Studio 2008 是vc9.
Visual Studio 2010 是vc10
Visual Studio 2012 是vc11
以此类推, 如果需要使用php 5.5.0 VC11 x86 Non Thread Safe 那么肯定需要安装vc11

目前vc11已经释放出update 3的安装包, 可以完美兼容php 5.5.0

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
+ 订阅

云安全开发者的大本营

其他文章