poj1979 Red and Black【搜索】

简介: 点击打开题目 Red and Black Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 23194   Accepted: 12513 Description ...

点击打开题目

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23194   Accepted: 12513

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题目翻译:给出一个m*n的图,然后‘.’代表可以走的路线,‘@’代表起点,‘#’代表墙,不能走,

求:算上起点,一共有多少格子可以走?

解题思路:dfs搜索!

#include<cstdio>
int m,n,x1,y1,cot;
char G[22][22];
int mov[][2]={0, 1, 0, -1, -1, 0, 1, 0};
void dfs(int x,int y){
    G[x][y]='#';
    int i,X,Y;
    for(i=0;i<4;i++){
        X=x+mov[i][0];
        Y=y+mov[i][1];
        if(G[X][Y]!='#'&&X>=0&&X<n&&Y>=0&&Y<m){
            cot++;
            dfs(X,Y);
        }
    }
}
int main(){
    int i,j;
    while(scanf("%d%d",&m,&n),m|n){
        for(i=0;i<n;++i)
            scanf("%s",G[i]);
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
                if(G[i][j]=='@'){
                    x1=i;y1=j;
                }
        cot=1;
        dfs(x1,y1);
        printf("%d\n",cot);
    }
    return 0;
}


目录
相关文章
|
机器学习/深度学习 算法
Fox and Cross(#228(div2)B. )(四周上搜索)
Fox and Cross(#228(div2)B. )(四周上搜索)
38 0
|
算法 安全 Swift
LeetCode - #33 搜索旋转排序数组(Top 100)
不积跬步,无以至千里;不积小流,无以成江海,Swift社区 伴你前行。如果大家有建议和意见欢迎在文末留言,我们会尽力满足大家的需求。
|
算法 安全 Swift
LeetCode - #31 下一个排列 (Top 100)
不积跬步,无以至千里;不积小流,无以成江海,Swift社区 伴你前行。如果大家有建议和意见欢迎在文末留言,我们会尽力满足大家的需求。
|
C++
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
106 0
CodeForces - 1469B Red and Blue (前缀和)
CodeForces - 1469B Red and Blue (前缀和)
104 0
|
机器学习/深度学习 Windows
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
Codeforces Round #748 (Div. 3) F - Red-Black Number (记忆化搜索)
105 0
|
前端开发
由Google搜索页引发对box-shadow的使用和技巧总结
CSS3的box-shadow有点类似于text-shadow,只不过不同的是text-shadow是对象的文本设置阴影,而box-shadow是给对象实现图层阴影效果。(本文我们搁下IE不谈,只谈谈box-shadow的具体使用方法)
1416 0