poj1979 Red and Black【搜索】

简介: 点击打开题目 Red and Black Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 23194   Accepted: 12513 Description ...

点击打开题目

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23194   Accepted: 12513

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题目翻译:给出一个m*n的图,然后‘.’代表可以走的路线,‘@’代表起点,‘#’代表墙,不能走,

求:算上起点,一共有多少格子可以走?

解题思路:dfs搜索!

#include<cstdio>
int m,n,x1,y1,cot;
char G[22][22];
int mov[][2]={0, 1, 0, -1, -1, 0, 1, 0};
void dfs(int x,int y){
    G[x][y]='#';
    int i,X,Y;
    for(i=0;i<4;i++){
        X=x+mov[i][0];
        Y=y+mov[i][1];
        if(G[X][Y]!='#'&&X>=0&&X<n&&Y>=0&&Y<m){
            cot++;
            dfs(X,Y);
        }
    }
}
int main(){
    int i,j;
    while(scanf("%d%d",&m,&n),m|n){
        for(i=0;i<n;++i)
            scanf("%s",G[i]);
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
                if(G[i][j]=='@'){
                    x1=i;y1=j;
                }
        cot=1;
        dfs(x1,y1);
        printf("%d\n",cot);
    }
    return 0;
}


目录
相关文章
|
6月前
|
Java
hdu-1312-Red and Black
hdu-1312-Red and Black
33 0
poj 2362 hdoj 1518 Square(搜索)
不难了解,小棒子的长度越长,其灵活性越差。例如长度为5的一根棒子的组合方式要比5根长度为1的棒子的组合方式少,这就是灵活性的体现。
47 0
|
机器学习/深度学习 算法
Fox and Cross(#228(div2)B. )(四周上搜索)
Fox and Cross(#228(div2)B. )(四周上搜索)
32 0
HDU - 1312 Red and Black(DFS)
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. Write a program to count the number of black
83 0
hdu 1312 Red and Black(BFS)
hdu 1312 Red and Black(BFS)
144 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
150 0