HDU 1076(第n个生日在哪一年)

简介: Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party.

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

 

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

 

Note:

if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input

3

2005 25

1855 12

2004 10000

 

Sample Output

2108

1904

43236

/*
该题N定义为50000RE,100000AC
因为该题year没范围,但因为要可以求第10000个生日,
所以 year的范围也绝对不会是INT_MAX,
考虑到不知year的范围,先试用is_leap(int year) 函数判断
闰年,不用初始化,若超时,再按我这种方法
*/ 
#include<string.h>
#include<stdlib.h>
#define N 100000
int leap[N];
void isleap()
{
    int i,j;
    memset(leap,0,sizeof(leap));
    for(i=1;i<N;i++)
    if(i%4==0&&i%100!=0||i%400==0)
        leap[i]=1;
}
int main()
{
    int i,j,T;
    int year,num,cnt;
    scanf("%d",&T);
    isleap();
    while(T--)
    {
        cnt=0;
        scanf("%d %d",&year,&num);
        for(i=year;cnt<num;i++)
        if(leap[i])
            cnt++;
        printf("%d\n",i-1);
    }
    system("pause");
    return 0;
}
        
    
     

 

目录
相关文章
|
5月前
|
C++
【PTA】L1-033 出生年(C++)
【PTA】L1-033 出生年(C++)
96 0
【PTA】L1-033 出生年(C++)
|
4月前
1092 最好吃的月饼 (20 分)
1092 最好吃的月饼 (20 分)
[蓝桥杯 2021 省 B2] 特殊年份
[蓝桥杯 2021 省 B2] 特殊年份
132 1
|
数据采集 程序员 Python
【每周一坑】特殊的生日
好吧,我在跳票的道路上又双叒叕前进了一步……今天终于厚着脸皮来更新【每“周”一坑】啦。感谢在后台孜孜不倦催促我的同学们
|
测试技术
PTA 1020 月饼 (25 分)
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。
131 0
PTA 1041 考试座位号 (15 分)
每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。
100 0
|
C++
蓝桥杯练习题一 - 生日蜡烛(c++)
蓝桥杯练习题一 - 生日蜡烛(c++)
155 0
打印日期(华中科技大学考研机试)
打印日期(华中科技大学考研机试)
109 0
打印日期(华中科技大学考研机试)
(C/C++)1092 最好吃的月饼 (20 分)
月饼是久负盛名的中国传统糕点之一,自唐朝以来,已经发展出几百品种。若想评比出一种“最好吃”的月饼,那势必在吃货界引发一场腥风血雨…… 在这里我们用数字说话,给出全国各地各种月饼的销量,要求你从中找出销量冠军,认定为最好吃的月饼。
225 0
(C/C++)1092 最好吃的月饼 (20 分)
|
机器学习/深度学习
洛谷每日三题之第一天
洛谷每日三题之第一天