HDOJ 1157 Who's in the Middle

简介: Problem Description FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of...

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input
* Line 1: A single integer N

  • Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output
* Line 1: A single integer that is the median milk output.

Sample Input
5
2
4
1
3
5

Sample Output
3

Hint

INPUT DETAILS:

Five cows with milk outputs of 1..5

OUTPUT DETAILS:

1 and 2 are below 3; 4 and 5 are above 3.

一道求中位数的简单题

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include<iostream>

#include<algorithm>

using namespace std;
bool cmp(int a,int b){
    return a>b;
}//从大到小排序;

int main(){
    int n;
    while(scanf("%d",&n)==1){
    int i,j,arr[10005];
    for(i=0;i<n;i++){
        scanf("%d",&arr[i]);
    }
         sort(arr,arr+n,cmp);
    printf("%d\n",arr[(n-1)/2]);
    }
    return 0;
}

下面用快排做:

/**#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include<iostream>

#include<algorithm>

using namespace std;
bool cmp(int a,int b){
    return a>b;
}//从大到小排序;

int main(){
    int n;
    while(scanf("%d",&n)==1){
    int i,j,arr[10005];
    for(i=0;i<n;i++){
        scanf("%d",&arr[i]);
    }
         sort(arr,arr+n,cmp);
    printf("%d\n",arr[(n-1)/2]);
    }
    return 0;
}
**/

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include<iostream>

#include<algorithm>

using namespace std;
int cmp(const void *x,const void *y){
    return (*(int *)x-*(int *)y);//从小到大
   /** return (*(int *)y-*(int *)x);//从大到小**/
}

int main(){
    int n;
    while(scanf("%d",&n)==1){
    int i,j,arr[10005];
    for(i=0;i<n;i++){
        scanf("%d",&arr[i]);
    }
         qsort(arr,n,sizeof(int),cmp);
       /**  for(int i=0;i<n;i++){
            printf("%d\n",arr[i]);
         }**/
    printf("%d\n",arr[(n-1)/2]);
    }
    return 0;
}

目录
相关文章
|
存储 算法 搜索推荐
Leetcode 347.Top K Frequent Elements
一句话理解题意:输出数组中出现次数对多的k个数。 在如果用C语言来写这个题目,思路就是先按数的大小排序,然后再用一个结构体数组保存每个数的出现次次数。 因为数组已经有序了,所以只需要遍历一次数组就可以获得每个数的出现次数了。
52 3
hdoj 4706 Children's Day
题目意思就是用a-z组成一个N,然后到z后又跳回a,输出宽从3到10的N。
48 0
Codeforces Round #192 (Div. 2) (330B) B.Road Construction
要将N个城市全部相连,刚开始以为是最小生成树的问题,其实就是一道简单的题目。 要求两个城市之间不超过两条道路,那么所有的城市应该是连在一个点上的,至于这个点就很好找了,只要找到一个没有和其他点有道路限制的即可。
41 0
|
机器学习/深度学习 算法
LeetCode 347. Top K Frequent Elements
给定一个非空的整数数组,返回其中出现频率前 k 高的元素。
46 0
LeetCode 347. Top K Frequent Elements
HDOJ 1326 Box of Bricks(简单题)
HDOJ 1326 Box of Bricks(简单题)
110 0
HDOJ 1326 Box of Bricks(简单题)
HDOJ 1157 Who's in the Middle
HDOJ 1157 Who's in the Middle
91 0
|
Java
HDOJ(HDU) 2164 Rock, Paper, or Scissors?
HDOJ(HDU) 2164 Rock, Paper, or Scissors?
115 0
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
102 0