服务器数据恢复—Linux操作系统网站服务器数据恢复案例

简介: 服务器数据恢复环境:一台linux操作系统网站服务器,该服务器上部署了几十个网站,使用一块SATA硬盘。服务器故障&原因:服务器在工作过程中突然宕机。管理员尝试重新启动服务器失败,于是将服务器上的硬盘拆下检测,发现很多坏扇区。联系当地的一家数据恢复公司处理,但是没有成功。

服务器数据恢复环境:
一台linux操作系统网站服务器,该服务器上部署了几十个网站,使用一块SATA硬盘。

服务器故障&原因:
服务器在工作过程中突然宕机。管理员尝试重新启动服务器失败,于是将服务器上的硬盘拆下检测,发现很多坏扇区。联系当地的一家数据恢复公司处理,但是没有成功。
当用户方联系我们后,经过沟通和初步检测,工程师对服务器故障问题进行初步推断。
1、服务器硬盘出现坏道后,用户试图进行fsck操作,让问题更加严重。
2、以部分块组全为0来看,可能做过未完成的mkfs。
3、先找的这家公司在恢复数据的过程中存在进一步破坏数据的可能性。

服务器数据恢复过程:
1、使用专业工具以只读方式将这块硬盘进行完整镜像,并在镜像过程中分析数据。服务器操作系统层面划分了两个分区:100M的boot分区和/分区(剩余空间全部分配到该分区并通过LVM管理),文件系统均为EXT3。根分区超级块正常,根据超级块查看第一块组描述表正常,但节点区全为0。
2、北亚企安数据恢复工程师根据块组描述表分析其他块组,发现前几十个块组全部为0,但块组前后的数据区明显有数据存在。中间块组区元数据正常(描述表、节点、BITMAP等),最后部分块组的元数据区全部为0。
3、试图查找根目录,以根目录为线索恢复根目录节点区。
4、以生成的根目录节点区与根目录记录生成文件系统树,文件系统树生成后已经可以看到大量数据,而且文件系统结构正常,但部分文件或文件夹的节点为0。通过节点跟踪,发现节点区位于文件系统前部分及后部分。
5、试图恢复节点区为0的文件与文件夹,文件夹大部分恢复成功,但文件大部分无法恢复。
6、试图恢复之前做的.TAR.GZ备份包,但打开时报错,中间数据被破坏,只能导出部分网站数据。
7、经过检查核对,用户确认需要的重要数据已经成功恢复出来,认可数据恢复结果。

TIPS:
1、服务器上的重要的数据一定不要放在单盘上,尽量通过raid来存放数据。
2、做好备份工作,尽量将备份包放到不同的存储体上。退而求其次,也一定不要放到同一分区下。
3、硬盘出现故障后,在进行任何操作之前,先做完整备份。
4、选择专业正规的数据恢复公司,不专业的公司或个人会无意(技术原因)或有意对数据造成二次破坏。

相关文章
|
11月前
|
存储 运维 数据挖掘
服务器数据恢复—EqualLogic存储硬盘出现坏道的数据恢复案例
某品牌EqualLogic PS6100存储阵列上有一组由16块硬盘组建的raid5磁盘阵列。磁盘阵列上层划分多个大小不同的卷,存放虚拟机文件。 硬盘出现故障导致存储阵列不可用,需要恢复存储阵列中的数据。
|
11月前
|
存储 运维 Oracle
服务器数据恢复—存储硬盘指示灯亮黄灯,RAID5阵列崩溃的数据恢复案例
服务器存储数据恢复环境: 某单位一台某品牌DS5300存储,1个机头+4个扩展柜,50块的硬盘组建了两组RAID5阵列。一组raid5阵列有27块硬盘,存放Oracle数据库文件。存储系统上层一共划分了11个卷。 服务器存储故障: 存储设备上两个硬盘指示灯亮黄色。其中一组RAID5阵列崩溃,存储不可用,设备已经过保。
|
11月前
|
存储 运维 数据挖掘
服务器数据恢复—Raid5阵列2块硬盘损坏,热备盘未激活的数据恢复
EMC存储上有一组由多块stat硬盘组建的raid5磁盘阵列,该raid5阵列中有两块热备盘。上层采用的是zfs文件系统。 raid5阵列中2块硬盘出现故障,只有一块热备盘激活。
|
人工智能 运维 安全
重塑 AI 算力底座!阿里云服务器操作系统 V4 正式发布
Alinux 4不仅是技术突破,更是产业变革的催化剂。
|
11月前
|
自然语言处理 监控 数据可视化
如何建设网站:使用阿里云的服务器网站建设5大步骤
企业用阿里云服务器建网站,无需复杂技术,按五步骤即可。先规划需求明确网站功能;再选入门级服务器并初始化;接着部署 PageAdmin CMS,可视化操作易上手;然后选模板填内容搭建网站;最后测试适配与稳定性,绑定域名备案后上线。PageAdmin 还方便后期维护调整。
996 10
|
12月前
|
Unix 应用服务中间件 索引
服务器数据恢复—LUN映射出错导致文件系统共享冲突的数据恢复案例
SUN光纤存储系统中有一组由6个硬盘组建的RAID6,划分为若干LUN,MAP到跑不同业务的服务器上,这些服务器上运行的是SOLARIS操作系统。 服务器不存在物理故障。由于公司业务变化,需要增加一台服务器跑新的应用。服务器管理员在原服务器在线的状态下,将其中一个lun映射到一台新服务器上。实际上,这个刚映射过去的卷已经map到了solaris生产系统上的某个lun上了。映射到新服务器后,服务器对这个卷进行初始化的操作,原solaris系统上的磁盘报错,重启服务器后这个卷已经无法挂载。 服务器管理员寻求sun原厂工程师的帮助。sun工程师检测后执行了fsck操作。执行完成后文件系统挂载成功。查
|
存储 数据挖掘 Linux
服务器数据恢复—重装系统导致OceanStor存储上的分区无法访问的数据恢复案例
服务器存储数据恢复环境: 华为OceanStor某型号存储+扩展盘柜,存储中的硬盘组建了raid5磁盘阵列,上层分配了1个lun。 linux操作系统,划分了两个分区,分区一通过lvm扩容,分区二为xfs文件系统。 服务器存储故障: 工作人员重装系统操作失误导致磁盘分区变化,分区二无法访问,数据丢失。
|
11月前
|
存储 SQL 关系型数据库
服务器数据恢复—raid崩溃导致同友存储无法启动的数据恢复
某单位同友存储,存储中有一组raid5磁盘阵列。存储内部共有虚拟机若干台,raid5阵列崩溃导致存储无法启动。
|
弹性计算 安全 Linux
阿里云服务器ECS安装宝塔Linux面板、安装网站(新手图文教程)
本教程详解如何在阿里云服务器上安装宝塔Linux面板,涵盖ECS服务器手动安装步骤,包括系统准备、远程连接、安装命令执行、端口开放及LNMP环境部署,手把手引导用户快速搭建网站环境。
|
存储 算法 数据挖掘
服务器数据恢复—昆腾存储StorNext文件系统数据恢复案例
一台昆腾存储设备中有一组raid5磁盘阵列。阵列上有两块硬盘先后离线,raid5磁盘阵列不可用。

热门文章

最新文章