HDU-1686-Oulipo

简介: HDU-1686-Oulipo



Oulipo

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 98   Accepted Submission(s) : 63

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:


Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…


Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.


So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.


 


Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 


Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 


Sample Input

      3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN      

 


Sample Output

      1 3 0      

 


Source

华东区大学生程序设计邀请赛_热身赛

 


题目意思很明显了就是kmp  求第一个串在第二个里面出现几次 假如说主串是   a   b  a  b  a  b  c  d  a   b   a    b   a   b   h     f   a    b     a     b    a    b   子串是   ababab

                     

i    0   1  2  3  4  5  6  7  8   9  10  11 12 13 14  15 16  17   18   19   20   21

    a   b  a  b  a  b  c  d  a   b   a    b   a   b   h     f   a    b     a     b    a    b

                                     a   b   a    b   a   b

j                                   -1   0   0    1   2    3    4                                                                  

这是子串的跳转表

i   0   1    2    3   4    5    6

    a    b   a    b   a    b

j    -1   0   0    1   2    3    4


  点击这里   kmp详解



#include<cstdio>
#include<cstring>
const int M=10000+10;
char str2[M*100],str1[M];
int p[M];
int cnt,len1,len2;
void getp()
{
    int i=0,j=-1;
    p[i]=j;
    while(i<len1)
    {
        if(j==-1||str1[i]==str1[j])
        {
           i++;j++;
           p[i]=j;
        }
        else    j=p[j];
    }
}
void kmp()
{
    getp();
    int i=0,j=0;
    while(i<len2)
    {
        if(j==-1||str2[i]==str1[j])
        {
            i++;j++;
            if(j==len1) cnt++; // 每次查到匹配串长度是就说明出现了一个匹配串
        }
        else  j=p[j];
    }
}
int main()
{ 
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",str1,str2);
        len1=strlen(str1);
        len2=strlen(str2);
        cnt=0;
        kmp();
        printf("%d\n",cnt);
    }
    return 0;
}





目录
相关文章
|
29天前
|
Java 定位技术 数据安全/隐私保护
HDU1429-胜利大逃亡(续)
HDU1429-胜利大逃亡(续)
20 0
|
1月前
|
机器学习/深度学习
HDU1210 Eddy's 洗牌问题
HDU1210 Eddy's 洗牌问题
|
7月前
hdu 2502 月之数
hdu 2502 月之数
19 0
hdu 2094 产生冠军
hdu 2094 产生冠军
130 0
|
机器学习/深度学习 算法 Java
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem B. Bullet
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem B. Bullet
142 0
|
人工智能 Java C++
HDU 3785 寻找大富翁
寻找大富翁 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6716    Accepted Submission(s): 2492 Problem Description 浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.
1049 0