Jungle Roads(最小生成树)

简介: Jungle Roads(最小生成树)

题目:

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题目描述:

首先输入n代表有n个点,然后输入n-1行,每一行第一个字母和数字m代表这个字母到其他字母有m个路线,后面的是第一个字母到那个字母和具体距离是多少,然后构建一个无向图,求所有点连接起来的最短距离。

注意:每一个字母要以字符串的形式输入,不然会超时(字符串遇到空格会自动结束)。

程序代码:

#include<stdio.h>
#include<string.h>
int e[50][50],dis[1000],book[1000];
int main()
{
  int n,m,i,j,k,t,min;
  int count,sum,c,b;
  char s1[5],s[5];
  int inf=99999999;
  while(scanf("%d",&n)!=EOF)
  {
    if(n==0)
      break;
    getchar();
    memset(e,0,sizeof(e));
    memset(dis,0,sizeof(dis));
    memset(book,0,sizeof(book));
    count=sum=0;
    for(i=1;i<=n;i++)
      for(j=1;j<=n;j++)
      {
        if(i==j)
          e[i][j]=0;
        else
          e[i][j]=inf;
      }
    for(i=1;i<n;i++)
    {
      scanf("%s%d",s,&m);
      b=s[0]-'A'+1;
      for(j=1;j<=m;j++)
      {
        scanf("%s%d",s1,&t);
        c=s1[0]-'A'+1;
        e[b][c]=e[c][b]=t;
      }
    }
    for(i=1;i<=n;i++)
      dis[i]=e[1][i];
    book[1]=1;
    count++;
    while(count<n)
    {
      min=inf;
      for(i=1;i<=n;i++)
      {
        if(book[i]==0&&dis[i]<min)
        {
          min=dis[i];
          j=i;
        }
      }
      book[j]=1;
      count++;
      sum=sum+dis[j];
      for(k=1;k<=n;k++)
      {
        if(book[k]==0&&dis[k]>e[j][k])
          dis[k]=e[j][k];
      }
    }
    printf("%d\n",sum); 
  }
  return 0; 
} 
相关文章
|
算法 C++
用prim和kruskal算法求最小生成树问题
用prim和kruskal算法求最小生成树问题
81 0
Constructing Roads(kruskal)
Constructing Roads(kruskal)
50 0
UPC Graph (最小生成树 || 并查集+二分)
UPC Graph (最小生成树 || 并查集+二分)
92 0
|
算法
图论最短路及生成树(Prim,Djikstra,Spfa,Bellan-ford,kruskal,topsort)
图论最短路及生成树(Prim,Djikstra,Spfa,Bellan-ford,kruskal,topsort)
139 1
2021杭电多校第三场-Road Discount-wqs二分+最小生成树
get函数是求出将黑色的边权加上一个值x之后的一个花费,我们会这个函数处理出x=-1000->1000的所有情况,然后将信息储存在save中,然后在询问的时候,直接遍历save集合,遇见满足情况的便直接输出,否则输出-1,虽然没有-1的情况/doge
137 0
2021杭电多校第三场-Road Discount-wqs二分+最小生成树
Sticks(剪枝+BFS)
Problem Description George took sticks of the same length and cut them randomly until all parts became at most 50 units long.
1411 0
|
算法
Prim Algoritm(最小生成树)
Prim Algorithm。这个算法可以分为下面几个步骤: 将顶点集V分成两个集合A和B,其中集合A表示目前已经在MST中的顶点,而集合B则表示目前不在MST中的顶点。 在B寻找与集合A连通的最短的边(u,v),将这条边加入最小生成树中。
862 0