node版本与npm版本不对应的解决方案

简介: node版本与npm版本不对应的解决方案


错误情况

今天遇到了个问题,原来用的node的版本是v14.16.0的,后来升级到了最新版20多的时候,以前的项目启动不了。

于是我手动将node卸载了,装回了14的版本,结果发现还是不行,这次报错的是说npm版本太高了与弄的版本不兼容。

解决方式

我这边使用的是nvm来处理的,但其实这不是解决问题的根源。

需要先将Node卸载掉,然后将本地的安装node目录删掉。

找到nvm的安装目录:

nvm path

执行这个命令就能看到安装目录,然后打开设置文件settings.txt,修改一下里面的内容:

root: D:\Users\24519\AppData\Roaming\nvm
path: D:\Users\24519\AppData\Roaming\nvm
node_mirror: https://npm.taobao.org/mirrors/node/
npm_mirror: https://npm.taobao.org/mirrors/npm/

主要是第二行,如果之前我们有装过node的话,第二行可能是之前的目录,会影响当前的nvm中的node环境,随意需要将第二行脸的path改成现在nvm中的node目录。就可以了。

目录
相关文章
|
5天前
|
JavaScript
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
|
5天前
【Node】Mac多版本Node切换
【Node】Mac多版本Node切换
14 1
|
5天前
|
资源调度 jenkins 持续交付
jenkins 自动安装nodejs16.16.0版本报错处理
jenkins 自动安装nodejs16.16.0版本报错处理
32 0
|
5天前
|
资源调度 JavaScript Linux
nvm, node.js, npm, yarn 安装配置
nvm, node.js, npm, yarn 安装配置
37 1
|
3天前
|
JavaScript Unix Shell
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
8 0
|
5天前
node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题
node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题
|
5天前
|
网络安全 计算机视觉
【node】 npm install 报错:code 128
【node】 npm install 报错:code 128
41 1
|
5天前
|
JavaScript Linux 数据安全/隐私保护
node内网安装npm私服以及依赖包上传发布verdaccio
node内网安装npm私服以及依赖包上传发布verdaccio
119 1
|
5天前
|
JavaScript 内存技术
node与npm版本对应关系以及使用nvm管理node版本
node与npm版本对应关系以及使用nvm管理node版本
543 0

推荐镜像

更多