其实实际场景中一般通过运营商上网有两种线路:
专线,上下行带宽相等,有固定公网地址,价格昂贵
PPPoE拨号上网,运营商分配账号密码,获取运营商内网地址,地址不规定,定期可能变化,上下行不对等
PPPoE实验
现在模拟下拨号PPPoE实现上网。
完成内网LAN端的网关、地址、终端地址配置。
服务器端配置
# 创建分配给客户端的地址池,一般我们客户端是没有固定地址,都是从服务器端获取
ip pool client_pool
gateway-list 12.1.1.2
network 12.1.1.0 mask 255.255.255.252
dns-list 114.114.114.114
# 创建给客户端认证的账号密码,服务类型为ppp
aaa
local-user chuck@gd.163.com password cipher %$%$|MYQ9*!ad<vp2w8+w)^(\GL*%$%$
local-user chuck@gd.163.com service-type ppp
# 创建一个虚拟拨号模板,配置认证模式CHAP,绑定地址池,配置自身IP地址
interface Virtual-Template0
ppp authentication-mode chap
remote address pool client_pool
ip address 12.1.1.2 255.255.255.252
# 将上面的模板绑定到物理接口
interface GigabitEthernet0/0/1
pppoe-server bind Virtual-Template 0
# 创建一个环回接口模拟Internet
interface LoopBack0
ip address 8.8.8.8 255.255.255.255
客户端配置
# 先创建拨号规则,允许所有IP触发拨号
dialer-rule
dialer-rule 1 ip permit
# 客户端创建一个虚拟的拨号口用于进行验证配置
interface Dialer1
link-protocol ppp # 默认协议ppp
ppp chap user chuck@gd.163.com # 配置chap认证用户名
ppp chap password cipher 12345678 # 配置chap认证密码,需要与服务器端一致
mtu 1420 # 配置分片,因为IP报文加上一些验证字段可能导致数据分片,默认1500
ip address ppp-negotiate # 配置自动从服务器端获取地址
dialer user chuck@gd.163.com # 配置一个dialer的用户名
dialer bundle 1 # 配置一个绑定编号
dialer timer idle 0 # 配置拨号模式为永久在线,如果是按需拨号可能会掉线
dialer timer autodial 1 # 自动拨号重连的间隔
dialer-group 1 # 拨号配置组,建议全部编号都用同一个即可
nat outbound 2000 # nat也需要在目标里面配置
# 内网网关
interface GigabitEthernet0/0/0
ip address 192.168.1.254 255.255.255.0
# 将上面模板绑定到物理接口,相当于将上面模板配置配在物理接口上了。
interface GigabitEthernet0/0/1
pppoe-client dial-bundle-number 1
# 默认路由需要指向Dialer0
ip route-static 0.0.0.0 0.0.0.0 Dialer0
实验结果
AR2
PC
服务器查看会话
客户端查看会话信息