【问题:创建Vue项目】npm ERR! code CERT_HAS_EXPIRED npm ERR! errno CERT_HAS_EXPIRED npm ERR!

简介: 【问题:创建Vue项目】npm ERR! code CERT_HAS_EXPIRED npm ERR! errno CERT_HAS_EXPIRED npm ERR!

🍀问题

这个报错是因为你正在尝试访问 npm 的 registry,但所使用的 SSL 证书已经过期了。SSL 证书用于加密网络通信,并验证网站的身份。当证书过期时,浏览器或其他客户端会拒绝连接,因为无法验证安全性。


🍀解决办法

npm config get registry 
npm cache clean --force
npm config set strict-ssl false
npm config get registry:
    这个命令用于获取当前 npm 的 registry 配置。
    Registry 是 npm 存储和获取包的地方,它包含了各种 JavaScript 包的元数据和代码。
    这个命令会显示当前 npm 配置的 registry 地址,以便你了解正在使用的 registry 是哪一个。
npm cache clean --force:
    这个命令用于强制清除 npm 的缓存。
    npm 在本地会保存已经下载过的包,以便在下次需要时可以快速获取。有时候,缓存中的内容可能会过期或损坏,导致安装或更新包时出现问题。
    --force 选项用于强制清除缓存,而不需要确认。
npm config set strict-ssl false:
    这个命令用于在 npm 配置中设置 strict-ssl 为 false。
    strict-ssl 是一个 npm 的配置项,用于控制是否强制要求 SSL 连接。
    将 strict-ssl 设置为 false 可以暂时关闭 npm 对 SSL 证书的严格检查。这可能会暂时解决由于 SSL 证书问题而导致的安装或更新包失败的问题,但同时也可能会降低安全性。

挑战与创造都是很痛苦的,但是很充实。


相关文章
|
2天前
|
网络安全 计算机视觉
【node】 npm install 报错:code 128
【node】 npm install 报错:code 128
41 1
|
2天前
|
缓存
npm install 报 npm ERR! cb()never called!的错误
npm install 报 npm ERR! cb()never called!的错误
22 0
|
2天前
项目打包报错“caniuse-lite is outdated. Please run next command `npm update`”的解决方案
项目打包报错“caniuse-lite is outdated. Please run next command `npm update`”的解决方案
58 1
|
1天前
|
JavaScript Unix Shell
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
7 0
|
2天前
使用npm install时遇到问题:npm ERR! code ERESOLVE
使用npm install时遇到问题:npm ERR! code ERESOLVE
|
2天前
npm报错:npm ERR! code ECONNREFUSED npm ERR! errno ECONNREFUSED,npm ERR! npm ERR! If you are behind a
npm报错:npm ERR! code ECONNREFUSED npm ERR! errno ECONNREFUSED,npm ERR! npm ERR! If you are behind a
|
2天前
|
JavaScript Linux 数据安全/隐私保护
node内网安装npm私服以及依赖包上传发布verdaccio
node内网安装npm私服以及依赖包上传发布verdaccio
110 1
|
2天前
|
JavaScript 内存技术
node与npm版本对应关系以及使用nvm管理node版本
node与npm版本对应关系以及使用nvm管理node版本
496 0
|
2天前
|
JavaScript
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
|
2天前
|
资源调度 JavaScript Linux
nvm, node.js, npm, yarn 安装配置
nvm, node.js, npm, yarn 安装配置
34 1

推荐镜像

更多