Dungeon Master(BFS广度优先搜索)

简介: Dungeon Master(BFS广度优先搜索)

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.


Is an escape possible? If yes, how long will it take?

Input


The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output


Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!


Sample Input

3 4 5
S....
.###.
.##..
###.#
#####
#####
##.##
##...
#####
#####
#.###
####E
1 3 3
S##
#E#
###
0 0 0


Sample Output

1. Escaped in 11 minute(s).
2. Trapped!


题目分析其实这是一道简单的三维BFS的题目,相比较与其他二维BFS迷宫问题,三维只是多加了一个楼层,那么我们就把二维转化为三维,其他的与二维迷宫差不了太多。详细解释在代码中,我已经解释得很详尽了,希望各位可以听懂。

  #include <iostream>
  #include <algorithm>
  #include <cstdio>
  #include <cstring>
  using namespace std;
  struct node
  {
      int x;
      int y;
      int z;
      int num;
  } link[40000];
  int op, tp, l, m,ll, n, flag, ans;
  int v[44][44][44];
  char st[44][44][44];
  int jk[6][3] = {{0, 1, 0}, {1, 0, 0}, {0, -1, 0}, {-1, 0, 0}, {0, 0, -1}, {0, 0, 1}};
  bool Judge(int dz, int dx, int dy)
  {
      if(dx < 0 || dx >= m || dy < 0 || dy >= n || dz < 0 || dz >= l)
      return false;
      else
      return true;
  }
  int main()
  {
    //  int i, j, k;
      while(scanf("%d%d%d", &l, &m, &n)&& (l != 0 || n != 0 || m != 0))//几个圈每个圈的行和列 
      {
          op = tp = flag = 0;
          memset(v, 0, sizeof(v));
          for(int i = 0; i < 40000; i++)//应该初始化 
              link[i].num = 0;
          for(int i = 0; i < l; i++)
              for(int j = 0; j < m; j++)//有几个圈 
                  scanf("%s", st[i][j]);//每个圈 由多少行 
          for(int i = 0; i < l; i++)//几个圈 
              for(int j = 0; j < m; j++)//几行 
                  for(int k = 0; k < n; k++)//几列 
                      if(st[i][j][k] == 'S'){
                        link[tp].z = i;//第几圈
                          link[tp].x = j;  //第几行                          
                          link[tp].y = k;//第几列 
                          tp++;
                          v[i][j][k] = 1;//标记作用 
                          break;
                  }
           int x, y, z, i;
      while(op < tp)
      {
          for(i = 0; i < 6; i++)
          {
              x = link[op].x + jk[i][0];//行
              y = link[op].y + jk[i][1];//列 
              z = link[op].z + jk[i][2];//圈 
              if(Judge(z, x, y) && v[z][x][y] == 0)
              {
                  if(st[z][x][y] == '.')//s移动到这里了 
                  {
                      v[z][x][y] = 1;
                      link[tp].x = x;
                      link[tp].y = y;
                      link[tp].z = z;
                      link[tp].num = link[op].num + 1;//加一分钟 
                      tp++;
                  }
                  else if(st[z][x][y] == 'E')//终点 
                  {
                      v[z][x][y] = 1;
                      flag = 1;
                      ans = link[op].num + 1;
                      //cout<<ans<<endl;
                      break;
                  }
              }
          }
          //if(flag)//!=0
              //break;
          op++;//一套大循环加一次 
      }
          if(flag)//!=0
              printf("Escaped in %d minute(s).\n", ans);
          else
              printf("Trapped!\n");
      }
      return 0;
  }


相关文章
|
29天前
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)(下)
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)
10 0
|
29天前
|
算法
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)(上)
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)
22 0
|
29天前
|
存储 人工智能
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)(中)
深度优先搜索(DFS、深搜)和广度优先搜索(BFS、广搜)
13 0
|
3月前
|
存储 算法 定位技术
图论算法dijkstra dfs bfs以及动态规划
图论算法dijkstra dfs bfs以及动态规划
35 0
|
7月前
|
存储 前端开发 算法
深度优先搜索(DFS)和广度优先搜索(BFS)
深度优先搜索(DFS)和广度优先搜索(BFS)
|
8月前
|
算法 C++
BFS从0到1
BFS从0到1
64 0
|
10月前
|
机器学习/深度学习 人工智能 定位技术
BFS题单总结
BFS题单总结
62 0
|
11月前
DFS(深度优先搜索)和BFS(宽度优先搜索)
DFS(深度优先搜索)和BFS(宽度优先搜索)
48 0
|
算法
【和zqy学算法】Day1:DFS与BFS
【和zqy学算法】Day1:DFS与BFS
121 0
|
存储 算法 C++
BFS
文章目录 前言 一、BFS是什么? 二、例题,代码 1.AcWing 844. 走迷宫 本题分析 AC代码 2.AcWing 845. 八数码 本题分析 AC代码 三、时间复杂度
91 0
BFS