【PAT甲级】1126 Eulerian Path

简介: 【PAT甲级】1126 Eulerian Path

1126 Eulerian Path


In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)


Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:


Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6


Sample Output 1:

2 4 4 4 4 4 2
Eulerian
• 1
• 2

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian


题意


在图论中,欧拉路径是图中的一条路径,该路径满足恰好访问每个边一次。


而欧拉回路是一条在同一顶点处开始和结束的欧拉路径。


如果一个连通图的所有顶点的度数都为偶数,那么这个连通图具有欧拉回路,且这个图被称为欧拉图。


如果一个连通图中有两个顶点的度数为奇数,其他顶点的度数为偶数,那么所有欧拉路径都从其中一个度数为奇数的顶点开始,并在另一个度数为奇数的顶点结束。


具有欧拉路径但不具有欧拉回路的图被称为半欧拉图。


现在,给定一个无向图,请你判断它是欧拉图、半欧拉图还是非欧拉图。

思路


  1. 输入每条边,并记录每条边的度数。
  2. 通过 dfs 来计算一共经过了多少结点,从而判断该图是否为连通图。
  3. 输出该图中所有结点的度数。
  4. 判断该图是否为连通图,如果是连通图还要进一步计算度数为奇数的结点,然后再输出该图是什么图。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 510;
int n, m;
int d[N];
bool g[N][N], st[N];
//判断是否为连通图
int dfs(int u)
{
    st[u] = true; //标记该点
    int res = 1;  //计算经过了多少结点
    for (int i = 1; i <= n; i++)   //遍历临近结点
        if (!st[i] && g[u][i]) //判断该边是否存在
            res += dfs(i);
    return res;
}
int main()
{
    cin >> n >> m;
    //输入每条边
    for (int i = 0; i < m; i++)
    {
        int a, b;
        cin >> a >> b;
        g[a][b] = g[b][a] = true;
        d[a]++, d[b]++;  //更新度数
    }
    int cnt = dfs(1); //判断是否为连通图
    //输出每个点的度数
    cout << d[1];
    for (int i = 2; i <= n; i++)   cout << " " << d[i];
    cout << endl;
    //判断是否为欧拉回路
    if (cnt == n)
    {
        //计算度数为奇数的结点数量
        int s = 0;
        for (int i = 1; i <= n; i++)
            if (d[i] % 2)
                s++;
        if (s == 0)    puts("Eulerian");
        else if (s == 2)   puts("Semi-Eulerian");
        else puts("Non-Eulerian");
    }
    else    puts("Non-Eulerian");
    return 0;
}


目录
相关文章
|
5月前
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
29 0
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
|
12月前
|
人工智能 算法 数据可视化
数字孪生DARPA X-DATA项目
数字孪生DARPA X-DATA项目
134 0
|
网络协议 网络安全
【Sword系列】第七届全国残疾人职业技能大赛样题-网络安全-flag not found
pcapng文件是Packet Capture Next Generation的缩写,是一种新型的网络数据包捕获文件格式。
86 0
 【Sword系列】第七届全国残疾人职业技能大赛样题-网络安全-flag not found
|
存储 机器学习/深度学习 算法
【PAT甲级】1131 Subway Map
【PAT甲级】1131 Subway Map
39 0
【PAT甲级】1146 Topological Order
【PAT甲级】1146 Topological Order
57 0
|
边缘计算 开发框架 Cloud Native
建一座国际连锁“商场”:openEuler的雄心与蓝图 | 开源访谈《源创者说》首播
建一座国际连锁“商场”:openEuler的雄心与蓝图 | 开源访谈《源创者说》首播
195 0
PAT甲级 1008. Elevator (20分)
PAT甲级 1008. Elevator (20分)
73 0
PAT甲级 1005. Spell It Right(20分)
PAT甲级 1005. Spell It Right(20分)
50 0
PAT甲级 1009. Product of Polynomials (25分)
PAT甲级 1009. Product of Polynomials (25分)
64 0
|
安全 算法 物联网
阿里云Link ID²标准项目获浙江省标准创新重大贡献奖
9月25日,浙江省标准创新贡献奖评审委员会公布了获奖获奖名单,以阿里云Link ID²物联网设备身份认证为依据的标准项目斩获重大贡献奖,阿里巴巴集团首席风险官郑俊芳代表领奖。
989 0
阿里云Link ID²标准项目获浙江省标准创新重大贡献奖