【PAT甲级 - C++题解】1028 List Sorting

简介: 【PAT甲级 - C++题解】1028 List Sorting

1028 List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.


Input Specification:


Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:


For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60


Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90


Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98


Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60


Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9


Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90


题意


第一行给定学生人数 N 和序号 C 。


按照给定序号数对学生进行排序:


如果 C = 1 ,则按照 ID 升序的顺序排序。


如果 C = 2 ,则按照名称以不降序的顺序排序。


如果 C = 3 ,则按照成绩以不降序的顺序排序。


当出现学生名字相同或是成绩相同的情况时,按照 ID 升序的顺序,对他们进行排序。


思路

  1. 用结构体数组存储学生信息,注意要用 scanf 输入,这题数据量比较大,用 cin 会超时。
  2. 分别设定三个比较函数,然后根据给定的 C 值进行对应的排序。
  3. 输出排序后的结果。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 100010;
struct Student {
    string id, name;
    int grade;
}all[N];
//按照id升序排序
bool cmp1(Student& s1, Student& s2)
{
    return s1.id < s2.id;
}
//按照名字升序排序
bool cmp2(Student& s1, Student& s2)
{
    if (s1.name != s2.name)    return s1.name < s2.name;
    return s1.id < s2.id;
}
//按照成绩升序排序
bool cmp3(Student& s1, Student& s2)
{
    if (s1.grade != s2.grade)  return s1.grade < s2.grade;
    return s1.id < s2.id;
}
int main()
{
    int n, c;
    scanf("%d %d", &n, &c);
    //输入学生信息
    char id[10], name[10];
    for (int i = 0; i < n; i++)
    {
        int grade;
        scanf("%s %s %d", &id, &name, &grade);
        all[i] = { id,name,grade };
    }
    if (c == 1)    sort(all, all + n, cmp1);   //按照id升序排序
    else if (c == 2)   sort(all, all + n, cmp2);   //按照名字升序排序
    else    sort(all, all + n, cmp3);   //按照成绩升序排序
    //输出排序结果
    for (int i = 0; i < n; i++)
        printf("%s %s %d\n", all[i].id.c_str(), all[i].name.c_str(), all[i].grade);
    return 0;
}
目录
相关文章
|
1月前
|
存储 搜索推荐 C++
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器2
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
52 2
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器2
|
1月前
|
存储 算法 C++
【C++打怪之路Lv10】-- list
【C++打怪之路Lv10】-- list
21 1
|
1月前
|
存储 C++ 容器
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器1
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
54 5
|
1月前
|
存储 编译器 C++
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
57 2
|
1月前
|
存储 缓存 C++
C++番外篇——list与vector的比较
C++番外篇——list与vector的比较
22 0
|
1月前
|
C++
C++番外篇——list的实现
C++番外篇——list的实现
19 0
|
1月前
|
存储 C++ 容器
C++入门9——list的使用
C++入门9——list的使用
19 0
|
2天前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
14 2
|
8天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
33 5
|
14天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
46 4