PTA 1054 The Dominant Color (20 分)

简介: 代码如下

题目


Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.


Input Specification: Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2 24 ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.


Output Specification: For each test case, simply print the dominant color in a line.


Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
结尾无空行
Sample Output:
24
结尾无空行


解题思路


数组排序,然后找中间值


M, N = map(int,input().split())
# M, N = map(int,"5 3".split())
inputList = []
# from collections import defaultdict
# resDict = defaultdict(int)
for _ in range(N):
    eachInput = list(map(int, input().split()))
    # eachInput = list(map(int, "24 24 0 0 24".split()))
    # for i in eachInput:
    #     resDict[i] += 1
        # inputList.append(i)
    inputList += eachInput
# from collections import Counter
# counter = Counter(inputList).most_common(1)
# print(resDict)
# counter = Counter(resDict).most_common(1)
length = len(inputList)
inputList.sort()
print(inputList[length//2])
# print(counter[0][0])


目录
相关文章
【PTA】7-8 到底有多二 (15分)
【PTA】7-8 到底有多二 (15分)
2220 0
|
机器学习/深度学习 存储 C++
【PAT甲级 - C++题解】1053 Path of Equal Weight
【PAT甲级 - C++题解】1053 Path of Equal Weight
83 0
|
C++
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
【PAT甲级 - C++题解】1135 Is It A Red-Black Tree
100 0
PTA 7-4 胖达与盆盆奶 (20 分)
俗称“胖达”,会排队吃盆盆奶。它们能和谐吃奶的前提,是它们认为盆盆奶的分配是“公平”的,即:更胖的胖达能吃到更多的奶,等胖的胖达得吃到一样多的奶。
183 0
|
测试技术
PTA 1039 到底买不买 (20 分)
小红想买些珠子做一串自己喜欢的珠串。卖珠子的摊主有很多串五颜六色的珠串,但是不肯把任何一串拆散了卖。
119 0
L1-057 PTA使我精神焕发 (5 分)
L1-057 PTA使我精神焕发 (5 分)
94 0
L1-057 PTA使我精神焕发 (5 分)
PTA 7-1 多二了一点 (15 分)
若一个正整数有 2n 个数位,后 n 个数位组成的数恰好比前 n 个数位组成的数多 2,则称这个数字“多二了一点”。
127 0