题目
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification: Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2 24 ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification: For each test case, simply print the dominant color in a line.
Sample Input: 5 3 0 0 255 16777215 24 24 24 0 0 24 24 0 24 24 24 结尾无空行 Sample Output: 24 结尾无空行
解题思路
数组排序,然后找中间值
M, N = map(int,input().split()) # M, N = map(int,"5 3".split()) inputList = [] # from collections import defaultdict # resDict = defaultdict(int) for _ in range(N): eachInput = list(map(int, input().split())) # eachInput = list(map(int, "24 24 0 0 24".split())) # for i in eachInput: # resDict[i] += 1 # inputList.append(i) inputList += eachInput # from collections import Counter # counter = Counter(inputList).most_common(1) # print(resDict) # counter = Counter(resDict).most_common(1) length = len(inputList) inputList.sort() print(inputList[length//2]) # print(counter[0][0])