PAT甲级 1008. Elevator (20分)

简介: PAT甲级 1008. Elevator (20分)

1008. Elevator (20分)


The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.


For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.


Output Specification:

For each test case, print the total time on a single line.


Sample Input:

3 2 3 1
结尾无空行


Sample Output:

41
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int A[N];
    int sum = 0;
    for (int i = 0; i < N; i++)
    {
        cin >> A[i];
        if (i == 0)
        {
            sum += A[i] * 6;
            continue;
        }
        int tmp = A[i] - A[i - 1];
        if (tmp > 0)
        {
            sum += tmp * 6;
        }
        else
        {
            sum += tmp * (-4);
        }
    }
    sum += 5 * N;
    cout << sum;
    return 0;
}
目录
相关文章
|
7月前
1052 卖个萌 (20 分)//部分正确
1052 卖个萌 (20 分)//部分正确
|
7月前
1053 住房空置率 (20 分)
1053 住房空置率 (20 分)
|
C++
【PAT甲级 - C++题解】1008 Elevator
【PAT甲级 - C++题解】1008 Elevator
59 0
|
存储
【PAT甲级】1122 Hamiltonian Cycle
【PAT甲级】1122 Hamiltonian Cycle
72 0
|
算法
PAT甲级 1003. Emergency(25分)
PAT甲级 1003. Emergency(25分)
97 0
PAT甲级 1003. Emergency(25分)
PAT甲级 1005. Spell It Right(20分)
PAT甲级 1005. Spell It Right(20分)
61 0
PAT甲级 1010. Radix (25分)
PAT甲级 1010. Radix (25分)
83 0
PAT甲级 1009. Product of Polynomials (25分)
PAT甲级 1009. Product of Polynomials (25分)
73 0
|
Linux 区块链 iOS开发
Gear 月度更新|4 月
Gear 月度更新|4 月
126 0
Gear 月度更新|4 月