PAT甲级 1008. Elevator (20分)

简介: PAT甲级 1008. Elevator (20分)

1008. Elevator (20分)


The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.


For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.


Output Specification:

For each test case, print the total time on a single line.


Sample Input:

3 2 3 1
结尾无空行


Sample Output:

41
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int A[N];
    int sum = 0;
    for (int i = 0; i < N; i++)
    {
        cin >> A[i];
        if (i == 0)
        {
            sum += A[i] * 6;
            continue;
        }
        int tmp = A[i] - A[i - 1];
        if (tmp > 0)
        {
            sum += tmp * 6;
        }
        else
        {
            sum += tmp * (-4);
        }
    }
    sum += 5 * N;
    cout << sum;
    return 0;
}
目录
相关文章
【PTA】7-8 到底有多二 (15分)
【PTA】7-8 到底有多二 (15分)
2220 0
|
C++
【PAT甲级 - C++题解】1008 Elevator
【PAT甲级 - C++题解】1008 Elevator
56 0
|
存储
【PAT甲级】1122 Hamiltonian Cycle
【PAT甲级】1122 Hamiltonian Cycle
62 0
|
调度 C语言 C++
PTA L2-014 列车调度(25分)
两端分别是一条入口(Entrance)轨道和一条出口(Exit)轨道,它们之间有N条平行的轨道。每趟列车从入口可以选择任意一条轨道进入,最后从出口离开。在图中有9趟列车,在入口处按照{8,4,2,5,3,9,1,6,7}的顺序排队等待进入。如果要求它们必须按序号递减的顺序从出口离开,则至少需要多少条平行铁轨用于调度? 输入格式: 输入第一行给出一个整数N (2 ≤ N ≤105),下一行给出从1到N的整数序号的一个重排列。数字间以空格分隔。 输出格式: 在一行中输出可以将输入的列车按序号递减的顺序调离所需要的最少的铁轨条数。
140 0
PTA 7-4 胖达与盆盆奶 (20 分)
俗称“胖达”,会排队吃盆盆奶。它们能和谐吃奶的前提,是它们认为盆盆奶的分配是“公平”的,即:更胖的胖达能吃到更多的奶,等胖的胖达得吃到一样多的奶。
181 0
|
测试技术
PTA 1039 到底买不买 (20 分)
小红想买些珠子做一串自己喜欢的珠串。卖珠子的摊主有很多串五颜六色的珠串,但是不肯把任何一串拆散了卖。
118 0
|
算法
PAT甲级 1003. Emergency(25分)
PAT甲级 1003. Emergency(25分)
93 0
PAT甲级 1003. Emergency(25分)
L1-057 PTA使我精神焕发 (5 分)
L1-057 PTA使我精神焕发 (5 分)
94 0
L1-057 PTA使我精神焕发 (5 分)
|
机器学习/深度学习 人工智能
PTA 7-3 拼题 A 是真爱 (20 分)
如果一个人在一段话里很多次提到 pintia,那对拼题 A 就是真爱啦~ 本题就请你检查一下给定的文字中出现了几次 pintia。
153 0