PAT甲级 1009. Product of Polynomials (25分)

简介: PAT甲级 1009. Product of Polynomials (25分)

1009. Product of Polynomials (25分)


This time, you are supposed to find A×B where A and B are two polynomials.


Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:


K N1 a**N1 N2 a**N2 … N**K aNK


where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.


Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.


Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行


Sample Output:

3 3 3.6 2 6.0 1 1.6
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N1, N2;
    cin >> N1;
    double arr[1005] = {0.0}, ans[2005] = {0.0};
    int z;
    double x;
    for (int i = 0; i < N1; i++)
    {
        cin >> z >> x;
        arr[z] = x;
    }
    cin >> N2;
    for (int i = 0; i < N2; i++)
    {
        cin >> z >> x;
        for (int j = 0; j < 1005; j++)
        {
            if (arr[j])
            {
                ans[z + j] += arr[j] * x;
            }
        }
    }
    int count = 0;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            count++;
        }
    }
    cout << count;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            printf(" %d %.1f", i, ans[i]);
        }
    }
    system("pause");
    return 0;
}

多项式相乘,与1002的思路一致。

目录
相关文章
|
供应链
电商云里 Product bundling 的一些概念
电商云里 Product bundling 的一些概念
|
PHP Python
矩阵制度三三复制直销系统模式开发详解 | 矩阵制度三三复制直销系统开发源码demo示例
矩阵制度三三复制模式是一种常见的直销模式,也被称为三三复制模式。该模式限制了前排的数量,只能填满3个位置,奖金则是按照固定的深度来进行领取的。在该模式中,每个参与者都可以推荐其他人加入,如果成功推荐,就可以获得相应的奖金。具体来说,如果推荐一个参与者,可以获得20美元的奖金;如果推荐两个参与者,可以获得10美元的奖金;如果推荐三个参与者,可以获得4美元的奖金。此外,该模式还有一些其他的奖金制度,如培育奖金、扣税等。
|
12月前
|
Android开发 iOS开发 Windows
什么是外企经常提及的 Product Portfolio
什么是外企经常提及的 Product Portfolio
【PAT甲级】1146 Topological Order
【PAT甲级】1146 Topological Order
58 0
|
存储 C++
【PAT甲级 - C++题解】1009 Product of Polynomials
【PAT甲级 - C++题解】1009 Product of Polynomials
49 0
|
算法框架/工具
【PAT甲级】1126 Eulerian Path
【PAT甲级】1126 Eulerian Path
58 0
PAT-2021年秋季考试 乙级 7-3 自定义判题程序 (20 分)
在每次允许插入、删除、修改一个字符的前提下,用最少的动作把一个字符串变成另一个字符串,是一道著名的可以用动态规划解决的问题。
103 0
PAT甲级 1005. Spell It Right(20分)
PAT甲级 1005. Spell It Right(20分)
50 0
|
测试技术
PAT乙级1002写出这个数(20分)
PAT乙级1002写出这个数(20分)
92 0
|
SQL 存储 关系型数据库
小胖问我:group by 怎么优化?(下)
小胖问我:group by 怎么优化?
小胖问我:group by 怎么优化?(下)