PAT甲级 1009. Product of Polynomials (25分)

简介: PAT甲级 1009. Product of Polynomials (25分)

1009. Product of Polynomials (25分)


This time, you are supposed to find A×B where A and B are two polynomials.


Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:


K N1 a**N1 N2 a**N2 … N**K aNK


where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.


Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.


Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行


Sample Output:

3 3 3.6 2 6.0 1 1.6
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N1, N2;
    cin >> N1;
    double arr[1005] = {0.0}, ans[2005] = {0.0};
    int z;
    double x;
    for (int i = 0; i < N1; i++)
    {
        cin >> z >> x;
        arr[z] = x;
    }
    cin >> N2;
    for (int i = 0; i < N2; i++)
    {
        cin >> z >> x;
        for (int j = 0; j < 1005; j++)
        {
            if (arr[j])
            {
                ans[z + j] += arr[j] * x;
            }
        }
    }
    int count = 0;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            count++;
        }
    }
    cout << count;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            printf(" %d %.1f", i, ans[i]);
        }
    }
    system("pause");
    return 0;
}

多项式相乘,与1002的思路一致。

目录
相关文章
|
供应链 关系型数据库 MySQL
Mysql 设计超市经营管理系统,包括员工信息表(employee)和 员工部门表(department)
Mysql 设计超市经营管理系统,包括员工信息表(employee)和 员工部门表(department)
398 0
Mysql 设计超市经营管理系统,包括员工信息表(employee)和 员工部门表(department)
|
6月前
电商项目商品表关系广告类别表
电商项目商品表关系广告类别表
【PAT甲级】1146 Topological Order
【PAT甲级】1146 Topological Order
63 0
|
存储 C++
【PAT甲级 - C++题解】1009 Product of Polynomials
【PAT甲级 - C++题解】1009 Product of Polynomials
59 0
|
SQL 存储 自然语言处理
晚上8点在地铁上收到boss需求:把400多张表的关系画出来明早客户要!
晚上8点在地铁上收到boss需求:把400多张表的关系画出来明早客户要!
111 0
晚上8点在地铁上收到boss需求:把400多张表的关系画出来明早客户要!
SAP报错因为不允许对公司代码 XXXX科目 XXXXXXXXXX进行销项/进项税相关操作,所以税码XX无效
问题描述:因为不允许对公司代码 3300 科目 6001000000 进行销项/进项税相关操作,所以税码 Z1 无效
SAP报错因为不允许对公司代码 XXXX科目 XXXXXXXXXX进行销项/进项税相关操作,所以税码XX无效
7-17 航空公司VIP客户查询 (10 分)
7-17 航空公司VIP客户查询 (10 分)
179 0
|
JavaScript 开发者 索引
品牌案例-根据Id完成品牌的删除|学习笔记
快速学习品牌案例-根据Id完成品牌的删除
157 0
|
数据库
【硬着头皮】 你别查询了,不就id么?
【硬着头皮】 你别查询了,不就id么?
103 0
【硬着头皮】 你别查询了,不就id么?
|
SQL 关系型数据库 MySQL
MySQL测试题——开发公司人事管理系统,包括 Employee表 和 Department表
MySQL测试题——开发公司人事管理系统,包括 Employee表 和 Department表
482 0
MySQL测试题——开发公司人事管理系统,包括 Employee表 和 Department表