PAT甲级 1009. Product of Polynomials (25分)

简介: PAT甲级 1009. Product of Polynomials (25分)

1009. Product of Polynomials (25分)


This time, you are supposed to find A×B where A and B are two polynomials.


Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:


K N1 a**N1 N2 a**N2 … N**K aNK


where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.


Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.


Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行


Sample Output:

3 3 3.6 2 6.0 1 1.6
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N1, N2;
    cin >> N1;
    double arr[1005] = {0.0}, ans[2005] = {0.0};
    int z;
    double x;
    for (int i = 0; i < N1; i++)
    {
        cin >> z >> x;
        arr[z] = x;
    }
    cin >> N2;
    for (int i = 0; i < N2; i++)
    {
        cin >> z >> x;
        for (int j = 0; j < 1005; j++)
        {
            if (arr[j])
            {
                ans[z + j] += arr[j] * x;
            }
        }
    }
    int count = 0;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            count++;
        }
    }
    cout << count;
    for (int i = 2004; i >= 0; i--)
    {
        if (ans[i])
        {
            printf(" %d %.1f", i, ans[i]);
        }
    }
    system("pause");
    return 0;
}

多项式相乘,与1002的思路一致。

目录
相关文章
|
3月前
|
Python
经济生产批量(Economic Production Quantity,EPQ)
经济生产批量(Economic Production Quantity,EPQ)
|
12月前
|
Android开发 iOS开发 Windows
什么是外企经常提及的 Product Portfolio
什么是外企经常提及的 Product Portfolio
【PAT甲级】1146 Topological Order
【PAT甲级】1146 Topological Order
58 0
|
存储 C++
【PAT甲级 - C++题解】1009 Product of Polynomials
【PAT甲级 - C++题解】1009 Product of Polynomials
49 0
SAP报错因为不允许对公司代码 XXXX科目 XXXXXXXXXX进行销项/进项税相关操作,所以税码XX无效
问题描述:因为不允许对公司代码 3300 科目 6001000000 进行销项/进项税相关操作,所以税码 Z1 无效
SAP报错因为不允许对公司代码 XXXX科目 XXXXXXXXXX进行销项/进项税相关操作,所以税码XX无效
PAT-2021年秋季考试 乙级 7-3 自定义判题程序 (20 分)
在每次允许插入、删除、修改一个字符的前提下,用最少的动作把一个字符串变成另一个字符串,是一道著名的可以用动态规划解决的问题。
105 0
|
测试技术
PAT乙级1004.成绩排名(20分)
PAT乙级1004.成绩排名(20分)
89 0
|
测试技术
PAT乙级1002写出这个数(20分)
PAT乙级1002写出这个数(20分)
92 0
|
存储 索引
Google Earth Engine(GEE)——在线统计美国人口和住房数据(以ee.Reducer.sum().repeat().group列表形式呈现)
Google Earth Engine(GEE)——在线统计美国人口和住房数据(以ee.Reducer.sum().repeat().group列表形式呈现)
290 0
Google Earth Engine(GEE)——在线统计美国人口和住房数据(以ee.Reducer.sum().repeat().group列表形式呈现)
SAP SD微观研究之销售订单类型配置里有关PO的几个字段
SAP SD微观研究之销售订单类型配置里有关PO的几个字段
SAP SD微观研究之销售订单类型配置里有关PO的几个字段