1001. A+B Format(20分)

简介: 1001. A+B Format(20分)

1001. A+B Format(20分)


Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).


Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.


Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.


Sample Input:

-1000000 9
结尾无空行


Sample Output:

-999,991
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++)
    {
        cout << s[i];
        if (s[i] == '-')
        {
            continue;
        }
        if ((len - 1 - i) % 3 == 0 && i != len - 1)
            cout << ",";
    }
    return 0;
}

我要麻了,第一题还出错,写了半小时。开始想复杂了,用了栈和整数求余。其实很简单,要注意的点就是算逗号的时候需要倒置求余。

目录
相关文章
|
7月前
|
索引
1001 A+B Format (20 分)
1001 A+B Format (20 分)
|
7月前
1043 输出PATest (20 分)
1043 输出PATest (20 分)
|
8月前
DATE_FORMAT函数使用
DATE_FORMAT函数使用
288 0
|
SQL
format函数
format函数
158 0
|
C语言 C++
1043 输出PATest (20 分)
给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
99 0
【1132】Cut Integer (20 分)
【1132】Cut Integer (20 分) 【1132】Cut Integer (20 分)
120 0
【1126】Eulerian Path (25分)【连通图】
1)如果是一个连通图,则只需要一次DFS即可完成遍历。 (2)可以用DFS判断一个无向图是否
166 0
【1144】The Missing Number (20 分)
【1144】The Missing Number (20 分) 【1144】The Missing Number (20 分)
80 0
|
Web App开发 JavaScript 前端开发