ZOJ-3869,Ace of Aces(简单题)

简介: ZOJ-3869,Ace of Aces(简单题)

Problem Description:


There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".


After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.


Please write program to help TSAB determine who will be the "Ace of Aces".


Input:


There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:


The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).


Output:


For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.  


Sample Input:


3


5


2 2 2 1 1


5 1 1 2 2 3


1


998


Sample Output:


2


Nobody


998


AC Code:


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1001
int a[N],num[N];
int main()
{
  int t,n;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(num,0,sizeof(num));//标记数组清零 
    for(int i=0;i<n;i++)
    {
      scanf("%d",&a[i]);
      num[a[i]]++;//每个数出现一次就加1 
    }
    int max1=0,max2=0,x=0;
    for(int i=0;i<N;i++)
    {
      if(max1<num[i])//第一遍遍历数组,查找到出现次数最多的那个数 
      {
        max1=num[i];//赋值 
        x=i;//对应下标赋给x 
      }
    }
    for(int i=0;i<N;i++)//第二次遍历数组,是为了查重 
    {
      if(max2<num[i]&&i!=x)//两个下标不能相同 
      {
        max2=num[i];//赋值 
      }
    }
    if(max1==max2)//如果两个数出现次数相同 
      printf("Nobody\n");
    else
      printf("%d\n",x);
  }
  return 0;
}


相关文章
|
2月前
|
Java C++ Python
试题 基础练习 FJ的字符串
试题 基础练习 FJ的字符串
22 0
|
9月前
|
算法 安全 数据安全/隐私保护
华为机试HJ21:简单密码
华为机试HJ21:简单密码
|
负载均衡 网络协议
阿里云ACE考试简答题分享
本人在7月份参加阿里云云计算ACE考试,复习了接近半年,其中简答题考试题目脑袋里面印象还很深刻,拿出来跟大家分享一下,阿里云ACE总分150分,90分即可,简答题30分哦 本人125分完美通过,顺利拿到了高级架构师ACE的证书
3936 1
阿里云ACE考试简答题分享
|
机器学习/深度学习
|
人工智能 BI 应用服务中间件