Choose the best route

简介: Choose the best route

题目:

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s

home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home

so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki

needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.


Input

There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

解题思路:这个是最短路经的题目,首先介绍样例:第一个5是五个公交站,8代表八条路径,第二个5是所到达的终点,接下来是家附近的公交站,然后求从该点出发到达终点的最短时间。

这个按正常思路容易超时,所以可以反过来求终点到各点的距离。

程序代码:

#include<stdio.h>
#include<string.h>
int e[2000][2000],dis[50000],book[50000];
int n,m,t;
int inf=99999999;
void dij()
{
  int i,j,k,u,v,min;
  for(i=1;i<=n;i++)
    dis[i]=e[t][i];
  for(i=1;i<=n;i++)
    book[i]=0;
  book[1]=1;
  for(i=1;i<n;i++)
  {
    min=inf;
    for(j=1;j<=n;j++)
    {
      if(book[j]==0&&dis[j]<min)
      {
        min=dis[j];
        u=j;
      }
    }
    book[u]=1;
    for(v=1;v<=n;v++)
    {
      if(e[u][v]<inf)
      {
        if(dis[v]>dis[u]+e[u][v])
          dis[v]=dis[u]+e[u][v];
      }
    }
  }
}
int main()
{
  int i,j,t1,t2,t3,a,b,c,d,tem;
  while(scanf("%d%d%d",&n,&m,&t)!=EOF)
  {
    memset(dis,0,sizeof(dis));
    memset(book,0,sizeof(book));
    for(i=1;i<=n;i++)
      for(j=1;j<=n;j++)
        if(i==j)  e[i][j]=0;
        else      e[i][j]=inf;
    for(i=1;i<=m;i++)
    {
      scanf("%d%d%d",&t1,&t2,&t3);
      if(e[t1][t2]>t3)
        e[t1][t2]=t3;
    }
    for(i=1;i<n;i++)
      for(j=i+1;j<=n;j++)
      {
        tem=e[i][j];
        e[i][j]=e[j][i];
        e[j][i]=tem;
      }
    d=inf;
    dij();
//    for(i=1;i<=n;i++)
//      printf("*%d ",dis[i]);
//    printf("%d\n");
    scanf("%d",&a);
    for(i=1;i<=a;i++)
    {
      scanf("%d",&b);
    //  printf("*%d\n",dis[b]);
      if(d>dis[b])
        d=dis[b];   
    }
    if(d==inf)
      printf("-1\n");
    else
      printf("%d\n",d);
  }
  return 0;
}
相关文章
|
22天前
|
网络架构
一文带你了解 Next Route 使用
一文带你了解 Next Route 使用
|
8月前
|
前端开发 网络架构
浅谈Router和Route
浅谈Router和Route
69 0
成功解决The selected network interface is not valid
成功解决The selected network interface is not valid
成功解决The selected network interface is not valid
|
存储 JavaScript 调度
Router和Route
Router和Route
67 0
|
前端开发
说说 router4的exact 属性
这段时间正在研究 react router4 ,发现了其中一个很特别的属性。因为没有系统的看过官方的文档,所以在这里也频繁的踩坑。在网上也看过很多文章,结果还是踩坑。现在终于把坑踩平了,今天就把这个小小的知识点记录下来。加深一下理解。
163 1
|
JavaScript
Vue报错Interpolation inside attributes has been removed.解决方法
Vue报错Interpolation inside attributes has been removed.解决方法
Vue报错Interpolation inside attributes has been removed.解决方法
【laravle】 Route [login] not defined.
【laravle】 Route [login] not defined.
103 0
【laravle】 Route [login] not defined.
|
网络协议
|
JavaScript 前端开发
|
网络协议

热门文章

最新文章

下一篇
开通oss服务