1001. A+B Format(20分)

简介: 1001. A+B Format(20分)

1001. A+B Format(20分)


Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).


Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.


Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.


Sample Input:

-1000000 9
结尾无空行


Sample Output:

-999,991
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++)
    {
        cout << s[i];
        if (s[i] == '-')
        {
            continue;
        }
        if ((len - 1 - i) % 3 == 0 && i != len - 1)
            cout << ",";
    }
    return 0;
}

我要麻了,第一题还出错,写了半小时。开始想复杂了,用了栈和整数求余。其实很简单,要注意的点就是算逗号的时候需要倒置求余。

目录
相关文章
|
2月前
|
SQL HIVE
Hive中日期处理函数的使用(date_format、date_add、date_sub、next_day)
Hive中日期处理函数的使用(date_format、date_add、date_sub、next_day)
105 3
|
4月前
|
Java
java将输入的字符串时间提前一天,再以字符串形式输出。输入时间格式为:yyyy-MM-dd
java将输入的字符串时间提前一天,再以字符串形式输出。输入时间格式为:yyyy-MM-dd
20 2
|
4月前
DATE_FORMAT函数使用
DATE_FORMAT函数使用
177 0
|
9月前
|
SQL Oracle 关系型数据库
sql中sysdate 和 current_date 的区别及to_char( tv_date, ‘YYYY-MM-DD‘)当天时间与数据库时间的格式转换与比较
在oracle中current_date与sysdate都是显示当前系统时间, 其结果基本相同,但是有三点区别: 1. current_date返回的是当前会话时间,而sysdate返回的是服务器时间; 2. current_date有时比sysdate快一秒,这可能是四舍五入的结果; 3. 如果修改当前会话的时区,比如将中国的时区为东八区,修改为东九区,则current_date显示的时间为东九区时间, 根据东加西减的原则,current_date应该比sysdate快一小时。
406 0
sql中sysdate 和 current_date 的区别及to_char( tv_date, ‘YYYY-MM-DD‘)当天时间与数据库时间的格式转换与比较
L1-042 日期格式化 (5 分)
L1-042 日期格式化 (5 分)
107 0
【1126】Eulerian Path (25分)【连通图】
1)如果是一个连通图,则只需要一次DFS即可完成遍历。 (2)可以用DFS判断一个无向图是否
136 0
【1144】The Missing Number (20 分)
【1144】The Missing Number (20 分) 【1144】The Missing Number (20 分)
69 0
|
Web App开发 JavaScript 前端开发