jest-environment-jsdom-fourteen
JSDOM environment for Jest with JSDOM 14
Last updated 7 months ago by ianschmitz .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install jest-environment-jsdom-fourteen 
SYNC missed versions from official npm registry.

jest-environment-jsdom-fourteen

Jest by default uses JSDOM 11 to support Node 6. This package uses JSDOM 14, which supports Node >= 8, and does not support Node 6 (and will therefore not be used in Jest any time soon).

If you need a newer JSDOM than the one that ships with Jest, install this package using npm install --save-dev jest-environment-jsdom-fourteen or yarn add jest-environment-jsdom-fourteen --dev, and edit your Jest config like so:

{
  "testEnvironment": "jest-environment-jsdom-fourteen"
}

If you would like to use JSDOM 13, see https://github.com/theneva/jest-environment-jsdom-thirteen.

Current Tags

  • 1.0.0-alpha.0                                ...           alpha (a year ago)
  • 1.0.1                                ...           latest (7 months ago)

4 Versions

  • 1.0.1                                ...           7 months ago
  • 1.0.0                                ...           7 months ago
  • 1.0.0-alpha.0                                ...           a year ago
  • 0.1.0                                ...           a year ago
Maintainers (1)
Downloads
Today 84
This Week 10,459
This Month 5,371
Last Day 2,807
Last Week 11,857
Last Month 60,950
Dependencies (6)
Dev Dependencies (11)
Dependents (1263)

Copyright 2014 - 2016 © taobao.org |