开发者社区 > 大数据与机器学习 > 实时计算 Flink > 正文

有没有用jdk17版本,使用flinkcdc的?

有没有用jdk17版本,使用flinkcdc的?

展开
收起
真的很搞笑 2023-11-21 09:16:58 80 0
3 条回答
写回答
取消 提交回答
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    Flink CDC 可以在 Java 8 或更高版本上运行,但并未明确提到它能否在 JDK 17 版本上使用。建议在官方文档或者社区论坛中寻找更准确的答案,或者直接联系技术支持以确认是否可以使用 JDK 17 版本来运行 Flink CDC。

    2023-11-21 23:10:16
    赞同 展开评论 打赏
  • flink-cdc依赖于flink ,目前flink 1.18才支持jdk17,但是flink-cdc还没兼容到flink 1.18,此回答整理自钉群“Flink CDC 社区”

    2023-11-21 22:20:23
    赞同 展开评论 打赏
  • 是的,您可以在JDK 17环境下编译和运行Flink 1.7.1,只要保证您使用的JDK版本与Flink 1.7.1支持的JDK版本兼容。同时,Flink CDC本质上是一个jar包,只需要引入该包并编写一个main方法即可展现其基本功能。

    值得注意的是,如果您使用的是Maven作为构建工具,可以在pom.xml文件中添加相应的配置来指定JDK版本。例如:org.apache.maven.plugins maven-compiler-plugin 3.8.1 17 17。如果您使用的是Gradle,可以在build.gradle文件中添加相应的配置来指定JDK版本。

    此外,FlinkCDC需要MySQL 5.7+的数据库。在开发前请确保已开启binlog并正确配置MySQL的my.cnf文件。

    2023-11-21 14:55:32
    赞同 展开评论 打赏

实时计算Flink版是阿里云提供的全托管Serverless Flink云服务,基于 Apache Flink 构建的企业级、高性能实时大数据处理系统。提供全托管版 Flink 集群和引擎,提高作业开发运维效率。

相关电子书

更多
低代码开发师(初级)实战教程 立即下载
冬季实战营第三期:MySQL数据库进阶实战 立即下载
阿里巴巴DevOps 最佳实践手册 立即下载