开发者社区 > 大数据与机器学习 > 实时计算 Flink > 正文

Flink CDC我本地用的jdk17打包的flinkcdc项目,是jdk版本问题吗?

Flink CDC我本地用的jdk17打包的flinkcdc项目,放到flink集群上报错,是jdk版本问题吗?Caused by: java.lang.SecurityException: Invalid signature file digest for Manifest main attributes

展开
收起
真的很搞笑 2023-10-23 15:26:33 83 0
1 条回答
写回答
取消 提交回答
  • 是的,这个问题可能是由于JDK版本不匹配导致的。请确保在Flink集群上使用的JDK版本与本地打包的Flink CDC项目所使用的JDK版本一致。如果不一致,可以尝试将本地项目的JDK版本更改为与Flink集群相同的版本,然后重新打包并部署到Flink集群上。

    2023-10-23 16:42:46
    赞同 展开评论 打赏

实时计算Flink版是阿里云提供的全托管Serverless Flink云服务,基于 Apache Flink 构建的企业级、高性能实时大数据处理系统。提供全托管版 Flink 集群和引擎,提高作业开发运维效率。

相关产品

  • 实时计算 Flink版
  • 热门讨论

    热门文章

    相关电子书

    更多
    Flink CDC Meetup PPT - 龚中强 立即下载
    Flink CDC Meetup PPT - 王赫 立即下载
    Flink CDC Meetup PPT - 覃立辉 立即下载