安装ossfs时出现“fuse: warning: library too old, some -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

安装ossfs时出现“fuse: warning: library too old, some

2022-01-01 19:55:50 711 1

安装ossfs时出现“fuse: warning: library too old, some operations may not work”报错,如何解决?

取消 提交回答
全部回答(1)
  • 小阿怪
    2022-01-02 13:02:15

    问题分析:出现错误的原因是ossfs编译时所使用的libfuse版本比运行时链接到的libfuse版本高,这往往是用户自行安装了libfuse导致的。CentOS-5.x和CentOS-6.x系统中,阿里云提供的ossfs安装包里包含了libfuse-2.8.4,如果在运行的时候环境中有libfuse-2.8.3,并且ossfs被链接到了旧版本的fuse上,就会出现上述错误。

    您可以通过ldd $(which ossfs) | grep fuse命令确认ossfs运行时链接的fuse版本,如结果是/lib64/libfuse.so.2,那么通过ls -l /lib64/libfuse*命令可以看到fuse的版本。

    解决方案:让ossfs链接到正确的版本。 通过rpm -ql ossfs | grep fuse命令找到libfuse的目录。 如果结果是/usr/lib/libfuse.so.2,则通过LD_LIBRARY_PATH=/usr/lib ossfs …命令运行ossfs。

    0 0
相关问答

1

回答

全球第一个数据库系统Integrated Database System(IDS)是个什么类型的数据

2022-09-07 18:03:17 38浏览量 回答数 1

1

回答

Dataworks 将mc表导入至 abd for postgresql 有文档吗?

2022-07-18 16:53:55 249浏览量 回答数 1

1

回答

【OSS】使用yum/apt-get安装ossfs时出现“conflicts with file f

2022-01-19 14:56:06 332浏览量 回答数 1

1

回答

云效代码管理平台(Codeup)内置P3C 代码规约检测插件,技术上是如何实现的呢?

2021-12-15 23:29:50 284浏览量 回答数 1

2

回答

执行SQL查询(小于20条以内)就会卡死,不同的客户端可能会报异常出现ora-12592错误

2021-10-12 11:26:35 432浏览量 回答数 2

1

回答

未加载库:尝试在具有MySQL2的OS X 10.6上运行“ Rails服务器”时,libmysql

2020-05-10 19:45:49 324浏览量 回答数 1

0

回答

i-wz9ct3cbrxx7y31u8j55 这个服务器被你们备案人员搞来搞去,哎,累死!

2018-12-27 17:02:43 402浏览量 回答数 0

2

回答

企业邮箱常见错误提示504 the number of RCPT attempts is achieved the maximum threshold

2018-01-29 10:57:58 1926浏览量 回答数 2

2

回答

企业邮箱常见错误提示510 The length of DATA content is achieved the maximum threshold

2018-01-29 10:59:26 4150浏览量 回答数 2

2

回答

企业邮箱常见错误提示510 The length of Attach is achieved the maximum threshold

2018-01-29 10:59:52 4241浏览量 回答数 2
+关注
0
文章
802
问答
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载