使用cmake查找正确的Python框架-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

使用cmake查找正确的Python框架

祖安文状元 2020-02-21 14:17:54 222

我正在Snow Leopard计算机上使用python的macports版本,并使用cmake为其构建跨平台扩展。我在CMakeLists.txt中使用以下命令在系统上搜索python解释器和库

include(FindPythonInterp)
include(FindPythonLibs  )

但是,尽管cmake在中标识了正确的解释器/opt/local/bin,但它尝试链接到错误的框架-即系统Python框架。

-- Found PythonInterp: /opt/local/bin/python2.6
-- Found PythonLibs: -framework Python

这会导致以下运行时错误

Fatal Python error: Interpreter not initialized (version mismatch?)

我一替换-framework Python为/opt/local/Library/Frameworks/Python.framework/Python一切,一切似乎就会按预期进行。

我该如何针对正确的Python框架建立cmake链接

/opt/local/Library/Frameworks/Python.framework/Python

而不是系统之一

/System/Library/Frameworks/Python.framework/Python
Python
分享到
取消 提交回答
全部回答(1)
  • 祖安文状元
    2020-02-21 14:18:02

    在以下内容中添加 ~/.bash_profile

    export DYLD_FRAMEWORK_PATH=/opt/local/Library/Frameworks
    
    

    至少暂时解决问题。显然,cmake使用的python解释器和python框架之间的不一致是一个错误,应该在新版本中予以修复。

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程