A2011 Magic Mirror

简介: A2011 Magic Mirror

文章目录

一、A2011 Magic Mirror

总结


一、A2011 Magic Mirror

本题链接:A2011 Magic Mirror


题目:

Jessie has a magic mirror.


Every morning she will ask the mirror: ‘Mirror mirror tell me, who is the most beautiful girl in the world?’ If the mirror says her name, she will praise the mirror: ‘Good guy!’, but if the mirror says the name of another person, she will assail the mirror: ‘Dare you say that again?’


Today Jessie asks the mirror the same question above, and you are given a series of mirror’s answers. For each answer, please output Jessie’s response. You can assume that the uppercase or lowercase letters appearing anywhere in the name will have no influence on the answer. For example, ‘Jessie’ and ‘jessie’ represent the same person.


Input

The first line contains an integer T(1≤T≤100), which is the number of test cases.


Each test case contains one line with a single-word name, which contains only English letters. The length of each name is no more than 15.


Output

For each test case, output one line containing the answer.


样例输入

2

Jessie

Justin


样例输出

Good guy!

Dare you say that again?


本博客给出本题截图:

image.png

image.png

AC代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 20;
char s[N];
int main()
{
    int n;
    scanf("%d", &n);
    while (n -- )
    {
        scanf("%s", s);
        for (int i = 0; s[i]; i ++ )
            if (s[i] >= 'A' && s[i] <= 'Z')
                s[i] = s[i] - 'A' + 'a';
        if (strcmp(s, "jessie")) puts("Dare you say that again?");
        else puts("Good guy!");
    }
    return 0;
}

总结

这步的操作是让s中所有的字母都变成小写字母,方便我们进行比较

        for (int i = 0; s[i]; i ++ )
            if (s[i] >= 'A' && s[i] <= 'Z')
                s[i] = s[i] - 'A' + 'a';


目录
相关文章
|
8天前
|
安全 网络协议 Linux
yum出现Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile解决方法
yum出现Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile解决方法
16 3
|
2月前
|
Java 定位技术 Android开发
安装apk显示 requires unavailable shared library com.xxx
安装apk显示 requires unavailable shared library com.xxx
17 0
|
8月前
|
Docker 容器
docker: invalid reference format.
docker: invalid reference format.
300 0
MAC编译lame ld: symbol(s) not found for architecture x86_64/_lame_init_old“, referenced from
MAC编译lame ld: symbol(s) not found for architecture x86_64/_lame_init_old“, referenced from
212 0
add file in debian/source/include-binaries if you want to store the modified binary in the debian
add file in debian/source/include-binaries if you want to store the modified binary in the debian
370 0
|
Shell
Detected problems with app native libraries (please consult log for detail): lib.so: text relocation
Detected problems with app native libraries (please consult log for detail): lib.so: text relocation
125 0
|
缓存
Error:Could not download ecj.jar : No cached version available for offline mode
Error:Could not download ecj.jar : No cached version available for offline mode
207 0
Error:Could not download ecj.jar : No cached version available for offline mode
The Soft Link between IM Level Storage Location and WM level Storage Type?(1)
The Soft Link between IM Level Storage Location and WM level Storage Type?(1)
The Soft Link between IM Level Storage Location and WM level Storage Type?(1)
|
关系型数据库 Linux
Linux No volume control GStreamer plugins and/or devices found
案例环境:Oracle Linux Server release 5.7 进入Oracle Linux系统后,在右上角点击声音图标时,则会弹出如下报错窗口: The volume control did not find any elements and/or devices to control .
956 0