HDU-1219,AC Me(字符串处理)

简介: HDU-1219,AC Me(字符串处理)

Problem Description:


Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.


It's really easy, isn't it? So come on and AC ME.


Input:


Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.


Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.


Output:


For each article, you have to tell how many times each letter appears. The output format is like "X:N".


Output a blank line after each test case. More details in sample output.


Sample Input:


hello, this is my first acm contest!


work hard for hdu acm.


Sample Output:


a:1


b:0


c:2


d:0


e:2


f:1


g:0


h:2


i:3


j:0


k:0


l:2


m:2


n:1


o:2


p:0


q:0


r:1


s:4


t:4


u:0


v:0


w:0


x:0


y:1


z:0



a:2


b:0


c:1


d:2


e:0


f:1


g:0


h:2


i:0


j:0


k:1


l:0


m:1


n:0


o:2


p:0


q:0


r:3


s:0


t:0


u:1


v:0


w:1


x:0


y:0


z:0


解题思路:


这道题就是给你一个字符串,然后来统计以下在这个字符串中每个英文字母出现的次数,用一个数组去标记一下就可以了,最好用gets去读入字符串!!!


程序代码:  


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
  char a[100001];
  char c[27]="abcdefghijklmnopqrstuvwxyz";
  int len,i,b[27];
  while(gets(a)!=NULL)
  {
    memset(b,0,sizeof(b));
    len=strlen(a);
    for(int i=0;i<len;i++)
    {
      if(a[i]=='a')
        b[1]++;
      else if(a[i]=='b')
        b[2]++;
      else if(a[i]=='c')
        b[3]++;
      else if(a[i]=='d')
        b[4]++;
      else if(a[i]=='e')
        b[5]++;
      else if(a[i]=='f')
        b[6]++;
      else if(a[i]=='g')
        b[7]++;
      else if(a[i]=='h')
        b[8]++;
      else if(a[i]=='i')
        b[9]++;
      else if(a[i]=='j')
        b[10]++;
      else if(a[i]=='k')
        b[11]++;
      else if(a[i]=='l')
        b[12]++;
      else if(a[i]=='m')
        b[13]++;
      else if(a[i]=='n')
        b[14]++;
      else if(a[i]=='o')
        b[15]++;
      else if(a[i]=='p')
        b[16]++;
      else if(a[i]=='q')
        b[17]++;
      else if(a[i]=='r')
        b[18]++;
      else if(a[i]=='s')
        b[19]++;
      else if(a[i]=='t')
        b[20]++;
      else if(a[i]=='u')
        b[21]++;
      else if(a[i]=='v')
        b[22]++;
      else if(a[i]=='w')
        b[23]++;
      else if(a[i]=='x')
        b[24]++;
      else if(a[i]=='y')
        b[25]++;
      else if(a[i]=='z')
        b[26]++;
    }
    for(int i=1;i<=26;i++)
    {
      printf("%c:%d\n",c[i-1],b[i]);
    }
    printf("\n");
  }
  return 0;
}


相关文章
|
5月前
【题解】NowCoder BC149 简写单词
【题解】NowCoder BC149 简写单词
50 15
|
5月前
|
C语言
【C语言刷题每日一题#牛客网BC6】输入三个整数,输出第二个整数
【C语言刷题每日一题#牛客网BC6】输入三个整数,输出第二个整数
|
5月前
【题解】NowCoder AB5 点击消除
【题解】NowCoder AB5 点击消除
43 6
|
Java
HDU 1570 AC
HDU 1570 AC
39 0
华为机试HJ46:截取字符串
华为机试HJ46:截取字符串
华为机试HJ59:找出字符串中第一个只出现一次的字符
华为机试HJ59:找出字符串中第一个只出现一次的字符
华为机试HJ65:查找两个字符串a,b中的最长公共子串
华为机试HJ65:查找两个字符串a,b中的最长公共子串
华为机试HJ12:字符串反转
华为机试HJ12:字符串反转
每日一题---709. 转换成小写字母[力扣][Go]
每日一题---709. 转换成小写字母[力扣][Go]
每日一题---709. 转换成小写字母[力扣][Go]
|
Go 索引
每日一题---438. 找到字符串中所有字母异位词[力扣][Go]
每日一题---438. 找到字符串中所有字母异位词[力扣][Go]
每日一题---438. 找到字符串中所有字母异位词[力扣][Go]