HDU-1690,Bus System(弗洛伊德)

简介: HDU-1690,Bus System(弗洛伊德)

Problem Description:


Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.

The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

网络异常,图片无法展示
|





Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?

To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.


Input:


The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.

Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.

Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.

In all of the questions, the start point will be different from the destination.

For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.


Output:


For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.


Sample Input:


2


1 2 3 4 1 3 5 7


4 2


1 2 3 4


1 4


4 1


1 2 3 4 1 3 5 7


4 1


1


2


3


10


1 4


Sample Output:


Case 1:


The minimum cost between station 1 and station 4 is 3.


The minimum cost between station 4 and station 1 is 3.


Case 2:


Station 1 and station 4 are not attainable.


解题思路:


这道题其实就是个最短路的问题,用Floyd和Dijkstra都可以写,但是主要是数据的问题,之前用int,long long都一直过不去,后来改成了#define LL __int64才AC的,只能说还是自己太水了啊。。。下面我们看代码


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define LL __int64
const LL INF=1e18;
LL map[1001][1101],dis[1001];
int main()
{
  LL ans=1,l1,l2,l3,l4,c1,c2,c3,c4,n,m,v,t;
  cin>>t;
  while(t--)
  {
    cin>>l1>>l2>>l3>>l4>>c1>>c2>>c3>>c4;
    cin>>n>>m;
    for(LL i=1;i<=n;i++)
      cin>>dis[i];
    for(LL i=1;i<=n;i++)
    {
      for(LL j=1;j<=n;j++)
      {
        if(i==j)
          map[i][j]=0;
        else
        {
          LL cnt=abs(dis[i]-dis[j]);
          if(cnt>0&&cnt<=l1)
            v=c1;
          else if(cnt>l1&&cnt<=l2)
            v=c2;
          else if(cnt>l2&&cnt<=l3)
            v=c3;
          else if(cnt>l3&&cnt<=l4)
            v=c4;
          else
            v=INF;
          map[i][j]=map[j][i]=v;
        }
      }
    }
    for(LL k=1;k<=n;k++)
    {
      for(LL i=1;i<=n;i++)
      {
        for(LL j=1;j<=n;j++)
        {
          if(map[i][j]>(map[i][k]+map[k][j]))
            map[i][j]=map[i][k]+map[k][j];
        }
      }
    }
    printf("Case %d:\n",ans++);
    for(LL i=0;i<m;i++)
    {
      LL a,b;
      cin>>a>>b;
      if(map[a][b]==INF)
        printf("Station %I64d and station %I64d are not attainable.\n",a,b);
      else
        printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",a,b,map[a][b]);
    }
  }
  return 0;
}


相关文章
|
C++
【PAT甲级 - C++题解】1112 Stucked Keyboard
【PAT甲级 - C++题解】1112 Stucked Keyboard
59 0
|
C++
【PAT甲级 - C++题解】1129 Recommendation System
【PAT甲级 - C++题解】1129 Recommendation System
61 0
|
C++
【PAT甲级 - C++题解】1008 Elevator
【PAT甲级 - C++题解】1008 Elevator
56 0
初学算法之---pta 福到了
初学算法之---pta 福到了
|
C++
【PAT甲级 - C++题解】1011 World Cup Betting
【PAT甲级 - C++题解】1011 World Cup Betting
59 0
[转]POJ3624 Charm Bracelet(典型01背包问题)
来源:https://www.cnblogs.com/jinglecjy/p/5674796.html 题目链接:http://bailian.openjudge.cn/practice/4131/ Time Limit: 1000MS          Memory Limit: 65536K  ...
1236 0
洛谷 P1200 [USACO1.1]你的飞碟在这儿Your Ride Is He…【字符串+模拟】
P1200 [USACO1.1]你的飞碟在这儿Your Ride Is He… 题目描述 众所周知,在每一个彗星后都有一只UFO。这些UFO时常来收集地球上的忠诚支持者。不幸的是,他们的飞碟每次出行都只能带上一组支持者。
1621 0