HDOJ 2033 人见人爱A+B

简介: HDOJ 2033 人见人爱A+B

Problem Description

HDOJ上面已经有10来道A+B的题目了,相信这些题目曾经是大家的最爱,希望今天的这个A+B能给大家带来好运,也希望这个题目能唤起大家对ACM曾经的热爱。

这个题目的A和B不是简单的整数,而是两个时间,A和B 都是由3个整数组成,分别表示时分秒,比如,假设A为34 45 56,就表示A所表示的时间是34小时 45分钟 56秒。


Input

输入数据有多行组成,首先是一个整数N,表示测试实例的个数,然后是N行数据,每行有6个整数AH,AM,AS,BH,BM,BS,分别表示时间A和B所对应的时分秒。题目保证所有的数据合法。


Output

对于每个测试实例,输出A+B,每个输出结果也是由时分秒3部分组成,同时也要满足时间的规则(即:分和秒的取值范围在0~59),每个输出占一行,并且所有的部分都可以用32位整数表示。


Sample Input

2

1 2 3 4 5 6

34 45 56 12 23 34


Sample Output

5 7 9

47 9 30

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-->0){
            int aH = sc.nextInt();
            int aM = sc.nextInt();
            int aS = sc.nextInt();
            int bH = sc.nextInt();
            int bM = sc.nextInt();
            int bS = sc.nextInt();
            int cH,cM,cS;
            int m;
            cS = (aS+bS)%60;
            m=(aS+bS)/60;
            cM = (aM+bM+m)%60;
            m=(aM+bM+m)/60;
            cH = aH+bH+m;
            System.out.println(cH+" "+cM+" "+cS);
        }
    }
}
目录
相关文章
HDOJ 2056 Rectangles
HDOJ 2056 Rectangles
136 0
HDOJ 2034 人见人爱A-B
HDOJ 2034 人见人爱A-B
128 0
HDOJ 2019 数列有序!
HDOJ 2019 数列有序!
134 0
|
安全
HDOJ 2022 海选女主角
HDOJ 2022 海选女主角
155 0
|
人工智能 Java BI
HDOJ 1412 {A} + {B}
Problem Description 给你两个集合,要求{A} + {B}. 注:同一个集合中不会有两个相同的元素. Input 每组输入数据分为三行,第一行有两个数字n,m(0 < n,m marr[mid]) { System.
781 0