poj 2503 查字典

简介: Description You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language.

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

其实用cin输入输出也可以
map<T,T>dd;
以及gets(a)与sscanf(a,"%s",str)配合用法;
a为char a[45];
#include<cstdio>
#include<string>
#include<iostream>
#include<map>
using namespace std;

int main()
{    map<string,string>dic;
    char a[11],b[11];
    int i=0;
 char str[21];
    while(gets(str))
    {
      if(str[0]=='\0'){break;}
      sscanf(str,"%s %s",a,b);
     dic[b]=a;
    }
    char c[11];
 string qq;
    while(scanf("%s",c)!=EOF)
        {
             string s=c;
           qq=dic[s];
           if(qq.length()==0)cout<<"eh"<<endl;
           else cout<<qq<<endl;

        }

    return 0;
}

 

相关文章
|
3月前
POJ-2245-Lotto
POJ-2245-Lotto
17 0
POJ 1012 Joseph
Joseph Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 53862   Accepted: 20551 Description The Joseph's problem is notoriously known.
829 0
POJ 1067 取石子游戏
取石子游戏 Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 40917   Accepted: 13826 Description 有两堆石子,数量任意,可以不同。
1098 0
poj 1455
Description n participants of > sit around the table. Each minute one pair of neighbors can change their places.
611 0
poj 2299 求逆序数
http://poj.org/problem?id=2299 #include using namespace std; int aa[500010],bb[500010]; long long s=0; void merge(int l,int m,int r) { ...
779 0
POJ 2487 Stamps
Description Background Everybody hates Raymond. He’s the largest stamp collector on planet earth and because of that he always makes fun of all the others at the stamp collector parties.
1051 0
|
机器学习/深度学习
|
测试技术