最大乘积(Maximum Product,UVA 11059)

简介: Problem D - Maximum Product Time Limit: 1 second   Given a sequence of integers S = {S1, S2, .

 

Problem D - Maximum Product

Time Limit: 1 second

 

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms ofS. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each elementSi is an integer such that-10 ≤ Si ≤ 10. Next line will haveN integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., whereM is the number of the test case, starting from1, andP is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.



 

#include <stdio.h>
#include <set>

using namespace std;

int main(){
	int n;
	int * val = NULL;
	set<long long> s;
	while((scanf("%d",&n) == 1) && n != 0){
		val =  new int[n];
		int i = 0;
		for (;i  < n; i++) {
			scanf("%d",&val[i]);
		}
		s.clear();
		int j ;
		for(i = 0;i < n -1;i++){	//枚举起点

			for (j = i; j < n; ++j) {//枚举终点
				int k;long long ji = 1;
				for(k = i; k <= j;k++){
					ji *= val[k];
				}
				s.insert(ji);
			}

		}

		long long max = *(s.rbegin());
		if(max > 0){
			printf("%ld\n",max);
		}
		else{
			printf("0\n");
		}
                delete val;
        }


	return 0;

}


 



 

目录
相关文章
UVa787 - Maximum Sub-sequence Product(最大连续乘积子串)
UVa787 - Maximum Sub-sequence Product(最大连续乘积子串)
47 0
LeetCode 152. Maximum Product Subarray
给定一个整数数组 nums ,找出一个序列中乘积最大的连续子序列(该序列至少包含一个数)。
47 0
LeetCode 152. Maximum Product Subarray
|
人工智能
HDOJ/HDU 2710 Max Factor(素数快速筛选~)
HDOJ/HDU 2710 Max Factor(素数快速筛选~)
104 0
ZOJ Problem Set - 3758 素数
ZOJ Problem Set - 3758 素数
99 0
|
Java 数据安全/隐私保护
[LintCode] Number of Islands(岛屿个数)
描述 给一个01矩阵,求不同的岛屿的个数。 0代表海,1代表岛,如果两个1相邻,那么这两个1属于同一个岛。我们只考虑上下左右为相邻。 样例 在矩阵: [ [1, 1, 0, 0, 0], [0, 1, 0, 0, 1], [0, 0, 0, 1, 1], [0, 0, 0, 0, 0], [0, 0, 0, 0, 1] ] 中有 3 个岛。
1249 0
|
人工智能 机器学习/深度学习