1019. General Palindromic Number (20)

简介: A number that will be the same when it is written forwards or backwards is known as a Palindromic Number.

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1

分析:

(1)给定一个十进制数n 给定一个进制d

(2)判断n在d进制下是否回文

(3)逆序输出n在d进制下的每一位

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int n, d, len = 0, flag = 1;
    scanf("%d %d", &n, &d);
    
    int s[100];
    //将n转换为d进制
    while (n) {
        s[len++] = n % d;
        n /= d;
    }
    for (int i = 0; i < len / 2; i++) {
        if (s[i] != s[len - i - 1]) {
            flag = 0;
            break;
        }
    }
    
    if (flag) {
        printf("Yes\n");
    }else{
        printf("No\n");
    }
    
    for (int i = len - 1; i >= 0; i--) {
        printf("%d", s[i]);
        if(i != 0) printf(" ");
    }
    if (len == 0) {
        printf("0");
    }
    cout << endl;
    
    return 0;
}


目录
相关文章
完美解决Non-terminating decimal expansion; no exact representable decimal result.异常
完美解决Non-terminating decimal expansion; no exact representable decimal result.异常
23507 0
完美解决Non-terminating decimal expansion; no exact representable decimal result.异常
|
JSON 数据格式
遇到【Unexpected character (‘“‘ (code 34)): was expecting comma to separate Object entries】的解决办法
遇到【Unexpected character (‘“‘ (code 34)): was expecting comma to separate Object entries】的解决办法
遇到【Unexpected character (‘“‘ (code 34)): was expecting comma to separate Object entries】的解决办法
|
Windows
Illegal character in opaque part at index
Illegal character in opaque part at index
|
IDE 开发工具
C - error: converting to execution character set:Illegal byte sequence
C - error: converting to execution character set:Illegal byte sequence
1292 0
C - error: converting to execution character set:Illegal byte sequence
成功解决ValueError: Number of passed names did not match number of header fields in the file
成功解决ValueError: Number of passed names did not match number of header fields in the file
|
C++
PAT (Advanced Level) Practice - 1038 Recover the Smallest Number(30 分)
PAT (Advanced Level) Practice - 1038 Recover the Smallest Number(30 分)
124 0
PAT (Advanced Level) Practice - 1082 Read Number in Chinese(25 分)
PAT (Advanced Level) Practice - 1082 Read Number in Chinese(25 分)
101 0
【1019】General Palindromic Number (20 分)
【1019】General Palindromic Number (20 分) 【1019】General Palindromic Number (20 分)
95 0
成功解决ValueError: Parameter values for parameter (n_estimators) need to be a sequence.
成功解决ValueError: Parameter values for parameter (n_estimators) need to be a sequence.
成功解决ValueError: Parameter values for parameter (n_estimators) need to be a sequence.
成功解决TypeError: Value passed to parameter 'paddings' has DataType float32 not in list of allowed valu
成功解决TypeError: Value passed to parameter 'paddings' has DataType float32 not in list of allowed valu